PG protection off in the "Limited Account"

Discussion in 'ProcessGuard' started by Stupor, Feb 14, 2005.

Thread Status:
Not open for further replies.
  1. Stupor

    Stupor Guest

    After creating a "limited" user account in WinXP SP2, I realize that the protection checkmark for the PG is toggled off with the following error message, "Check dcsuserprot.exe". In the admin account, no such error arises. I should also mention that I have subsequently elevated this limited account to the full permission status with regards to PG. But it still renders useless to no avail. Any thoughts or comments would be appreciated.
     
  2. Gavin - DiamondCS

    Gavin - DiamondCS Former DCS Moderator

    Joined:
    Feb 10, 2002
    Posts:
    2,080
    Location:
    Perth, Western Australia
    Hi,

    Just dont try to run PG in that account. You can only configure protection from within ADMIN accounts. Execute a new program in the limited account and you will see that you DO get execution alerts, you are still protected
     
  3. earth1

    earth1 Registered Member

    Joined:
    Oct 17, 2004
    Posts:
    177
    Location:
    Kansas, USA
    I'm not certain about the message, "Check dcsuserprot.exe". I was getting stuck at "Initializing" as the status. Try starting procguard.exe using a shortcut with "Run as different user" checked, so that procguard.exe can run as Administrator. For more detail, see this thread.

    HTH
     
  4. tlu

    tlu Guest

    Gavin, it's no problem using the runas command.
     
  5. war59312

    war59312 Registered Member

    Joined:
    Nov 30, 2002
    Posts:
    72
    Location:
    U.S.A
    This should work too:

    "%windir%\system32\runas.exe /savecred /user:Computername\administrator "%programfiles%\ProcessGuard\procguard.exe""
     
  6. tlu

    tlu Guest

    Yes, the /savecred parameter works only under the WinXP Pro version, not under Home, though.
     
Thread Status:
Not open for further replies.