PG Default Browser Launch - How Do I Change It?

Discussion in 'ProcessGuard' started by chicagostonepro, Aug 16, 2006.

Thread Status:
Not open for further replies.
  1. chicagostonepro

    chicagostonepro Registered Member

    Joined:
    Aug 16, 2006
    Posts:
    4
    When I let ProcessGuard (v3.410) connect out for file info on an executeable, it launches Internet Explorer.

    That sucks. Especially since the PG UI is only active in the Administrator account.

    I've looked, but haven't found any documentation regarding changing this. I'm using Firefox 1.5.0.6, would like to set PG to launch that, instead. Hell, I like Opera too, if that works better with PG, I'll install Opera again.

    WinXP, SP2. PG is full license, home use, all computers.

    I just upgraded PG from 3.15.

    TIA
     
  2. some made up name

    some made up name Registered Member

    Joined:
    Jan 31, 2006
    Posts:
    60
    to get PG to launch a browser other than IE, make sure that is you default browser (ie. when you open a local html file firefox/opera should be opening it). usually the browser 'complains' that it isn't the default and asks if you want to make it the default.

    as for the administrator account thing ... look at the browsers properties in procexplorer and compare it to one opened manually ... you should see that the browser spawned by PG has practically no privilges at all.
     
  3. chicagostonepro

    chicagostonepro Registered Member

    Joined:
    Aug 16, 2006
    Posts:
    4
    Yup, that did it. I forgot to set Firefox as default in the administrator account. Thank you for the heads up.

    The issue of the Admin account is that it's a vulnerable position from which to connect out, so it's simply good practice to not use IE, even hardened, from an Admin account.

    Thanks again!
     
Thread Status:
Not open for further replies.