PG and FolderGuard

Discussion in 'ProcessGuard' started by rdsu, Jan 31, 2005.

Thread Status:
Not open for further replies.
  1. rdsu

    rdsu Registered Member

    Joined:
    Jun 28, 2003
    Posts:
    4,456
    Hi,

    I don't know why, but about 2 months ago that I can't use the FolderGuard and it's seems that it's because of ProcessGuard...

    I want to know if someone use this 2 programs together?

    If they are incompatible, can you suggest some good program like FolderGuard?

    Thanks
     
  2. Bowserman

    Bowserman Infrequent Poster

    Joined:
    Apr 15, 2003
    Posts:
    510
    Location:
    South Australia
    Hi VaMPiRiC_CRoW :).

    When you say that you can't use FolderGuard, what exactly is happening? I will download the trial in a moment and see if it needs any special allowances in ProcessGuard, but it would help to know what the specific problem/s are that you are encountering. And if we can sort it out, then I will add the necessary allowances to the ProcessGuard Application Database.

    Regards,
    Jade.
     
  3. rdsu

    rdsu Registered Member

    Joined:
    Jun 28, 2003
    Posts:
    4,456
    Hi Bowserman,

    I can install the FolderGuard, but when I reboot the windows, I don't have Internet and the ProcessGuard doesn't load correctly. The main window of ProcessGuard only shows the Main tab but I can't set nothing... Finally I can't make a normal windows reboot or shutdown.

    Click on reset or power down, enter on safe mode and uninstall the FolderGuard...

    Regards
     
  4. Bowserman

    Bowserman Infrequent Poster

    Joined:
    Apr 15, 2003
    Posts:
    510
    Location:
    South Australia
    Been testing this here and so far so good. Did you put ProcessGuard in Learning Mode while installing and keep it in Learning Mode?

    In my testing so far, FGuard.exe needs to be allowed to install a driver/service (driver in fact) and to create a hook ( global Call Wndproc Return hook).
    Also, when FolderGuard is configured to run at startup, rundll32.exe now tries to create a global Call Wndproc Return hook and global GetMessage hook upon startup (also tries this after performing various tasks in FolderGuard), but I have not allowed rundll32.exe to install hooks in ProcessGuard yet and have encoutered no problems upon startup and while running FolderGuard.

    After the installation of FolderGuard, be sure to check all the options under PERMISSIONS, MODIFY USER LIST, TRUSTED PROGRAMS and SETTINGS. You may have input some conflicting settings in a previous installation of FolderGuard that are being remembered upon re-installation.


    Hopefully, my testing this far gives you a few thing to try to see if you can find the problem :). Anyway, I'm off to bed and will check back tomorrow.


    Regards,
    Jade.
     
  5. Bowserman

    Bowserman Infrequent Poster

    Joined:
    Apr 15, 2003
    Posts:
    510
    Location:
    South Australia
    One more thing. Have you disabled the protection for ProcessGuard and then installed FolderGuard and tried rebooting?...problem still there? If so, then it it is not ProcessGuard causing the problem after all.

    Regards,
    Jade.
     
  6. rdsu

    rdsu Registered Member

    Joined:
    Jun 28, 2003
    Posts:
    4,456
    I disabled the PG while installed FG, and the problem still there...

    Maybe I did something in the past that cause this...

    I've to make a clean windows install when I had some time...

    Thanks for you help Bowserman ;)

    Best Regards
     
  7. Bowserman

    Bowserman Infrequent Poster

    Joined:
    Apr 15, 2003
    Posts:
    510
    Location:
    South Australia
    No problem VaMPiRiC_CRoW, glad I could help :).

    Regards,
    Jade.
     
  8. rdsu

    rdsu Registered Member

    Joined:
    Jun 28, 2003
    Posts:
    4,456
    After I make a clean windows install, I already don't have the problem with FolderGuard and ProcessGuard :)

    Regards
     
Thread Status:
Not open for further replies.