Perte de DNS

Discussion in 'LnS French Forum' started by parorun, May 18, 2004.

Thread Status:
Not open for further replies.
  1. parorun

    parorun Guest

    Je n'ai rien trouvé de concluant sur les autres threads :

    Je suis chez OOL en ADSL 128 (opérateur des Départements d'Outre Mer = HORS DE PRIX), aucun (?) rapport avec AOL.
    XPpro sp2
    Athlon 2000+
    Bewan USBst
    512Mo RAM
    LNS 2.04p2, Lns 2.05 finale.

    Problème : perte d'accès au DNS : la connexion est active mais rien ne passe. Pas de message dans la console de LnS.
    La déconnexion ne permet pas la reconnexion.
    Quitter LnS ne change rien.
    Avec firewall PC-Cillin : pas de problème (oui je sais, pas solution non plus).

    Nécessité d'un reboot pour pouvoir se reconnecter, sinon :
    <erreur 1450 : Ressources système insuffisantes pour terminer le servixe demandé.>

    Comme je suis têtu, essai 2 :

    <erreur 734 : protocole PPP a été arrêté>

    Mais en plus je suis bourrin, essai 3 :

    <TCP/IP rapporte l'erreur 31 : Un prériphérique attaché au système ne fontionne pas correctement>

    Bon là je reboot. Et hop je me connecte. Puis je perd la connexion. Je deviens fou.

    Je regarde l'Observateur d'Evenements et je confirme que :
    L'agent proxy DNS a rencontré une erreur lors de l'obtention de la liste locale des serveurs de résolution de noms. Des serveurs DNS ou WINS peuvent être inaccessibles aux clients sur le réseau local. La donnée est le code de l'erreur.

    J'ai cru que c'était le modem USB et les chipsets VIA, mais non, à mon grand regret c'est LnS.

    Pourtant ça a marché pendant un temps... Peut-être qu'OOL a changé quelque chose dans leur protocole ?

    Dans se cas comment identifier (sachant que leur Hot-Line payante ne répond pas) ce changement ?

    Je ne suis pas trop chaud pour intégrer les règles "Club Internet" sans savoir où je vais...

    Si j'ai manqué un thread sur le sujet excusez-moi...
     
  2. gkweb

    gkweb Expert Firewall Tester

    Joined:
    Aug 29, 2003
    Posts:
    1,932
    Location:
    FRANCE, Rouen (76)
    Bonjour parorun,

    tu nous dit "L'agent proxy DNS a rencontré une erreur", tu utilises donc un programme particulier ?

    Sous windows 2000 et XP, il y a un service windows "Client DNS" que tu peut utiliser ou pas, mais si tu l'utilise il faut lui donner accès au net.

    D'après ce que tu nous dit, il n'y a rien de loggué dans le journal ?

    Le seul truc que je vois, c'est que tu as probablement bloqué ce fameux "agent proxy DNS" dans le filtrage logiciel, donc il ne peut pas acceder au réseau, et si tu as laissé les options par défaut, rien n'est loggué quand ce programme est bloqué.

    Si tu retrouve le nom de l'exe de ce prog particulier, enleves le de la liste du filtrage logiciel, et quand Look'n'Stop te demande d'autoriser ou non l'accès à Internet pour celui ci, repond "oui toujours" ca devrait régler ton problème.

    gkweb.
     
  3. parorun

    parorun Guest

    gkweb, merci pour ta réponse, mais malheureusement il n'ya aucune interdiction d'aucune sorte dans ma liste logicielle ! Même Explorer n'a pas essayé de se connecter depuis ma réinstallation.

    Non, je pense que le proxy DNS est le client DNS ou une appellation d'un de ses modules. Mais je ne suis absolument pas qualifié pour l'affirmer.

    De plus, si j'interdisait à un service DNS de franchir le firewall, je ne pourrait pas du tout surfer... Or là, il s'agit d'un plantage de connexion au bout d'un certain temps. Même une connection à une IP ne fonctionne pas... pas de ping, rien... les downloads en cours stoppent... mais la connexion est toujours détectée comme active par Windoze.

    Le truc affreux, c'est que l'acceptation des règles Club Internet (ben oui j'ai testé quand même) a résolu le problème de stabilité de la connexion. Mais le journal s'est vidé du même coup !!! Et je suis méfiant sur les conséquences d'accepter une règle d'autorisation "au sommet", surtout quand elle vide le journal de rapports légitimes sur des connexions non-autorisées par les règles intermédiaires.
    Je n'ai plus de "bloquer tout le reste" ! La liste reste vide...

    Alors, OK, je veux bien croire que OOL ait changé son protocole et utilise des packets fragmentés... Mais pourquoi ça plante la connection de ne pas les accepter ? Car on arrive bien à un plantage logiciel qui, fait rare sous XP, ne peut être résolu sans rebooter !!!

    J'adore LnS parcequ'il permet de comprendre ce que l'on fait. Mais là, je ne comprend plus !

    Merci pour votre intérêt !
     
  4. gkweb

    gkweb Expert Firewall Tester

    Joined:
    Aug 29, 2003
    Posts:
    1,932
    Location:
    FRANCE, Rouen (76)
    Plusieurs FAI passent aux paquets fragmentés, je suppose que le but est d'assurer un meilleur tps de réponse, car des paquets plus petits arrivent plus vite, et permet aux utilisateurs probablement de se connecter plus rapidement.

    Donc la règle "club-internet" pourrait etre renommé en "FAI paquets-fragmentés" :)

    Ca plante la connexion de bloquer ces paquets car ce sont probablement ceux
    qui te servent à communiquer avec les serveurs de ton FAI.
    Un FAI normalement test si tu es toujours en ligne tous les X intervalles de temps, si tu ne répond pas, pour lui tu es deconnecté donc tu perd ta connexion.
    Après il est possible que comme la "deconnexion" ne se soit pas fait proprement (ton Windows n'est pas "au courant") cela occasione des problèmes comme tu as eu.

    Pour moi il n'y a pas a chercher plus loin, tu avais besoin d'autoriser les paquets fragmentés, et maintenant ta connexion marche.

    Si tu veux être sûr que tu es bien sécurisé tu peut faire des tests de scan en ligne comme GRG ou Symantec.

    gkweb.
     
  5. Pac

    Pac Guest

    Salut,

    J'ai exactement le meme souci que decrit ci-dessus : des perte de la connexion, impossible de me reconnecter (erreur 31 sur TCP/IP) et je suis oblige de faire un reboot de XP pour me reconnecter...c'est depuis que je suis passe au 9, avant sous tele2 ca marchait nickel...bon j'ai aussi upgrade mon firewall outpost...
    Quels sont "les regles de Club Internet" decrits ci-dessus? peut-etre s'appliquent-elles au 9 aussi??

    merci
     
  6. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Ces règles autorisent les paquets fragmentés utilisés par certains fournisseurs.
    Ce n'était pas le problème du thread d'origine je pense, mais vous pouvez essayer dans votre cas. Ces règles sont importables depuis ici:
    http://www.looknstop.com/Fr/rules/rules.htm#ClubInternet

    Frédéric
     
Thread Status:
Not open for further replies.