Permission for programs trough ESS and VPN

Discussion in 'ESET Smart Security' started by AlexGer, Apr 30, 2010.

Thread Status:
Not open for further replies.
  1. AlexGer

    AlexGer Registered Member

    Joined:
    Apr 30, 2010
    Posts:
    2
    Location:
    Germany
    Hello guys,

    I've got a problem and got the hope that someone can help me.
    I'm using ESS and I'm very happy with it but now I've got some prgrams from my company who need to be tunneled trough a VPN to a server, and there start the problems.
    Tunneling and activating the VPN works, working with the programs too but if the VPN gets disconnected (Say hello to Mr WiFi) theres a policy which says I'm not allowed to proceed with working trough an unsecure connection.

    Now I want to configure my ESS Firewall to only let the programms stay connected when the VPN connection is active but I didn't got a clue how to perform this task...
    I tried with Zones and Rules but the programm instantly switches over to my unsecure connection if the VPN disconnects.

    Do you guys got any idea how to solve this problem?

    The only information I've got for the VPN is my Login, Password, Login Server and DNS/Gateway Server (I think, the one you see in the tab "details" is you click on status of the VPN)

    Sorry for my bad english (If it's bad ^^) and for my, lets say, stupid question, I'm still just a trainee IT Specialist
     
  2. Cudni

    Cudni Global Moderator

    Joined:
    May 24, 2009
    Posts:
    6,956
    Location:
    Somethingshire
    What OS and any particular wifi software also running (like Intel or Atheros etc)? Thinking you might use those to block/control/allow connections somehow. Although if your VPN drops you stop working, reconnect and continue if all else fails
     
  3. AlexGer

    AlexGer Registered Member

    Joined:
    Apr 30, 2010
    Posts:
    2
    Location:
    Germany
    I'm running XP Home and on my other pc Win7 Ultimate,
    WiFi software, don't know, both are Atheros adapters which just needed the driver to be installed
     
Thread Status:
Not open for further replies.