Outpost Firewall Pro 2009 (6.7 2954.446.0710) Released on 21 july 2009

Discussion in 'other firewalls' started by mack_guy911, Jul 21, 2009.

Thread Status:
Not open for further replies.
  1. mack_guy911

    mack_guy911 Registered Member

    Joined:
    Mar 21, 2007
    Posts:
    2,677
    Outpost Firewall Pro History of changes
    Outpost Firewall Pro 2009 (6.7 2954.446.0710)
    Release date: 21 july 2009
    What's new:
    Windows 7 beta-support
    Anti-Spyware engine improved
    The following improvements are introduced:
    Improved content filtering performance
    The following issues are resolved (only significant ones are listed):
    Issues with Heuristic analysis
    Issues with configuration after computer infection
    Self-protection exclusions list was not preserved under Windows Vista
    Issues after Windows Vista SP1 loading, including:
    Services were not started
    Strange windows behavior
    Slow startup
    Several most commonly reported crashes, including:
    Possible crash in case of insufficient memory;
    Possible crash while scrolling through the Host Protection components list
    Several most commonly reported freezes, including:
    Possible freeze on scrolling the applications list
    Possible freeze on UAC dialog display
    Some visual notifications could be displayed in Entertainment Mode
    Possible problems with ICS (packets could be blocked)
    Possible problems with drivers installation
    Possible compatibility issues with KAV/KIS
    High CPU load in case of working with Lingvo X3
    Hosts file modification could not sometimes be detected
    Adding Windows/System32 folder to exclusions did not work
    Rules for EMULE.EXE were not applied
    Issues while receiving mail using The Bat!
    Incredimail could crash on mail receiving
    Rawsocket rules did not work correctly
    Content filtering rules did not work for mtorrent.exe
    Port scanning false positives on detecting UDP packet to the closed port from DNS server
    Some printer functions did not work if Outpost was installed on a computer
    Outpost could cause GUI freeze under Windows Vista 64
    Internet Explorer could crash on trying to change site properties using Quick Tune plug-in
    No Quick Tune plug-in in Internet Explorer on x64 platforms
    Update settings did not work correctly
    Registry key [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager] "BootExecute" was not protected
    Incompatibility with Jaws application
    Outpost service could not start with enabled UAC
    Windows Firewall could not sometimes be disabled after Outpost installation
    Incoming NetBIOS connections were blocked even if NetBIOS check box in LAN settings was selected
    By default content is not filtered for loopback address anymore
    Music could not be played from imeem.com with Outpost installed
    RPC DCOM attack could not be detected
    Outpost could not sometimes detect driver load
    Outpost could detect Norton Antivirus after its uninstallation
    Incoming connections could be successfully established in case of blocking policy
    Transit packets were blocked on attempt to open web pages on VMWare
    More minor issues
     
  2. c2d

    c2d Registered Member

    Joined:
    Sep 26, 2007
    Posts:
    570
    Location:
    Bosnia
    thanks mack_guy911 :thumb:
     
  3. Antarctica

    Antarctica Registered Member

    Joined:
    Feb 25, 2003
    Posts:
    1,617
    Location:
    Canada
    Thanks.Gee, lots of bug fixes.:)
     
  4. G1111

    G1111 Registered Member

    Joined:
    May 11, 2005
    Posts:
    2,127
    Location:
    USA
    Last edited: Jul 21, 2009
  5. mack_guy911

    mack_guy911 Registered Member

    Joined:
    Mar 21, 2007
    Posts:
    2,677
    yea true it work great with KIS 2010 without firewall good working without trouble
     
  6. s23

    s23 Registered Member

    Joined:
    Feb 22, 2009
    Posts:
    263
    All problems i'm havin with Outpost corrected in this version (mainly the DNS false portscan). It feel more smooth too. Very good.
     
  7. mvdu

    mvdu Registered Member

    Joined:
    Oct 14, 2003
    Posts:
    1,151
    Location:
    PA
    Still problems with Avira's WebGuard. Reported it at their forums. I'd have to go back to the previous version, which was fine. To me, this is the worst version yet.
     
  8. hany3

    hany3 Registered Member

    Joined:
    Dec 2, 2007
    Posts:
    207
    the bad news is that there is still no option to disable the news download
    just wondering if agnitum still insists on such advertizing behaviour in a product that is supposed to be a paid one
     
  9. BerserkerPup

    BerserkerPup Registered Member

    Joined:
    Dec 2, 2003
    Posts:
    61
    Location:
    New Jersey USA
    Thanks for posting what changed in this update. :)
     
  10. hayc59

    hayc59 Updates Team

    Joined:
    Oct 29, 2008
    Posts:
    2,132
    Location:
    R.I.P. Roger(roddy32)
    hany its being worked on and you know very well
    that there is a work around! use it or wait for the update
    that will change your whole world!! o_O :gack:
     
  11. hany3

    hany3 Registered Member

    Joined:
    Dec 2, 2007
    Posts:
    207
    and agnitum knows very well about this issue


    it's not abug that should remains for years to be fixed it's an advertizing approach intetionally made agnitum
    in fact if they had wanted to remove this advertizing , they would have done this moths ago "Third Conditional":D coz it's difficult to happen

    the adware behavior in a security software does NOT need what u call "a work a round " from the public it needs curative , complete and FAST interference from the vendor
    it must be abasic approach or a strategy for the developper company rather than "a work around" from the public "some instructions and changed files in the installtion directory of the firewall made by some persons who are non-developpers , i never do that and never take this risk as it may add some bugs or crashes to the product and could even affect the overall security performance of outpost

    my world is very nice
    but unfortunately sometime the man wrongly thought that he could change the outside world making it better but invain
     
    Last edited: Jul 22, 2009
  12. Ro4dRuNn3r

    Ro4dRuNn3r Guest

    Does somebody know more about it? o_O
     
  13. FirePost

    FirePost Registered Member

    Joined:
    Jul 29, 2005
    Posts:
    212
    The news issue was not addressed in this release. Agnitum are aware some people dislike it. There are threads where it is debated. This should not be added to them.
     
  14. mvdu

    mvdu Registered Member

    Joined:
    Oct 14, 2003
    Posts:
    1,151
    Location:
    PA
    The problem I'm having is with Avira's WebGuard. I uninstalled WebGuard and have internet. But I think the new Outpost is designed this way, unfortunately. It's possibly an inconvienence and not a bug.
     
  15. Toby75

    Toby75 Registered Member

    Joined:
    Mar 10, 2006
    Posts:
    480
    Anyone using Outpost Pro having problems updating? My last spyware database update was 8/14. o_O
     
  16. firzen771

    firzen771 Registered Member

    Joined:
    Oct 29, 2007
    Posts:
    4,815
    Location:
    Canada
    i dont even bother installing Outpost AS since i have an AV already so i wuldnt know :doubt:
     
  17. chrisretusn

    chrisretusn Registered Member

    Joined:
    Jun 16, 2004
    Posts:
    1,322
    Location:
    Philippines
    No problems, last update 18 Aug 2009 1000 PST, just now manually did an update 20 Aug 2009 @ 0618 PST Malware database dated 19 Aug 2009, 1925743 signatures.
     
  18. chrisretusn

    chrisretusn Registered Member

    Joined:
    Jun 16, 2004
    Posts:
    1,322
    Location:
    Philippines
    That is an older version, current is Version: 6.7 (2957.446.0711) Release date: July 27, 2009

    Agnitum Outpost Security Suite History of Changes

    Outpost Firewall PRO History of Changes
     
  19. kjdemuth

    kjdemuth Registered Member

    Joined:
    Jul 29, 2005
    Posts:
    2,960
    Location:
    Boston, MA
    What scan engine does the Outpost suite use?
     
  20. Toby75

    Toby75 Registered Member

    Joined:
    Mar 10, 2006
    Posts:
    480
    Are you using the Suite or the Pro version?

    EDIT: Seems others are having the problem as well:
    http://www.outpostfirewall.com/forum/showthread.php?t=24505
     
  21. firzen771

    firzen771 Registered Member

    Joined:
    Oct 29, 2007
    Posts:
    4,815
    Location:
    Canada
    VirusBuster i believe
     
  22. Dr payne

    Dr payne Guest

    I would like a professional opinion instead of some random comments spewing.
     
  23. thathagat

    thathagat Guest

    virusbuster and Agnitum’s own spyware, worm, adware and other snoop-ware intelligence.....
    here from Agnitum’s site
     
  24. Toby75

    Toby75 Registered Member

    Joined:
    Mar 10, 2006
    Posts:
    480
    Well..firzen771's "opinion" is correct.
     
  25. chrisretusn

    chrisretusn Registered Member

    Joined:
    Jun 16, 2004
    Posts:
    1,322
    Location:
    Philippines
    Now that was a right friendly and professional comment. :rolleyes:

    It uses VirusBuster. See this Agnitum KB Article.
     
Loading...
Thread Status:
Not open for further replies.