Outpost 2009 packet drop problem

Discussion in 'other firewalls' started by pandlouk, Apr 4, 2009.

Thread Status:
Not open for further replies.
  1. pandlouk

    pandlouk Registered Member

    Joined:
    Jul 15, 2007
    Posts:
    2,559
    Hi guys,

    I have a problem with OSS 2009. Similar to OPFW 2009 and Internet Download Manager
    Already contacted the support on 17/3/2009 but since they have not provided any solution yet, I thought to post the problem here too just in case someone has a similar problem or an idea about a solution.

    When I try to download something with firefox (or with the "download them all" firefox addon) the download starts but after some seconds it stops. It does not happen always but most of the times it does.
    It happens also with other programs (for example when I try to update the list of the usenet servers with newsrover the update cannot complete unless I manually stop it and restart it 3-4 times). Even the windows update stops and it does not reasume the download, unless I disable it and reanable it.
    And the biggest problem is that I cannot troubleshoot it because the logs do not display anything blocked (both IP4/IP6 and lowlevel loging are set to the maximum).

    I tried everything, disabled all the components, editing the ini with the settings, manually uninstalled the outpost firewall driver from the network connection settings tab,etc. But still the problem exists.
    Then I manually unloaded one by one the agnitum drivers and I'm sure that this bug is caused by either "afw.sys" or "afwcore.sys" drivers (are responsible for packet filtering).
    Everything else browsing, voip, vpn, p2p, works fine. And in virtual machines I cannot replicate it. :( o_O

    Anyone else experiences similar problems?
    Any ideas on how to further troubleshoot it?

    ps.I could easily find what is going on and report it to agnitum, if I had another computer to use as a gateway, but unfortunatly I don't.

    thanks,
    Panagiotis
     
  2. G1111

    G1111 Registered Member

    Joined:
    May 11, 2005
    Posts:
    2,127
    Location:
    USA
    For Firefox check to see: Type about:config in the address bar. Scroll down to xpinstall.enabled. Double click it to change the value from false to true. If it already set for true I would try uninstalling Outpost and do a clean install allowing Outpost to create the rules.
     
  3. pandlouk

    pandlouk Registered Member

    Joined:
    Jul 15, 2007
    Posts:
    2,559
    Thanks G1111,

    - I checked and is not a problem with the firefox and XPInstall.
    -Already done that. It happens even with a fresh install of OSS and having it on learning mode or in allow all mode.

    Argh!! It happens even when I use custom allow net rules that override the application rules. :'(
    Probably a bug in the http and ftp filters of the drivers.

    Panagiotis
     
  4. G1111

    G1111 Registered Member

    Joined:
    May 11, 2005
    Posts:
    2,127
    Location:
    USA
    The only other thing I can suggest is post on the Outpost forum. I have been an Outpost user for several years. Outside of some past conflicts with Kaspersky I have not experienced your problem.
     
  5. pandlouk

    pandlouk Registered Member

    Joined:
    Jul 15, 2007
    Posts:
    2,559
    I had the same thought initially and registered there but the site will not let me post or even edit my account (says something about waiting for activation from the administrators).
    Then I decided to post it here, hoping that someone else besides me and MrGSM has the same problems (it would help identifying the conflict).
    Maybe it has to do with the drivers of my NIC.

    Panagiotis
     
  6. hayc59

    hayc59 Updates Team

    Joined:
    Oct 29, 2008
    Posts:
    2,132
    Location:
    R.I.P. Roger(roddy32)
    Pandlouk, as far as registering it goes through that
    procedure because of so much spam lately from
    folks with nothing better to do than cause mayhem!
    If you have troubles pm me and I can see what I can do :)
     
  7. pandlouk

    pandlouk Registered Member

    Joined:
    Jul 15, 2007
    Posts:
    2,559
    Thanks GiddyUp,

    I figured that something like that was the reason.
    Sorry for not being able to post earlier but I was away from home for the last month.

    I am in contact with agnitum support about this problem, but for the moment the only solutions are:
    1st solution. Modify the "C:\Program Files\Agnitum\Outpost Security Suite Pro (or Outpost
    > Firewall Pro)\machine.ini" and change 'EnableContentHandler' to 'FALSE'.
    2nd solution. Or do not modify anything in the 'machine.ini' and instead go to "Settings > Application rules" select the program that gives you the problem (in my case firefox) and 'disable content filtering' for that application.

    ps. the support also asked me to test the 'EnableContentProcessing' of the machine.ini and changing it to 'FALSE' but it does not resolve the problem.


    Panagiotis
     
  8. hany3

    hany3 Registered Member

    Joined:
    Dec 2, 2007
    Posts:
    207
    hi pandlouk
    if u do to the thread u referred to in outpost forum
    u see my post in the second position
    in fact we did many many threads in the outpost forum , and sent alot of mails to the agnitum support

    the problem is that they completely deny the presence of any bug in the content filtering


    when u are downloading using the download manager , u feel as if the download is throttled by the content filtering , the speed counters of IDM freeze frequently for asecond
    i remeber once i downloaded a movie 700 mb then a found the file corrupted due to may be dropped packets or whatever bug in the buggy content filtering


    after 2 years of sending emails about these bugs in the content filtering , the only response from agintum was that they gave the user an option to deny the installation of content filtering at outpost setup , i know this is an analgesic solution like aspirin , but it's food that they finally realized that many users suffered alot from the content filtering

    not to mention the spyware behaviour in downloading the agnitum new even if the user don't like this

    many of as know that outpost 2009 is a revloutional product in the firewall software world but unfortunately there is nothing 100% perfect
     
  9. hany3

    hany3 Registered Member

    Joined:
    Dec 2, 2007
    Posts:
    207
    the solution is simple by disabling teh content filtering

    1- by editing the machine.ini

    or

    2-set the rule for firefox or any download client to disable content filtering

    or

    3-from the begining at outpost setup , don't choose to install web control


    because the problem is simply due to uncerrectable bugs in the content filtering module of outpost
     
Loading...
Thread Status:
Not open for further replies.