OSS does not detect OpenSUSE

Discussion in 'Acronis Disk Director Suite' started by Maal656, Jun 14, 2007.

Thread Status:
Not open for further replies.
  1. Maal656

    Maal656 Registered Member

    Joined:
    Apr 16, 2007
    Posts:
    8
    I have the following HD configuration:

    * Partition 1 - Ext3 (Not used)
    * Partition 2 - NTFS - Windows Vista installed on it.
    * Partition 3 - NTFS - Windows XP installed on it
    * Partition 4 - Extended partition:
    - Partition 5 - FAT 32 - Data
    - Partition 6 - SWAP - Linux Swap
    - Partition 7 - Ext3 - \ for OPENSUSE
    - Partition 8 - Ext3 - To test another Linux...
    - Partition 9 - Ext3 - Not used
    - Partition 10 - Ext3 - \Home

    As indicated, I've installed OpenSUSE on partition 4, with the GRUB installed in the first sector of this partition. However, the Acronis OS Selector doen't detect any SO in this partition.

    As previous problems with the detection of the WinXP partition were solved editing manually the bootwiz.oss file, Is there any way to create a new icon and edit it "manually" to try to start OpenSUSE? (Currently the only way to start it is to start the computer with the installation DVD, and during the installation process, to select an option to "start installed OpenSuse").

    The configuration files of the GRUB installed in the OpenSUSE partition are the following:

    /boot/grub/device.map
    Code:
    (fd0)	/dev/fd0
    (hd0)	/dev/mapper/nvidia_daddbbaj 
    /boot/grub/menu.lst
    Code:
    # Modified by YaST2. Last modification on mié jun 13 23:25:49 CEST 2007
    default 0
    timeout 8
    gfxmenu (hd0,6)/boot/message
    
    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title openSUSE 10.2
        root (hd0,6)
        kernel /boot/vmlinuz-2.6.18.2-34-default root=/dev/mapper/nvidia_daddbbaj_part7 vga=0x317 resume=/dev/mapper/nvidia_daddbbaj_part6 splash=silent showopts
        initrd /boot/initrd-2.6.18.2-34-default
    
    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE 10.2
        root (hd0,6)
        kernel /boot/vmlinuz-2.6.18.2-34-default root=/dev/mapper/nvidia_daddbbaj_part7 vga=normal showopts ide=nodma apm=off acpi=off noresume edd=off 3
        initrd /boot/initrd-2.6.18.2-34-default
    /etc/grug.conf
    Code:
    setup --stage2=/boot/grub/stage2 (hd0,6) (hd0,6)
    quit
    Thanks for your help!!
     
  2. MudCrab

    MudCrab Imaging Specialist

    Joined:
    Nov 3, 2006
    Posts:
    6,483
    Location:
    California
    Maal656,

    Hello again! I'll take a stab at this a see if I can help again. I haven't had to mess with my Linux setups, but I do have the OSS entries and the steps I used to make it work.

    I don't know for sure how you installed GRUB so you may need to reinstall it. That may fix the problem so it's what I would try first.

    Boot into Suse (or from a Live Linux CD like Knoppix if you can't) and open a terminal/console window. You will need to be in "root" mode so it may be "sudo" or you may need to login as root first. In Ubunutu you just use sudo, but I'm not familiar with Suse.

    In root mode, at the prompt ($ or #) start grub ( <ENTER> means to press the Enter key) :
    Code:
    $sudo grub <ENTER>
    [i]or[/i]
    #grub <ENTER>
    This will bring up the GRUB prompt ( > )
    Then type
    Code:
    >find /boot/grub/stage1 <ENTER>
    It should return where GRUB is installed, in your case it should be (hd0,6)
    Type
    Code:
    >root (hd0,6) <ENTER>
    >setup (hd0,6) <ENTER>
    This will install GRUB to the bootsector of the (hd0,6) partition. Hopefully you won't get any fatal error messages. To exit from the GRUB program
    Code:
    >quit <ENTER>
    Once that is done, reboot back to the OSS menu. Click on the Toos menu and then on OS Detection Wizard. Click Next to get to first screen. Select the "Detect OS on Partition" option and click Next. The next screen will list the partitions. Find the Suse partition in the list and click on it to highlight it. Click the "Bootable" button and the Next button should become enabled. Click the Next button and hopefully OSS will find Suse. This has always worked for me.

    The OSS entry will look something like what's below (I copied one of my entries). You will have different OS id's and Partition ID's. I don't know if you can just copy the entry into your OSS bootwiz.oss file (changing the partition ID's to be correct) and have it work. I've never tried it.
    Code:
    		<id2040028655 boot_as_ms71="0" boot_as_os2="0" boot_cd_entry="0" boot_partition="353106529" icon="icon_sys_linux" language="" lba="1" name_template="Ubuntu Edgy" nthide="0" os_type="linux" uninstall_info="1" use_manual_disks_order="0" write_boot="0">
    			<partitions>
    				<id1002412294 active="1" />
    				<id353106529 active="1" />
    			</partitions>
    		</id2040028655>
    I don't know what partitions, if any, actually need to be marked as "active" for a Linux boot. If you're booting from a primary partition, then it must be active, otherwise not (in your case, not). The two partitions shown in my entry as active are one of my XP partitions (primary) and the Linux boot parititon (also primary). My two other Linux partitions are logicals and boot from the their bootsector just like what you're trying to do.

    Hope it helps. Post back you have success or any problems.
     
    Last edited: Jun 14, 2007
  3. K0LO

    K0LO Registered Member

    Joined:
    Mar 9, 2006
    Posts:
    2,591
    Location:
    State College, Pennsylvania
    Oops! I think you meant to say type the following:
    Code:
    >root (hd0,6) <ENTER>
    >setup (hd0,6) <ENTER>
     
  4. MudCrab

    MudCrab Imaging Specialist

    Joined:
    Nov 3, 2006
    Posts:
    6,483
    Location:
    California
    Thanks, Mark.

    I corrected it in the post.
     
  5. Maal656

    Maal656 Registered Member

    Joined:
    Apr 16, 2007
    Posts:
    8
    Ops! It seems that the GRUB is incorrectly installed. When I follow your steps I get the following:

    Code:
        GNU GRUB  version 0.97  (640K lower / 3072K upper memory)
    
     [ Minimal BASH-like line editing is supported.  For the first word, TAB
       lists possible command completions.  Anywhere else TAB lists the possible
       completions of a device/filename. ]
    
    grub> find /boot/grub/stage1
     (hd0,6)
    
    grub> root (hd0,6)
     Filesystem type is ext2fs, partition type 0x83
    
    grub> setup (hd0,6)
     Checking if "/boot/grub/stage1" exists... yes
     Checking if "/boot/grub/stage2" exists... yes
     Checking if "/boot/grub/e2fs_stage1_5" exists... yes
     Running "embed /boot/grub/e2fs_stage1_5 (hd0,6)"... failed (this is not fatal)
     Running "embed /boot/grub/e2fs_stage1_5 (hd0,6)"... failed (this is not fatal)
     Running "install /boot/grub/stage1 (hd0,6) /boot/grub/stage2 p /boot/grub/menu
    .lst "... failed
    
    Error 22: No such partition
    
    grub>
    Maybe it is due to the FakeRAID I have mounted: A RAID 0 using the nVIDIA chipset of the motherboard...
     
  6. MudCrab

    MudCrab Imaging Specialist

    Joined:
    Nov 3, 2006
    Posts:
    6,483
    Location:
    California
    Were you installing GRUB from booting into Suse, using the Suse live/install cd or Knoppix?

    Were you in "root" mode? I can't tell since you didn't post the prompt before you started GRUB.

    Did you have write access enabled on the partition? (I don't know about Suse, but in Knoppix you'd have to right-click on the partition icon and select the Change to Writeable mode option.

    In doing some searching it looks like there might be a "repair" option when you boot from the Suse cd. Have you tried that?

    GRUB is finding its files on (hd0,6) so it can read the drive so I wouldn't think that the RAID is causing a problem but may be. I have Intel RAID on my computer and GRUB sees the array okay.

    You may need to post this in the Suse support forum. Once GRUB is fixed, I think OSS will pick it up okay.
     
  7. K0LO

    K0LO Registered Member

    Joined:
    Mar 9, 2006
    Posts:
    2,591
    Location:
    State College, Pennsylvania
    The first two failed (this is not fatal) errors almost always occur when installing GRUB to a partition so they can be ignored. The third p /boot/grub/menu.lst ...failed is indicating some kind of failure to install the menu.lst file. Either it is missing or it contains an error or GRUB can't write to the partition, as MudCrab has pointed out.
     
Thread Status:
Not open for further replies.