OSS did not recognize my XP partition - Resolved, maybe

Discussion in 'Acronis Disk Director Suite' started by kinoini, Feb 22, 2007.

Thread Status:
Not open for further replies.
  1. kinoini

    kinoini Registered Member

    Joined:
    Jun 4, 2006
    Posts:
    9
    If this thread is a repeat of something already posted, I apologize. I'm posting as an FYI, in case anyone has the same type of bizarre situation.

    Problem: OSS did not recognize my bootable XP partition. If I enabled OSS, the system would not boot.

    Quick background.
    I'm running an "AMD Athlon™ 64 X2 Processor 4200+" CPU, with two SATA RAID 0 drives, one primary bootable, one as a data repository. The RAID is hardware controlled by the mobo. I wanted to load Freespire into a separate partition, and use OSS to manage booting two os's. I created a primary linux partition on the main drive. The Freespire cd did not view the partition as part of a raid array, but as a partition on only one of the two drives in the array. Installation failed.

    I used True Image 10 to make a full backup of the drive, broke-up the RAID on the primary drive, and recovered the backup to the single drive. System booted up fine. Here's where it gets weird. I installed Freespire, but did not prevent it from writing the GRUB to the mbr. My first linux install (be gentle with me, please), so my MBR was messed up. Not to worry, I restored the MBR from the backup image. Back in business. (Another frustrating, but seemingly unrelated problem: booting to the xp cd and trying to run fixmbr did not work, because the xp cd does not see my sata single drive as a system drive...I believe its because I didn't do the F6 install scsi drivers, since I don't have a floppy drive, but that's another problem for another day).

    However, oss did not view the xp partition as an operating system, even though the computer booted to it just fine. I tried installing/uninstalling/reinstalling oss from within windows and from the bootable media. No bootable partition except for the linux.

    After several hours of research, reloads, I noticed a slight difference in the boot.ini file on this computer compared to the boot.ini on my other two computers (both intel processors):

    [boot loader]
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINNT="Microsoft Windows XP Professional" /noexecute=optin /fastdetect /usepmtimer

    I changed the value from WINNT to WINDOWS. I removed the /usepmtimer switch. I restarted, and OSS successfully added the XP bootable partition.

    I booted to each os several times last night, and noted no difference. However, I have seen documentation that indicates the /usepmtimer may resolve certain AMD dual core performance and gaming issues. I'm not sure which of the changes corrected the problem. It was 2 am, and the system satisfactorily booted to both XP or Freespire. Tonight, I will test each of the changes individually to see if I can re-create the problem.

    This works, however I need to do some performance tests on the machine. I'm still curious why the disparity in the boot.ini file. And was it the WINNT or the /usepmtimer switch? Anyone seen this before?

    Here is the Microsoft link regarding this switch http://support.microsoft.com/?scid=kb;en-us;895980

    I do have Cool'n'Quiet enabled in my bios...so I suppose I need to do some add'l testing.

    I hope this saves someone from a few hours of frustration if they are having the same problem.

    kinoini.
     
  2. cortez

    cortez Registered Member

    Joined:
    Nov 19, 2006
    Posts:
    444
    Location:
    Chicago
    Thanks in advance. Any info and variations on boot.ini operations are like gold in my eyes. Good Luck on your ongoing trials.
     
  3. kinoini

    kinoini Registered Member

    Joined:
    Jun 4, 2006
    Posts:
    9
    Thanks. I tested the config tonight. It was definetly the WINNT value that caused OSS to ignore my XP partition. The "/usepmtimer" did not impact the OSS detector. So, I set it back until I fully understand what it does, or doesn't do. It's all good.

    Not sure why the WINNT value was ever set, and frankly, this is really the first I've looked at the boot.ini file. That'll be one to tuck away for a rainy day.
     
Thread Status:
Not open for further replies.