Opera 10.10 (Linux) YouTube says 'Go Upgrade'

Discussion in 'all things UNIX' started by Ocky, Apr 18, 2010.

Thread Status:
Not open for further replies.
  1. Ocky

    Ocky Registered Member

    Joined:
    May 6, 2006
    Posts:
    2,677
    Location:
    George, S.Africa
    Since today - I have the latest flash player (64bit) and it's OK with Firefox.
    Anybody see this as well ?

    Edit:- When I disable my flashblocker userjs (which enables me to set flash on by clicking an f icon in the player), the player appears but with message 'an error has occured please try again later'. I think I have seen this before and that was 'fixed' soon thereafter.
     
    Last edited: Apr 18, 2010
  2. funkydude

    funkydude Registered Member

    Joined:
    Apr 5, 2004
    Posts:
    6,855
    This happens to me randomly with Opera 10.51 and Win7. It will randomly work and randomly not work. I *think* a reboot solves it?

    I'm willing to bet it's a YouTube problem. They will be detecting flash, but don't have the right code to properly detect the version. So they are assuming you need to upgrade if the version cannot be read. If it was an Opera issue, I would think it would happen every time.
     
  3. linuxforall

    linuxforall Registered Member

    Joined:
    Feb 6, 2010
    Posts:
    2,136
    Try latest beta for both Win and Linux, it fixes the youtube issue. Beta can be found here at http://my.opera.com/desktopteam/blog/ So far flash in youtube and other sites seem to be working fine here.
     
  4. Ocky

    Ocky Registered Member

    Joined:
    May 6, 2006
    Posts:
    2,677
    Location:
    George, S.Africa
    I installed the latest flashblocker.js from the site - I no longer get the upgrade prompt but when clicking the button I get the player with the 'an error has occured please try again later' message. All other sites are fine - so although A.Ruzanov says it's fixed in the latest script it doesn't work today for me. YouTube have probably found a way to get around this script. On the other hand I do remember having encountered this problem in the past and it was of short duration so maybe it will be the same this time.
    Scroll down to read the last couple of comments. http://my.opera.com/Lex1/blog/flashblock-for-opera-9?startidx=450#comments

    Edit:- It must be Youtube - my wife has the same story and she doesn't use a flashblocker.js. Will check tomorrow to see if YouTube really thinks
    Opera 10.10 is its enemy.

    @linuxforall - I would but no printing.
     
    Last edited: Apr 18, 2010
  5. dw426

    dw426 Registered Member

    Joined:
    Jan 3, 2007
    Posts:
    5,543
    This kept happening to me in 10.52 as well. A reboot did not solve the Youtube issue for me.
     
  6. Ocky

    Ocky Registered Member

    Joined:
    May 6, 2006
    Posts:
    2,677
    Location:
    George, S.Africa
  7. Durad

    Durad Registered Member

    Joined:
    Aug 13, 2005
    Posts:
    591
    Location:
    Canada
    Here is what I found:

    Use Text editor and create this file:

    Code:
    // ==UserScript==
    // @name        YoutubeProtectionRemover
    // @include     http://www.youtube.com/*
    // @description Removes lame protection on YouTube
    // @copyright 2010, Snap
    // ==/UserScript==
    
    window.opera.addEventListener(
    'BeforeScript',
    function (ev){
    ev.element.text = ev.element.text.replace("yt.flash.update(swfConfig, forceUpdate);","");
    },
    
    false);
    //end
    Name it: YoutubeProtectionRemover.js

    Now go to YouTube right click it Edit Site Preferences, select Scripting and at the bottom choose a folder where this file is located, click OK and restart Opera.

    (make sure that folder is accessible by Opera)
     
  8. Ocky

    Ocky Registered Member

    Joined:
    May 6, 2006
    Posts:
    2,677
    Location:
    George, S.Africa
    Yes, I saw that and tried it out but still no go even when clearing cache. In fact the flashblocker.js I mentioned before includes an almost identical script which purports to fix the prob. but not for me.

    Code:
    // Fix for youtube
    if(location.hostname.indexOf('youtube.com') != -1)window.opera.addEventListener('BeforeScript', function(e){
    	e.element.text = e.element.text.replace(/yt\.flash\.update\(swfConfig, forceUpdate\);/, '');
    }, false);
    Thanks for posting it as it may help other Opera users.:thumb:
     
  9. lodore

    lodore Registered Member

    Joined:
    Jun 22, 2006
    Posts:
    9,006
    its happerned to me a few times as well on windows 7
    only on some videos thou.
     
  10. Ocky

    Ocky Registered Member

    Joined:
    May 6, 2006
    Posts:
    2,677
    Location:
    George, S.Africa
    It works when setting site preferences to 'Never Accept Cookies' with my Opera version 10.10 (64 & 32 bit) on Ubuntu(s).
    Weird hey ? The flashblock.js & getvideo.js also work.

    Tube userjs.jpg
     
    Last edited: Apr 26, 2010
  11. linuxforall

    linuxforall Registered Member

    Joined:
    Feb 6, 2010
    Posts:
    2,136
    Works fine here on Ubuntu x64 Karmic with x64 flash, I use latest version 10.52 build 6325
     
Loading...
Thread Status:
Not open for further replies.