OpenPGP & Enigmail problems..

Discussion in 'encryption problems' started by Xpirex, Apr 18, 2014.

Thread Status:
Not open for further replies.
  1. Xpirex

    Xpirex Registered Member

    Joined:
    Mar 24, 2005
    Posts:
    5
    Hi, i just installed OpenGPG and Enigmail on a Macbook Pro (10.8.5) and everything works fine.

    Except one thing. Every single email I now send to anyone is automatically encrypted. I have disabled 'Sign Message' and 'Encrypt Message' in the OpenGPG menu but every message is still signed and encrypted. How can I disable this so that I can choose to encrypt on a message to message basis or maybe just auto encrypt to certain specific email addresses only?

    I am able to decrypt all my own messages sent to my other emails and I have a friend that can decrypt and read all of my messages but I can not decrypt or read any of hers even though I have imported her public key. How can this be? She is on a Windows system.
     
  2. Veeshush

    Veeshush Registered Member

    Joined:
    Mar 16, 2014
    Posts:
    643
    I think this might be what you're looking for:

    In Thunderbird

    Go Address Book > Create OpenPGP rule and set "Use the following OpenPGP keys" to none (for those contacts you don't want to use it with)

    And then take a look in Account Settings > OpenPGP Security > and make sure everything is setup ok in there such as "encrypt messages by default" is unchecked (that might be the one doing it).
     
  3. Xpirex

    Xpirex Registered Member

    Joined:
    Mar 24, 2005
    Posts:
    5
    Thank you Veeshush, I was up all night playing with it and managed to work it out. :) It was the "encrypt messages by default" option.

    When I opened Address Book ads you suggested i could not see any option to edit any rules though.
     
  4. Veeshush

    Veeshush Registered Member

    Joined:
    Mar 16, 2014
    Posts:
    643
    Yeah, personally I'm pretty new to OpenPGP. I had an issue myself recently where my inbox messages were garbled, so I had to go View > Message body as > Plain Text.

    Right click on a contact and it should show up (but I'm on Win7 so it might be different on your Mac).
     
Thread Status:
Not open for further replies.