OpenDNS DNS Crypt always communicating.

Discussion in 'privacy technology' started by TigerRaptorFX, Jul 24, 2012.

Thread Status:
Not open for further replies.
  1. TigerRaptorFX

    TigerRaptorFX Registered Member

    Joined:
    Sep 9, 2011
    Posts:
    58
    Couldn't find the answers I was looking for. So time to ask.

    Ever since I installed DNS Crypt my connection is constantly active. Wheather I'm browsing the internet or when my computer is idling. This thing is always communiting with the OpenDNS servers every 1 or 2 seconds. As seen in my network meter gadget.

    http://i799.photobucket.com/albums/yy272/TigerRaptorFX/DNSCrypt.jpg

    Is this normal behavior for this program?
     
    Last edited: Jul 24, 2012
  2. jedisct1

    jedisct1 Registered Member

    Joined:
    Jul 7, 2012
    Posts:
    39
    Location:
    San Francisco, CA
    Re: OpenDNS DNS Crypt always communiting.

    This is not dnscrypt.

    The user interface does that when the "fallback to insecure" box has been checked. It constantly checks if encrypted queries are not filtered by a router/firewall and disables dnscrypt if this is the case. This also renders the whole thing virtually useless since flooding the router is all it takes in order to force a protocol downgrade.

    Don't enable this blindly.
     
  3. funkydude

    funkydude Registered Member

    Joined:
    Apr 5, 2004
    Posts:
    6,852
    Re: OpenDNS DNS Crypt always communiting.

    If you're capable of it I suggest you stick to only using the proxy program instead of installing the GUI. I had all kinds of issues with memory & CPU consumption with what should be a simple GUI. It's also still buggy and hasn't been updated in nearly a month. It uses an old version of the proxy and they STILL haven't fixed the UAC issue.
     
  4. treehouse786

    treehouse786 Registered Member

    Joined:
    Jun 6, 2010
    Posts:
    1,388
    Location:
    Lancashire
    Re: OpenDNS DNS Crypt always communiting.

    how does one achieve this? i have experienced similar issues which you have noted
     
  5. TigerRaptorFX

    TigerRaptorFX Registered Member

    Joined:
    Sep 9, 2011
    Posts:
    58
    Re: OpenDNS DNS Crypt always communiting.

    I already went through the necessary troubleshootings before posting this thread. Even with the computer plugged directly into the cable modem. DNS Crypt still acted the same with "fall back to insecure DNS" enable and disabled. Even with Comodo firewall I gave that program as much leeway as possable.

    So yes it is DNS Crypt in this case.

    That part I failed to take into consideration. Since it still using the old proxy, that maybe the issue here. Because I'm out of ideas.
     
    Last edited: Jul 24, 2012
  6. funkydude

    funkydude Registered Member

    Joined:
    Apr 5, 2004
    Posts:
    6,852
    Re: OpenDNS DNS Crypt always communiting.

    When I was monitoring the proxy with the GUI installed I would periodically see it go from 0 to 0.1Mbps every second or so, much like you are experiencing. When I started using the proxy only I no longer had the issue. It's probably yet another bug in the GUI where the option isn't taking effect.

    I'll try find some time to take some screenshots and make a guide at some point. But to put it simply, download the appropriate proxy file from github, extract it and place the file somewhere permanent. Set your DNS IP to 127.0.0.1 (your own PC) in your connection settings. Run the proxy file and all DNS data will be sent to OpenDNS via the DNSCrypt proxy.

    To make it auto-launch at PC startup/login you can create a scheduled task or a registry entry.
     
  7. TigerRaptorFX

    TigerRaptorFX Registered Member

    Joined:
    Sep 9, 2011
    Posts:
    58
    Re: OpenDNS DNS Crypt always communiting.

    I gave your suggestion a try and everything seems to be acting normal.

    Thanks for the help.
     
Loading...
Thread Status:
Not open for further replies.