"Open With" problem - choice change won't work?

Discussion in 'other software & services' started by krazo1961, Jun 23, 2006.

Thread Status:
Not open for further replies.
  1. krazo1961

    krazo1961 Registered Member

    Joined:
    Aug 11, 2005
    Posts:
    5
    Hello,

    I have a question about file associations. I believe my daughter was messing around just double clicking on files and changed the a file type extension .dat to open with notepad. She must have double clicked on the file in this case a .dat extension file and left the check mark in the box were it reads: “always use the selected program to open this kind of file” when she selected from the “Open With” Dialog box. I can’t get it to change back and stay. Read below please.

    I went into the Control Panel then selected Folder Options and from there ‘File Types Tab’. I scrolled down the Folder Options dialog box until I saw the DAT extension then highlighted it and at the bottom half of there is a section that shows which program is selected to open it (a little notepad icon showed). As I said in this case it is notepad.

    There are the buttons Change and Advanced I went to the Change button and clicked I, it then brought up the “Open With” dialog box were I took the check mark OUT of the “always use the selected program to open this kind of file” box.

    This should have set it back to not open with any thing when double clicked on but after I un checked it and navigated back out I found that .dat files would still open up with notepad when double clicked rather than coming up with that dialog box that has the note about ‘this is a system file ect’ and that box has two choices one is the choose which program from a list, the list being the open with part already covered.

    I went back to find that the check mark was back in the box. I unchecked it again and clicked ok backing my way out and it still didn’t change it. How can I fix this if un checking it doesn’t want to work like it should. Where in the registry if that how to fix it is the open with choice for file extensions located and what do I do. If it is solved some other way please let me know.

    Thanks
     
  2. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
    when u go to the file types tab, just delete the entry for DAT. after that Windows will show the Open With screen again.
     
  3. Bubba

    Bubba Updates Team

    Joined:
    Apr 15, 2002
    Posts:
    11,271
    If there is no entry to delete as WSFuser suggested and you have to resort to the registry....the below registry location and the string value Application entry shown in pic if deleted should cause it to "change back and stay" for that logged on user.

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.dat
     

    Attached Files:

Loading...
Thread Status:
Not open for further replies.