Nouveau driver Lnsfw pour TCP SPI et plus...

Discussion in 'LnS French Forum' started by Frederic, Feb 27, 2005.

Thread Status:
Not open for further replies.
  1. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Bonjour à tous,

    Voici iun nouveau driver beta lnsfw.sys pour le filtrage internet.

    Le principal changement concerne le TCP SPI:
    - corrections de bugs (liés à de mauvaise détection des fermeture de connexion)
    - 256 entrées
    - gestion des timeout améliorée

    D'autres changements ont été apportés:
    - correction pour le critère "Différent Et" qui ne marchait pas
    - support pour les paquets fragmentés. Lors d'un datagramme IP fragmenté, maintenant le jeu de règle ne regarde que le 1er paquet et applique le même comportement aux autres paquets du datagramme. Ceci devrait éviter dorénavant d'inclure la règle spéciale autorisant les paquets fragmentés nécessaire pour certains fournisseurs d'acccès (cf cette règle).
    Pour activer cela il faut ajouter l'entrée suivante (et redémmarrer le PC):
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lnsfw1]
    "IPFragActive"=dword:00000001

    Ce nouveau driver est téléchargeable ici:
    http://looknstop.soft4ever.com/Beta/lnsfw/lnsfw.sys

    Pour l'installer:
    - renommez C:\WINNT\system32\drivers\lnsfw.sys en lnsfw.old (pour pouvoir revenir à un driver qui marche en cas de soucis)
    - placez le nouveau fichier dans C:\WINNT\system32\drivers
    - redémarrer

    Notez qu'il s'agit bien d'un driver beta, aussi, ne l'utilisez pas (ou attendez un peu) si vous avez peur de rencontrer des problèmes...

    Cordialement,

    Frédéric
     
  2. Doud

    Doud Guest

    Bonjour Frédéric,

    La version 4.06p2 (béta) de lnsfw.sys nécéssitait l'ajout de 4 clés dans la base de registre. Est-ce que, avec cette nouvelle version, ces 4 clés doivent disparaitre ?

    Merci de ta réponse.
     
  3. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Bonjour,

    En fait c'est la version beta de lnsfw1 qui nécessite ces 4 clefs supplémentaires.

    Et oui, ces 4 clefs sont toujours nécessaires lorsqu'on souhaite tester les nouveaux types de blocages proposés par ces clefs.

    Cordialement,

    Frédéric
     
  4. Doud

    Doud Guest

    Oups.....je me suis trompé de driver. Désolé ........
     
  5. arteta91

    arteta91 Guest

    Saluch, pas tout capté a quoi sert exactement ce driver, il permet d optimiser Look 'n' Stop ?

    Quel version de driver Lnsfw y a avec Look 'n' Stop 2.05p2 ?
    Jsuis fan Look 'n' Stop que depuis hier lol, deja placé les regles Phant0m`s-v6-Final et quelques modifs, vraiment impressionnant !!!
    Dois je installer ce driver ?

    Ptit questions aucun rapport :)
    Apres avoir placé les relges de Phant0m, j ai lancé MSN 7 pensant qu il pourrait pas se connecter ?, vu que j avais vu ici:
    --> http://www.looknstop.com/Fr/rules/rules.htm
    Une regle pour MSN/Messenger, pourtant il a reussi a se connecter, why ?
     
  6. arteta91

    arteta91 Guest

    pas grand monde arf
     
  7. bloodscourge

    bloodscourge Registered Member

    Joined:
    Jul 3, 2004
    Posts:
    372
    Location:
    France
    Salut,

    Pas trop en ce moment... Comme toujours le status béta implique une utilisation as is, a tes risques et perils ;). Sinon, pour resumer, ce driver est utile pour ceux qui ont des problemes avec le P2P et le TCP SPI activé (ralentissements/impossibilité connexion/reboot) ou ceux qui ont des problemes de paquets fragmentés avec leur FAI. Pour ce qui est des regles MSN, celles ci sont necessaires pour les transferts fichiers/video/son, pas pour les dialogues.

    Voilou ;)
     
  8. arteta

    arteta Registered Member

    Joined:
    Jun 13, 2005
    Posts:
    4
  9. bloodscourge

    bloodscourge Registered Member

    Joined:
    Jul 3, 2004
    Posts:
    372
    Location:
    France
    Salut,

    Voici les fichiers :
    - LNSFW1-d2.zip
    - lnsfw.sys

    Tu sais ou se trouve les instructions, y a plus qu'a ;)

    PS : Frederic, si il y a un quelconque probleme, je supprimerai ces liens. :)
     
  10. arteta

    arteta Registered Member

    Joined:
    Jun 13, 2005
    Posts:
    4
    Merki :cool: juste comme ca histoire de faire le relou :D

    J avais le lnsfw.sys de ce topic, donc version 4.0.0.8, la je recupere tes fichiers, et jtrouve comme version 4.0.0.7 o_O :ninja:

    La meme chose pour LNSFW1:
    Avant: version 3.0.0.5
    Apres: 3.04 d2

    Ca doit pas augmenter les versions de fichiers ? :ninja:
     
  11. bloodscourge

    bloodscourge Registered Member

    Joined:
    Jul 3, 2004
    Posts:
    372
    Location:
    France
    Euh... bah moi je t'ai filé ce que j'avais recuperé dans ces topics, après si ces versions sont moins recentes que ce que tu as...:D.
    En meme temps, si tu essaies d'installer ca par dessus la version 2.05p3 c'est normal ;) La version 2.05p3 contient a ma connaissance
    les drivers beta les plus recents! (cf les dates des topics ;))
     
    Last edited: Nov 11, 2005
  12. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Oui absolument.
    La 2.05p3 contient les drivers les plus à jour, c'est pour cela que les autres liens ne marchent plus (les fichiers ont été enlevé exprès).

    Frédéric
     
  13. Ornella

    Ornella Registered Member

    Joined:
    Nov 11, 2005
    Posts:
    9
    Salut,

    J'aurais quelques petites questions car je suis perdue là !!! :( :

    1) Quand je fais "Tester si nouvelle version disponible" dans LNS, je n'ai rien qui se passe o_O .
    Pour être sûr, j'ai été sur le site de LNS et je n'y ai vu aucune référence à cette version 2.05p3.

    C'est une version beta la 2.05p3 ?
    Ou est-ce juste ce fichier (lnsfw.sys) à télécharger pour mettre à jour LNS ? (voir le premier message de Frédéric)

    2) Ensuite si j'ai bien compris, cette version 2.05p3 permet d'utiliser le "Stateful Inspection Packet" avec des logiciels de partage (eMule etc.), c'est bien ça ?
    Ou apporte-t-elle au contraire d'autres fonctionnalités ?

    Voilà d'avance merci pour vos éclaircissements ;)
     
  14. bloodscourge

    bloodscourge Registered Member

    Joined:
    Jul 3, 2004
    Posts:
    372
    Location:
    France
    Salut,

    1) Tu devrais avoir une boite de dialogue avec le message : "pas de nouvelle version disponible pour l'instant". Si ce message n'apparait pas, verifie d'abord que tu n'as pas interdit looknstop.exe d'aller sur le net.

    Le sujet sur lequel tu te trouves concerne des drivers beta pour la version officielle 2.05p2. Ces derniers sont supplantés par ceux de la version beta 2.05p3. C'est pourquoi ils ne sont plus disponibles au telechargement.

    2) En effet, la version 2.05p3 ameliore en autre la compatibilité avec le TCP SPI et le peer to peer. Elle regle aussi des bugs : plus d'info dans la partie anglaise du forum ;)
     
  15. Ornella

    Ornella Registered Member

    Joined:
    Nov 11, 2005
    Posts:
    9
    Salut,

    Merci pour l'info !
    Donc tout est normal : la 2.05p3 est bien une version beta.

    A quand la version officielle ?

    Oui mais je ne connais pas l'anglais.

    @pluche
     
  16. arteta

    arteta Registered Member

    Joined:
    Jun 13, 2005
    Posts:
    4
    :ninja: Merki ;)
     
Thread Status:
Not open for further replies.