NoScript probs!

Discussion in 'other software & services' started by ams963, Mar 28, 2013.

Thread Status:
Not open for further replies.
  1. ams963

    ams963 Registered Member

    Joined:
    May 3, 2011
    Posts:
    5,965
    Location:
    Parallel Universe
    Hi,

    Even though I marked the option allow sites opened through bookmarks, when the sites are opened the scripts are still blocked by NoScript. Also LastPass always remains logged in until I log out. But after adding NoScript, LastPass is always found logged out after opening Firefox.

    Anyone got solutions? Please help if you got them.

    Best Wishes,
    Amit
     
  2. allizomeniz

    allizomeniz Registered Member

    Joined:
    Aug 23, 2009
    Posts:
    905
    It sounds like your login cookie's getting deleted but I can't think of anything in NS that would cause it, at least I've never had a problem with it. Hopefully someone else will know.

    As for the other issue, check Options>Embeddings, make sure "Apply these restrictions to whitelisted sites too" is unchecked. If that doesn't fix it, then I don't know.
     
  3. ams963

    ams963 Registered Member

    Joined:
    May 3, 2011
    Posts:
    5,965
    Location:
    Parallel Universe
    @allizomeniz
    The option 'Apply these restrictions to whitelisted sites too' is unchecked.

    When I remove NoScript everything falls to normal. LastPass is always logged in. I want NoScript to allow my bookmark sites but block scripts of other sites. Also LastPass should work as expected.

    I just don't get why it's acting like this?:doubt:
     
  4. wat0114

    wat0114 Registered Member

    Joined:
    Aug 5, 2012
    Posts:
    1,985
    Location:
    Canada
    Make sure lastpass.com is allowed in NS and also for 3rd party cookies.
     
  5. ams963

    ams963 Registered Member

    Joined:
    May 3, 2011
    Posts:
    5,965
    Location:
    Parallel Universe
    @wat0114
    Ah that solves the prob.:thumb: But allow sites opened through bookmarks does not work. I can see only three sites allowed in the whitelist after opening all the bookmarks.:doubt::(
     
  6. wat0114

    wat0114 Registered Member

    Joined:
    Aug 5, 2012
    Posts:
    1,985
    Location:
    Canada
    Okay, I'm not sure what's happening there o_O
     
  7. allizomeniz

    allizomeniz Registered Member

    Joined:
    Aug 23, 2009
    Posts:
    905
    I have mine set to "Temporarily allow top-level sites by default" and "Base 2nd level Domains (noscript.net). This allows the top-level sites and blocks all the third-party junk. I settled on those options 'cause if not, hardly any sites work right. If I want to access a top-level site, I at least have its name and URL and can decide if I wanna go there or not. I offer that as an alternative, I realize it doesn't explain your Bookmark situation though.

    You could try the author's support forum, http://forums.informaction.com/viewforum.php?f=3. He's always been helpful for me when I was having a problem.
     
Thread Status:
Not open for further replies.