NOD32 V4 - System hangs when I connect USB Mass Storage device

Discussion in 'ESET NOD32 Antivirus' started by enerata, Nov 15, 2009.

Thread Status:
Not open for further replies.
  1. enerata

    enerata Registered Member

    Joined:
    Nov 15, 2009
    Posts:
    6
    Location:
    Greece
    Hello everybody,

    Introduction: I have never installed an antivirus/security software before (so no conflicts :p) and my system has been running fine for years (yes I am talking about Windows XP SP3) and I hope/expect it will continue to do so until I finally upgrade to Windows 7 (I would like linux but it's not comfortable to develop in .NET under Debian for example, but as soon as I get fired I will switch to linux).

    After all years of usage, I thought it'd be a good idea to do a full system scan, so I installed NOD32 v4 (trial edition, I have 25 remaining days :blink:). Installation was smooth and full system scan found 0 threats, cool I thought :D.

    Problem Description: I connected my USB Mass Storage device and the system hang. To be more precise, I was able to switch between the running programs and operate them (using Alt+Tab), but the Desktop was frozen e.g. couldn't click "Start", right click on taskbar, right click on Desktop e.t.c. so I think explorer.exe or some other Windows component hang.

    Question to the experts: I think NOD32 somehow blocks explorer.exe, have you ever experienced anything similar?

    I plan to submit a customer support ticket in case the problem persists in which I will include a link to this thread, so anything you have to say might be useful :thumb:.

    Thank you all,
    enerata
     
  2. Brambb

    Brambb Registered Member

    Joined:
    Sep 25, 2006
    Posts:
    411
    Location:
    The Netherlands
    Do you have any specific reason this is NOD32 who causes this? Does this happen every time, with multiple flash drives, or is it just one? If you disable protection (temporarily) it wont freeze? More information would be useful.

    I for one never experienced or read this before.
     
  3. grun93

    grun93 Registered Member

    Joined:
    May 11, 2009
    Posts:
    24
    I had exactly the same experience when I used Nod32 AV v2.7. When I attached a Cowon Iaudio M5L musicplayer, the pc would freeze and the only solution was to turn it off. The Iaudio is basically also an mass storage device, it has a 1,8" HD (20 Mb). The pc is build around a Asus A8N-E mobo with Nvidea chipset, the OS was and still is Windows XP Pro with SP3 and all the latest patches.

    With Nod32 AV 3.0.384 I don't have any simular problems.
     
  4. enerata

    enerata Registered Member

    Joined:
    Nov 15, 2009
    Posts:
    6
    Location:
    Greece
    Hello Brambb,

    I believe it's NOD32 because I had never ever experienced the problem before, it only appeared after installing NOD32 V4.

    The very first time I mounted the external disk -after installing NOD32 V4, no other program installed or any other system changes- "the system hang" (it didn't exactly hang as I describe in the initial post).

    Unfortunately I have not been able to find a reproduction path (I know, that doesn't help much :eek:), but it happened with 2 different external drives under 2 different circumstances.

    1. When I first mounted disk No 1.
    2. During VirtualBox USB driver installation when I tried to mount disk No 2 in a virtual machine (running inside VirtualBox).

    In both cases, the problem only appeared once, after doing a hard reset, I was able to mount disk No 1, and mount disk No 2 in the VM.

    Drives where checked for surface errors, and were OK.

    Unfortunately I can't tell, the problem is not reproducible.

    Thank you for your reply :thumb:,
    enerata
     
  5. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Could you confirm or deny that uninstalling v4 and installing the latest v3 makes a difference? A link to v3 is available on the ESET's download page.
     
  6. enerata

    enerata Registered Member

    Joined:
    Nov 15, 2009
    Posts:
    6
    Location:
    Greece
    Hello Marcos,

    Can't confirm or deny that because the problem is not reproducible, it only happened once (for each disk).

    I tried uninstalling -> re-installing NOD32 V4, but the problem did not reproduce.

    Do you know if there's a way to completely remove NOD32 V4 (Program Files + Settings) so I can uninstall -> re-install and try again? Is there a command with appropriate parameters?

    Thank you,
    enerata
     
  7. Brambb

    Brambb Registered Member

    Joined:
    Sep 25, 2006
    Posts:
    411
    Location:
    The Netherlands
    If the normal uninstall tool (Start->All Programs->ESET->Uninstall) provided does not work as designed there is a manual way to do this. Then you are sure every trace is removed.
     
  8. enerata

    enerata Registered Member

    Joined:
    Nov 15, 2009
    Posts:
    6
    Location:
    Greece
    Hello Brambb,

    Thank you for the link, I will try that.

    Today I experienced another suspicious system hang while I was reading emails in Outlook. The hang occurred when I click on an email to read (NOD32 runs under default settings -> email protection is enabled). It did not get selected, the system froze and I was not able to move the mouse :blink:.

    It is unfair to blame NOD32 (a wonderful product result of a lot of work) for those hangs, maybe something is wrong with my system.

    I will uninstall NOD32, using the link you suggested, and run my system for a period of one week to see if any problems appear.

    Thank you,
    enerata
     
  9. enerata

    enerata Registered Member

    Joined:
    Nov 15, 2009
    Posts:
    6
    Location:
    Greece
    After one week without NOD32 I experience no more problems with my system. I believe the talented NOD32 engineers will find the problem and fix it, but to be honest I expected NOD32 to be a more stable and properly tested program :(.
     
  10. dormix

    dormix Registered Member

    Joined:
    Aug 5, 2007
    Posts:
    40
    Location:
    Center of Italy
    Hi. My notebook too hangs when I connect my brand new 2,5'' usb external hard disk by LACIE (hitachi HD insyde).

    ACER TRAVEL MATE 5510 XP PRO SP3, AMD TURION 64 X2.

    I made many tries and when I have disabled all EAV 4.0.474.0 protections I could explore the usb external HD without any problem except that I must insert both usb plugs (data, power) to make it work.

    Best regards.
     
  11. etacarinae

    etacarinae Registered Member

    Joined:
    Mar 16, 2010
    Posts:
    1
    I too have experienced this with Western Digital My Book External enclosures. I thought it was my GPU. Alas, now I've disabled NOD32 4..no more intermittent system hang. :cool:
     
  12. enerata

    enerata Registered Member

    Joined:
    Nov 15, 2009
    Posts:
    6
    Location:
    Greece
    Hello all,

    Just a guess.. maybe we all here in this thread use crappy USB cases. I've had a destructive file system corruption in one of my external USB drives, and I have good reasons to believe that it's my crappy external case to blame.. Just a thought..
     
Thread Status:
Not open for further replies.