NOD32 prevents debugging with Eclipse/Flex on Vista

Discussion in 'NOD32 version 2 Forum' started by agresens, Aug 1, 2007.

Thread Status:
Not open for further replies.
  1. agresens

    agresens Registered Member

    Joined:
    Aug 1, 2007
    Posts:
    1
    Hello

    I'm bummed because my favorite anti-virus software is preventing me from user the debugger with the Adobe Flex Plug-in for Eclipse on Vista.

    This happens even if:

    * I add the java executable to a list of exceptions that IMON should ignore (Eclipse runs under Java).
    * turn off IMON completely.

    The problem that happens is as follows:

    1. I am able to launch the debugger the first time the IDE starts.
    2. Subsequent attempts to launch the debugger return a "Unrecognized Windows Sockets error: 0: JVM_BIND".

    This does not happen with inferior anti-virus products like Bitdefender, which I'm running a trial of now.

    This also does not happen on Windows XP. I'm running NOD32 and this software without any issues on another machine.

    The details of this problem have been documented on the following web page at the adobe site. The details include dumps from TCPView that show which ports are open before, during and after the issue happens.

    http://www.adobe.com/cfusion/webfor...id=651&threadid=1281271&enterthread=y#4633333

    Thanks,

    August
     
  2. Shtong

    Shtong Registered Member

    Joined:
    Sep 2, 2007
    Posts:
    4
    I'm also having the same problem:When using Vista and Flex Builder and NOD32 (version 2.70.39), I'm unable to use debugging more than one time because of a "JVM_Bind" error :mad: . Details are the same as described into the post linked by agresens.

    I hope this bug will be fixed soon. As I make an intensive use of the blocked feature for work, I cannot install NOD32 on my computer until that bug is fixed.
     
  3. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Does disabling AMON or IMON make a difference? In order to disable IMON, click the Quit button in the IMON panel and restart the computer.
     
  4. Shtong

    Shtong Registered Member

    Joined:
    Sep 2, 2007
    Posts:
    4
    No it doesn't. I tried to deactivate every part of nod32, and I even tried to stop the NOD32 kernel service, but I still got the error after that.
     
  5. Shtong

    Shtong Registered Member

    Joined:
    Sep 2, 2007
    Posts:
    4
    Hello, anyone here ?

    If this this is not a place to get an official answer to these questions, so where should I submit the bug ?
     
  6. Blackspear

    Blackspear Global Moderator

    Joined:
    Dec 2, 2002
    Posts:
    15,115
    Location:
    Gold Coast, Queensland, Australia
    Please send an email to support @ eset.com with a link to this thread.

    Let us know how you go...

    Cheers :D
     
  7. Shtong

    Shtong Registered Member

    Joined:
    Sep 2, 2007
    Posts:
    4
    I sent the mail and the support guys asked me to check the issue with the beta version of NOD32, and that beta version fixed the problem. So it's all fine now:)
     
Thread Status:
Not open for further replies.