NOD32 messes with Steam?

Discussion in 'ESET NOD32 Antivirus' started by reynald, May 12, 2008.

Thread Status:
Not open for further replies.
  1. reynald

    reynald Registered Member

    Joined:
    Jul 29, 2007
    Posts:
    19
    I installed NOD32 a few months ago and have been happy with it. I noticed recently, however, that Steam (engine for Half-Life) is no longer running properly, and the games that play through it won't launch. I checked on steampowered.com and it says NOD32 "has been known to cause severe issues" with Steam. Have others experienced this, and have you found a solution?
     
  2. vidmar

    vidmar Registered Member

    Joined:
    Aug 30, 2006
    Posts:
    8
    I too saw issue with v3.0.650 and Steam. In my case it was while trying to play TF2. I could not access the master server to get a server list. It just would not connect.

    I'm back at v2.70.39 and no more problems.
     
  3. reynald

    reynald Registered Member

    Joined:
    Jul 29, 2007
    Posts:
    19
    Yeah I'm running v3.0.642. I see another post here by someone else who found relief from this conflict by rolling back to v2.7. Guess that's what I'll have to do. Would be nice to be able to use Steam with the most current NOD32 version. Although I realize the fault may be Steam's (some say it's a poorly written app) and not ESET's.
     
  4. reynald

    reynald Registered Member

    Joined:
    Jul 29, 2007
    Posts:
    19
    To update this thread, I rolled back to v2.7 and reinstalled Steam. My Steam games worked properly until my next reboot, after which Steam was screwed up again. So I'm still looking for a way for NOD32 & Steam to play nice together, if anyone has any suggestions.
     
  5. SmackyTheFrog

    SmackyTheFrog Registered Member

    Joined:
    Nov 5, 2007
    Posts:
    767
    Location:
    Lansing, Michigan
    Try setting up exclusions for the steam process in the IMON module. It sounds like the HTTP filter is most likely causing the issue.
     
  6. reynald

    reynald Registered Member

    Joined:
    Jul 29, 2007
    Posts:
    19
    Thanks -- I did this but am still getting the same result.
     
  7. wiak

    wiak Registered Member

    Joined:
    Sep 10, 2006
    Posts:
    107
    TF2 and steam games work fine for me with 3.0.657

    try put steam folder in exclusion list
     
  8. reynald

    reynald Registered Member

    Joined:
    Jul 29, 2007
    Posts:
    19
    IMON in v2.7 won't allow a folder to be put in the exclusion list, only executables. If 3.0.x will, I guess I'll have to go back to that, which will bring me full circle.
     
  9. reynald

    reynald Registered Member

    Joined:
    Jul 29, 2007
    Posts:
    19
    Well I reinstalled 3.0.657, reinstalled Orange Box, and put the steam folder in the exclusion list. Steam games ran fine after installation, but once again, a reboot messes them up. Steam apps won't run. I can see steam.exe running in Task Manager, but it's not in the system tray, its window won't open, and it hangs up at shutdown and has to be manually terminated. Sigh.
     
  10. wiak

    wiak Registered Member

    Joined:
    Sep 10, 2006
    Posts:
    107
    what software are you running? what os?
    also try put steam.exe in exclusion list and hl2.exe like
    if this wont work try
    Disable Web access protection
    NOD32 will catch viruses when they are downloaded anyway
    hope this works
     
  11. reynald

    reynald Registered Member

    Joined:
    Jul 29, 2007
    Posts:
    19
    It's the Orange Box version (pretty recent) of the Half-Life games. WinXP SP2.
    I had put the entire steam folder in based on a previous suggestion. Then it occurred to me this might only work for executables in that folder, when most of the hl2.exe's are several folders deep, in the separate game folders. So I painstakingly added all 8 of them to the exclusion list. Reinstalled the games -- worked fine until a reboot, just like before.
    Tried that. Same result. I give up. I've tried everything. Looks like I'm gonna have to uninstall NOD32.
     
  12. Fajo

    Fajo Registered Member

    Joined:
    Jun 13, 2008
    Posts:
    1,812

    Lol stupid question uninstall Nod32 Reboot try steam reboot again see if it screws up im seeing a pattern here =X :blink:
     
  13. reynald

    reynald Registered Member

    Joined:
    Jul 29, 2007
    Posts:
    19
    Success!
    Good suggestion -- I did that and found I still had the same problem, which ruled out NOD32 as the cause. But I had no idea what else it could be. I had been putting off installing XP Service Pack 3, so I went ahead and did that, and lo & behold -- it solved my problem. Steam now starts up properly (icon shows up in the taskbar), and its games launch. So I dunno what the problem was, but SP3 fixed it!
     
Thread Status:
Not open for further replies.