NOD32 antivirus won't let me use my FTP WS_FTP95 LE program

Discussion in 'ESET NOD32 Antivirus' started by doxavita, Oct 22, 2009.

Thread Status:
Not open for further replies.
  1. doxavita

    doxavita Registered Member

    Joined:
    Oct 22, 2009
    Posts:
    12
    Ever since I installed NOD32 antivirus 4.0.468.0, I'm unable to use an FTP program which I really need called: WS_FTP95 LE , When I open up the program the computer just goes into waiting/hourglass mode and I'm unable to upload stuff to a remote folder.

    I already tried adding WS_FTP95.exe and its containing folder into the Exclusions list of NOD32, but it still won't work.

    Tried temporarily disabling NOD32 (red icon in the taskbar) , but same problem.


    I'm using Windows Vista Service Pack 2 (32-bit)

    Your help is really appreciated.
    Thanks in advance.
    ---------------------
    UPDATE: I tried installing the firefox addon: FireFTP 1.0.6, which in theory does the same as my WSFTP program, and again, I'm unable to contact and upload to a remote folder, so It seems the entire FTP protocol is being blocked somehow by NOD32. Any thoughts?
     
    Last edited: Oct 22, 2009
  2. WayneP

    WayneP Support Specialist

    Joined:
    Apr 9, 2009
    Posts:
    339
    Hello doxavita,

    The interruption or difficulty you described may be a result of the Web Access Protection feature.

    1. Open the main program window by clicking the ESET icon next to the system clock or by clicking 'Start' -> 'All Programs' -> 'ESET' -> 'ESET Smart Security' or 'ESET NOD32 Antivirus'.

    2. Press the F5 key to display the Advanced Setup window.

    3. From the Advanced Setup tree, click 'Antivirus and antispyware' -> 'Protocol Filtering'.

    For ESET Smart Security users, click 'Personal Firewall' -> 'Protocol Filtering'.

    4. Select the 'Applications marked as Internet browsers or e-mail clients' option.

    5. From the Advanced Setup tree, click 'Antivirus and antispyware' -> 'Web access protection' -> 'HTTP' -> 'Web browsers' and make sure that only the applications you want scanned with the Internet filter are selected. Typically only real web browsers (iexplorer.exe, firefox.exe, etc.) will need to be selected. Repeat this step for email clients (outlook.exe, thunderbird.exe, etc.) by clicking 'POP3' -> 'Email Clients'.

    6. Click 'OK' to save your changes and then restart your computer.
     
  3. doxavita

    doxavita Registered Member

    Joined:
    Oct 22, 2009
    Posts:
    12
    I can get up to the Protocol filtering part, but there's no internet browser/email clients option.

    And I can get up to AntiSpyware / Web Access Protection but there's no Web Browsers option/tree

    Im using Windows Vista SP2
     
  4. doxavita

    doxavita Registered Member

    Joined:
    Oct 22, 2009
    Posts:
    12
    Any ideas?
     
  5. doxavita

    doxavita Registered Member

    Joined:
    Oct 22, 2009
    Posts:
    12
    Hmmm, I think I fixed it!, I had to disable Passive Transfers (in WSFTP)/ Passive Mode (in FireFTP).

    What is Passive mode though? What changes after this tweak I just did?
     
  6. WayneP

    WayneP Support Specialist

    Joined:
    Apr 9, 2009
    Posts:
    339
    The difference between active and passive modes are the reason passive works for you while using the ESET Software.

    Active mode: The server connects directly to a random port that the client specifies for data transfer. This appears to the firewall as traffic originating from the outside, which is blocked.

    Passive mode: The server comes up with the random port and the client connects to it for data transfer. This way the traffic originates from the client, which the firewall then allows.

    Active mode will not work with most firewalls.
     
Thread Status:
Not open for further replies.