No e-mail access

Discussion in 'LnS English Forum' started by redman, Oct 11, 2004.

Thread Status:
Not open for further replies.
  1. redman

    redman Registered Member

    Joined:
    Apr 16, 2004
    Posts:
    41
    I don't know whether this is a coincidence or not but since I upgraded Look 'n' Stop to the latest version, I cannot send or receive e-mails. This is what my e-mail client reports:-

    Account 'Plus Net - Brian' is paused.
    Account 'Plus Net - Maria' is paused.
    Account 'Plus Net - Support' is paused.
    *** Sending pending mail from account 'Plus Net - Brian' @ 11-Oct-04 8:25 PM ***
    Connecting to: 'localhost'
    Connect.c[311] MailMgr.dll
    Failed to send one or more pending messages.
    WINSOCK Error: Authoritative: Host not found. (Failed to look up the server name in DNS. Verify the server name or contact your System Administrator).
    Unable to resolve the IP address of the mail server.
    *** Checking mail for account 'Plus Net - General Mail' @ 11-Oct-04 8:25 PM ***
    Connecting to: '127.0.0.1'
    Disconnecting -> Successful
    Failed to get mail from account: 'valencia@127.0.0.1'
    Pop3.c[113] Pop3.dll
    Mail server responded: ' Socket Error # 11001'
    *** Checking mail for account 'Plus Net - Joseph' @ 11-Oct-04 8:25 PM ***
    Connecting to: 'mail.plus.net'
    Connect.c[311] MailMgr.dll
    Failed to get mail from account: 'valencia+joseph@mail.plus.net'
    WINSOCK Error: Authoritative: Host not found. (Failed to look up the server name in DNS. Verify the server name or contact your System Administrator).
    Unable to resolve the IP address of the mail server.
    11-Oct-04 8:25 PM: No new mail.** Error, see previous Details **
     
  2. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Do you have some Look 'n' Stop alerts in the log when this happens ?

    Is it normal that your email client connect to localhost/127.0.0.1 to send or retrieve the emails ?
    If yes do you have a proxy application on your PC relaying the requests ? if yes, is this application running and allowed to connect ?

    It seems some DLL are reporting the errors. Did you activate de DLL detection ? if yes, are the mentionned DLL allowed to connect ?

    Thanks,

    Frederic
     
  3. redman

    redman Registered Member

    Joined:
    Apr 16, 2004
    Posts:
    41
    Hi Frederic

    I don't know the answers to all your questions but I can confirm that it was the latest version of Look 'n' Stop that was causing the problem. As soon as I uninstalled it, my e-mail service resumed. I've put the previous version of Look 'n' Stop back on my PC and everything is still fine.

    Some of my e-mails are routed through ChoiceMail One (an anti-spam utility from www.digiportal.com) and 1st Email Antivirus (from www.zzee.com) which removes risky and undesirable HTML components and zips up e-mail attachments. These work in chain mode Internet >> 1st EAV >> ChoiceMail One >> E-mail Client (Courier from www.rosecitysoftware.com). Although this setup was difficult to figure out, it normally works fine. I'm not sure about the DLL detection, could you explain what this is and how I check it? Is it something that has been added to the new SP2 version?
     
  4. gkweb

    gkweb Expert Firewall Tester

    Joined:
    Aug 29, 2003
    Posts:
    1,932
    Location:
    FRANCE, Rouen (76)
    Hi,

    did you lock the Look'n'Stop configuration with a password ?
    About the DLL monitoring, you can check it in options, advanced options, DLL button (and see if the checkbox is checked).

    gkweb.
     
  5. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Hi redman,

    If you install again the 2.05p2 and the problem appears again here is what you can do:
    - verify if the DLL detection is enabled, if yes, disable it to see if it makes a difference
    - just after you noticed the issue, open the console and ask for the driver logs and send the log to us
    - you can also try to disable "Watch DNS Call" & "Watch thread injection" features to verify if they are involved or not (it is better to restart the computer after deactivating these options)
    - confirm that the problem is coming from the Application filtering

    Thanks,

    Frederic
     
  6. redman

    redman Registered Member

    Joined:
    Apr 16, 2004
    Posts:
    41
    I'll try this tomorrow as it's getting late and I'm tired. Looking at my current version however I see that there isn't a dll monitoring option, so if that is a new feature, perhaps that is the cause after all. I'll report back when I've had a go at your suggestions.
     
  7. redman

    redman Registered Member

    Joined:
    Apr 16, 2004
    Posts:
    41
    I can confirm that by deselecting "Watch DNS Call", the problem disappears. I don't know how to obtain the log file you wanted from within the console, but I have found a log file in the installation folder and attempted to add it to this message. I'm not sure if it will work because I've not tried to upload any files to this forum before.
     
  8. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Hi redman,

    You just need to click on the Drivers Logs button, then the Save button and specify a filename. Then send us the file at lnssupport@soft4ever.com.

    If finally the problem is caused by "Watch DNS Call" activation, probably an application doing DNS Calls is blocked when your email client try to connect.
    Do you specify some UDP ports for the email client in the application filtering ?

    Frederic
     
  9. redman

    redman Registered Member

    Joined:
    Apr 16, 2004
    Posts:
    41
    I can't find a Drivers Logs Button, or any logs in the program folders. Perhaps it's so obvious that I can't see it.
     
  10. gkweb

    gkweb Expert Firewall Tester

    Joined:
    Aug 29, 2003
    Posts:
    1,932
    Location:
    FRANCE, Rouen (76)
    Hi,

    see below :
     

    Attached Files:

Thread Status:
Not open for further replies.