Nintendo Wi-Fi Connector DISCONNECT with ESET

Discussion in 'ESET Smart Security' started by stev418, Feb 5, 2009.

Thread Status:
Not open for further replies.
  1. stev418

    stev418 Registered Member

    Joined:
    Feb 5, 2009
    Posts:
    3
    I am using ESET smart Security 3.0.684.0 and using an Official Nintendo Wi-Fi USB Connector but every time within seconds of connecting to Nintendo Wi-Fi in a Wii game I am getting disconnected with an error 84020. (info - the Nintendo Wi-Fi USB Connector is made by Buffalo and is used to create a soft AP)

    From Nintendo website error DB
    I have checked ESET firewall setting for NintendoWFCReg.exe and i have allow all for both IN/OUT and TCP/UDP

    Would love to know if i can fix this issue as at the moment I need to DISABLE FIREWALL totally to use the Nintendo Wi-Fi USB Connector

    OF note is the fact that i can use the connector without issue for other things like pokemon trading, or shopping/browsing on wii channels - this just occurs when using wifi in wii games
    thanks
     
    Last edited: Feb 7, 2009
  2. Rmuffler

    Rmuffler Former Eset Moderator

    Joined:
    Jun 26, 2008
    Posts:
    995
    Location:
    San Diego, CA USA
    Hello stev418,

    Adjust your protocol settings and switch to interactive mode. Below are the procedures.

    1. Open the main program window by clicking the ESET icon next to the system clock or by clicking Start -> All Programs -> ESET -> ESET Smart Security.
    2. Press the F5 key to display the Advanced Setup window.
    3. From the Advanced Setup tree, click Personal Firewall and then select Interactive mode from the Filtering mode drop-down menu.
    4. Then click Protocol Filtering.
    5. Select the Applications marked as Internet browsers or e-mail clients option.
    6. From the Advanced Setup tree, click Antivirus and antispyware -> Web access protection -> HTTP -> Web browsers and make sure that only the applications you want scanned with the Internet filter are selected. Typically only real web browsers (iexplorer.exe, firefox.exe, etc.) will need to be selected. Repeat this step for email clients (outlook.exe, thunderbird.exe, etc.) by clicking POP3 -> Email Clients.
    7. Click OK to save your changes.

    Thank you,
    Richard
     
  3. stev418

    stev418 Registered Member

    Joined:
    Feb 5, 2009
    Posts:
    3
    Thanks for the speedy reply

    I went through above procedure, but I am still receiving the same error.

    I am not sure why I am only getting this issue IN GAME, as I can use the wii Oprah web browser fine without any connection issues at all, the only difference I can think of is wii game servers use a different port then the wii browser ??

    The only way I can keep a connection IN GAME is to disable ESET firewall (I then enable windows firewall to have 'some' protection) but I would really prefer to keep ESET firewall enabled.

    Is there any way to totally disable eset firewall on my wii wifi connection? since its only a SoftAP it wont matter at all.
    thanks for any other ideas :\
     
    Last edited: Feb 7, 2009
  4. Rmuffler

    Rmuffler Former Eset Moderator

    Joined:
    Jun 26, 2008
    Posts:
    995
    Location:
    San Diego, CA USA
    Hello stev418,

    Go to Nintendo's support page here: http://www.nintendo.com/consumer/systems/wii/en_na/onlineFirewall.jsp

    Read through their compatibility information. Use the network tool on that page to verify outbound UDP traffic works through the router and through ESS. Make sure the following applications are allowed through the firewall:

    • Nintendo Wi-Fi Connector USB (NintendoWFCReg.exe )
    • Setup.exe (when installing the USB Connector)
    • SoftAPInstDrv.bin
    • mdriver.exe

    Thank you,
    Richard
     
  5. stev418

    stev418 Registered Member

    Joined:
    Feb 5, 2009
    Posts:
    3
    thanks, will have a look.

    Looks more like a Nintendo issue anyhow, found this while reading :\

    Important: The Nintendo Wi-Fi USB Connector has been discontinued until further notice.
     
Thread Status:
Not open for further replies.