Newest NoScript =Slowdowns/Stalls

Discussion in 'other software & services' started by dw426, Dec 20, 2008.

Thread Status:
Not open for further replies.
  1. dw426

    dw426 Registered Member

    Joined:
    Jan 3, 2007
    Posts:
    5,543
    Guys, is anyone else having issues with the newest NoScript version? It seems to slow down website loading and, when I need to allow scripts to run it tends to stall the browser for, oh, say about 5 seconds before it refreshes the page again. I don't recall having these kinds of problems with NoScript before and wanted to see if anyone else here noticed anything before I went over to NoScripts forums.
     
  2. mjgent

    mjgent Registered Member

    Joined:
    May 19, 2008
    Posts:
    43
    Location:
    Sandboxed in a VM behind a UTM
    No issues noticed here with 1.8.7.6....at least so far.
     
  3. Cloudcroft

    Cloudcroft Registered Member

    Joined:
    Feb 29, 2004
    Posts:
    433
    Location:
    The Hill Country of Texas
    Same here.
     
  4. Trespasser

    Trespasser Registered Member

    Joined:
    Mar 1, 2005
    Posts:
    1,194
    Location:
    Virginia - Appalachian Mtns
    I know what you're talking about. I'm experiencing it too but I wouldn't describe it as a slowdown. More a "are you sure you want to allow this site to run script on your computer?" type of pause that the author programmed into it. It's been that way for the last two or three releases from NoScript. Great extension.
     
  5. dw426

    dw426 Registered Member

    Joined:
    Jan 3, 2007
    Posts:
    5,543
    Hmm, well, at least I'm not alone, lol. I've also noticed the XSS/Crossscript thing is getting very very strong, almost to the point that I wonder if some of these blocks are not FP's. But that's a whole other thread, lol.
     
  6. iceni60

    iceni60 ( ^o^)

    Joined:
    Jun 29, 2004
    Posts:
    5,116
    noscript changed the behaviour recently, maybe you're not clicking outside the menu (or hitting Esc) to tell noscript you've made the changes you want?

    if that's it, i think , right-clicking the menu is the old behaviour and left-clicking is the changed behaviour.

    edit: this is what i'm talking about -
    http://noscript.net/faq#qa5_5
     
  7. Cloudcroft

    Cloudcroft Registered Member

    Joined:
    Feb 29, 2004
    Posts:
    433
    Location:
    The Hill Country of Texas
    Thanks for the tip.
     
  8. dw426

    dw426 Registered Member

    Joined:
    Jan 3, 2007
    Posts:
    5,543
    It doesn't make a difference in the clicking, it just seems slightly slower now. It's no showstopper, I just happened to notice the difference.
     
  9. Fontaine

    Fontaine Registered Member

    Joined:
    Jan 29, 2008
    Posts:
    245
    Thought it was just me that noticed. When I allow a script to run, there's about a 5 second pause before the page refreshes. Great plugin, but kind of annoying when you allow scripts one at a time, until you get the right one needed.
     
  10. dw426

    dw426 Registered Member

    Joined:
    Jan 3, 2007
    Posts:
    5,543
    Yes, plus, you have to be awful careful about which script you allow to run. For instance, which of these scripts should you allow to run?

    1. 819:axels-fun:412

    2. exponential.com

    Those are two real options in the NoScript menu on several websites. I know the answer, clicking "axels-fun" is an invite for problems. Exponential.com is a harmless ad and isn't needed for functioning of the websites. But not everyone is going to know that, and by the time you allow 10 scripts, trying to get that menu on a site to work, God knows what you've allowed.
     
  11. demoneye

    demoneye Registered Member

    Joined:
    Dec 30, 2007
    Posts:
    1,356
    Location:
    ISRHell
    i just install it for checking , it doesn't slow any speed in here , also i use flashblock so this add on is totally useless for me:D

    also it blocks this forum and all others one when try to add any smiles :)


    so u add this and many more to "exclusion" list , and at the end of the day you find your self allow it more than denied it :argh:
     
  12. Franklin

    Franklin Registered Member

    Joined:
    May 12, 2005
    Posts:
    2,517
    Location:
    West Aussie
    If using Noscript are the below settings in FF really needed which never showed any warnings even when deliberately visiting known compromising sites.

    You could try turning them off and see if there's any speed improvement?
    FF Security.jpg
     
  13. Reimer

    Reimer Registered Member

    Joined:
    Apr 6, 2008
    Posts:
    217
    The newer Noscript versions also have a new "sticky" feature where the noscript status bar menu now stays visible until you click anywhere else on the Firefox screen.

    This is so you can click and allow multiple javascript domains without having to click the Noscript icon for every domain you want to allow.

    So this might be perceived as "lag" because it looks like the noscript popup menu doesn't go away.

    To turn this off and go back to the old behaviour, go into "about:config"

    and search for "noscript.stickyUI"

    set that to false
     
Thread Status:
Not open for further replies.