My Router IP address is blocked by Avast Firewall

Discussion in 'hardware' started by Antarctica, Mar 26, 2010.

Thread Status:
Not open for further replies.
  1. Antarctica

    Antarctica Registered Member

    Joined:
    Feb 25, 2003
    Posts:
    1,618
    Location:
    Canada
    Hello,
    I noticed in the logs that 2-3 times a day the IP address from my D-Link Router (192.168.0.1) is blocked by Avast Firewall. Is it normal? any reason why D-Link would try to establish connection?
    Thank you for help
     
  2. NoIos

    NoIos Registered Member

    Joined:
    Mar 11, 2009
    Posts:
    607
    I don't know if Avast reports the related port. It could be something normal like uPnP or something bad too. So I think knowing the port is important. In any case Avast protects you, so you're ok. Just keep a note of the event so in the future if you have a problem related to networking with that pc, to check this again. Wait for the replies of others members too. I use Avast Security Suite but I have disabled the firewall component.
     
  3. Antarctica

    Antarctica Registered Member

    Joined:
    Feb 25, 2003
    Posts:
    1,618
    Location:
    Canada

    Thanks NoIos for your answer.
    It is related to Port 137, 138 and 0 does this make more sens to you?
     
  4. mvario

    mvario Registered Member

    Joined:
    Sep 16, 2008
    Posts:
    339
    Location:
    Haddonfield, IL
    Port 0 shouldn't be used. Ports 137/138 are Netbios. Your ISP may in fact already be filtering those ports, many do. Either way you shouldn't be getting any internet traffic on them so blocking them is a good thing.
     
  5. NoIos

    NoIos Registered Member

    Joined:
    Mar 11, 2009
    Posts:
    607
    mvario is right about the ports.

    Try to check with ShieldsUp ( https://www.grc.com/x/ne.dll?bh0bkyd2 ) how your router responds to this.

    Do you have or use a wireless network?

    Also in Avast check Firewall->Firewall Settings->Expert Settings->Friends and see if 192.168.0.0 is there.
     
  6. Antarctica

    Antarctica Registered Member

    Joined:
    Feb 25, 2003
    Posts:
    1,618
    Location:
    Canada
    Thanks guys for your help
    I did check with ShieldsUp and I am stealth.
    I am not using any wireless with my router, in fact the wireless is deactivate right now.And I checked the Avast Firewall, I can see the 192.168.0.0 in the Friends section.:)
     
  7. NoIos

    NoIos Registered Member

    Joined:
    Mar 11, 2009
    Posts:
    607
    I would not worry about an attack from 192.168.0.1, although it could be malicious behaviour behind it, but requires special methods and many errors by your part in order to be successful and in addition an infection somewhere in your lan.

    In any case and since you have also posted this at the Avast's forum I could only suggest some things till the experts give more specific answers.

    1. Login to your router and change your password to something difficult.
    2. Check if there are any special rules about these ports in your router. I think that you won't find any and there will be only a deny all for the incoming connections, but check this anyway.
    3. Do a routine security check to your pc using software like MBAM, HITMAN Pro and a-squared ( all have free versions ).
    4. If you want...try to disable the firewall component of your Avast suite and try another firewall. Keep the new firewall for a few days and monitor the situation. Then return back to avast after you have uninstalled the new firewall. ( Suggestions Online Armor, Outpost )
     
  8. Antarctica

    Antarctica Registered Member

    Joined:
    Feb 25, 2003
    Posts:
    1,618
    Location:
    Canada
    Thanks NoIos for your suggestions, really appreciate.:)
     
Loading...
Thread Status:
Not open for further replies.