MS says 3rd party defraggers on vista using vss problematic

Discussion in 'FirstDefense-ISR Forum' started by Horus37, May 5, 2007.

Thread Status:
Not open for further replies.
  1. Horus37

    Horus37 Registered Member

    Joined:
    Jan 4, 2007
    Posts:
    328
    Here is a link. Sounds kinda scarey about data corruption and using VSS which I know FDISR uses but different product. I wonder how PD8 uses VSS and if MS's warning about data corruption includes Raxco/leapfrog software? I'm thinking of the offline defrag with PD8 as an example of something that might apply. I'l forward this to raxco and see what they say. Wasn't sure where to put this thread but thought it might be of interest since it has to do with the VSS engine. Makes me want to switch to RSS. We'll see.

    http://news.softpedia.com/news/Don-...e-Block-during-Windows-Vista-Boot-53923.shtml
     
    Last edited: May 5, 2007
  2. Peter2150

    Peter2150 Global Moderator

    Joined:
    Sep 20, 2003
    Posts:
    17,039
    If I get a chance this weekend, I'll test.
     
  3. Peter2150

    Peter2150 Global Moderator

    Joined:
    Sep 20, 2003
    Posts:
    17,039
    Okay I did test. First I did a snapshot copy with FDISR. Ironically I couldn't get the ^(*&^ installer to run to install the patch. Yea Vista. But Build 173 of FDISR is working fine in Vista, so that is that.

    First attempt of offline defrag failed, and then realized I hadn't updated in the Vista snapshot, so I updated it. Offline defrag ran fine. I was fascinated to see my upgrade install of Vista had a hibernation file, but no Pagefile. I guess vista figured with 4gig I didn't need one.

    Anyway no problem with Perfect Disk and Vista.

    Pete

    PS I have the Business edition of Vista.
     
  4. TouchuvGrey

    TouchuvGrey Registered Member

    Joined:
    Jul 17, 2004
    Posts:
    441
    Location:
    South Mississippi USA ( ya'll )
    I've been using Auslogics DiscDefrag for the last month
    on my Vista Home Premium machine with no problem.



    Mike
     
  5. Horus37

    Horus37 Registered Member

    Joined:
    Jan 4, 2007
    Posts:
    328





    I'm using the newer 3.2 202 FDISR that moves the boot loader out of the MBR. The VSS copy engines are probably the same between the latest versions. I'm not using Vista yet but I've done plenty of offline defrags with PD8 latest version. I can't see any obvious data corruption from doing this. I'm fairly certain that is what the MS warning was about when booting up and doing an offline defrag in vista using VSS. I'm wondering if you made sure to switch over to using VSS instead of RSS? I remember you said you only use RSS.
     
  6. Peter2150

    Peter2150 Global Moderator

    Joined:
    Sep 20, 2003
    Posts:
    17,039
    Actually I turned VSS back on for a test and have left in on. No issues.
     
Thread Status:
Not open for further replies.