Missing truecrypt partition

Discussion in 'encryption problems' started by Nellemandela, Oct 14, 2012.

Thread Status:
Not open for further replies.
  1. Nellemandela

    Nellemandela Registered Member

    Joined:
    Oct 14, 2012
    Posts:
    2
    Location:
    Denmark
    [SOLVED] Missing truecrypt partition

    Hi

    I have a WD 2TB harddrive which has(or rather had) an encrypted non-system partition.

    Yesterday when trying to mount the volume, i noticed truecrypt only reported \device\harddisk2\partition0, and not partition1 as usual so i mounted it and windows explorer reported an error "invalid format or similar" when i tried to access the now mounted drive.

    I looked in diskmanager and saw that the usual RAW partition was gone, and all was unallocated, which has led me to conclude that the partitiontable went down the drain.

    DiskmanagerAndProperties.png

    After browsing around on the internet it seems that it is posible to get my data back if im able to create a new RAW partition (Without formatting anything of course) at the exact same spot and size as the old one was, and then mount the truecrypt volume using the volume header backup.. And this is where im stuck.

    I dont know what size i should create the partition with

    So i've added 2 attachments in hope that anyone can put me back on track

    1. The drive in winhex
    winhex.png

    2. The properties of the partition0 volume mounted
    DiskMounted.png

    Best regards
     
    Last edited: Oct 14, 2012
  2. Nellemandela

    Nellemandela Registered Member

    Joined:
    Oct 14, 2012
    Posts:
    2
    Location:
    Denmark
    Hi there,

    I solved it.

    The original volume was created using windows7, as is the machine i used to recover.

    Took a volume header backup of /device/harddisk2/partition0 to file.

    Using the wizard in disk manager i created a new partition (maximum size) and chose not to format.

    I restored the volume header backup from the file to /device/harddisk2/partition1 and mounted the volume

    Voila :)
     
  3. kraks

    kraks Registered Member

    Joined:
    Nov 1, 2012
    Posts:
    1
    Location:
    Denmark
    Hi Nellemandela

    I would very much like to hear a little more about your solution to this problem. I think I have kinda the same problem the only difference is I´m on a mac. I tried to pm you with no luck. Because I see that you also are from Denmark and then we go through this in our native language.

    My problem is I have a 2tb hdd encrypted with Truecrypt Hidden volume. Usually I have rdisk1s0 and rdisk1s1. One day my hdd crashed and after that I only had rdisk1s0, *s1 was gone.
    I have afterwards made a clone of the currupt hdd. It showed that I have about 9GB of bad sectors. My only priority is to log in to my hdd and copy the data of it.
    But I have no idea on how to do it. Hope you can help me.

    Thanks
     
Loading...
Thread Status:
Not open for further replies.