Missing Padlock on Bank Secure (https) Page with IE7

Discussion in 'other security issues & news' started by Green Giant, Nov 13, 2006.

Thread Status:
Not open for further replies.
  1. Green Giant

    Green Giant Registered Member

    Joined:
    Jun 18, 2003
    Posts:
    252
    Last week I installed IE7. I was concerned that when using the log on page to my Bank that no padlock appeared, although an embedded https URL appeared at the top of the page. There was no padlock to the right of this URL. My ISPs site and that of Amazon UK both showed the padlock for secure pages.

    At the suggestion of my Bank's IT Department, I reverted to IE6, before attempting another installation from a freshly downloaded IE7. Having removed IE7 yesterday, run RegVac Registry Cleaner (which runs overnight every day and which removed 887 entries yesterday), then defragmented the Registry, run CHKDSK and defragmented the hard drive, I could get the padlock again. Today having reinstalled a new download of IE7, there is no padlock for the Bank, but there is for Amazon and my ISP's secure pages.

    I have looked at the MS Message Board and the two threads there refer to those who were not aware of the resiting of the padlock. MS wanted £35 to deal with any e-mailed question!

    Has anyone else experienced this problem please and has a solution been found?
     
  2. Mrkvonic

    Mrkvonic Linux Systems Expert

    Joined:
    May 9, 2005
    Posts:
    8,703
    Hello,
    Try Firefox.
    Mrk
     
  3. Green Giant

    Green Giant Registered Member

    Joined:
    Jun 18, 2003
    Posts:
    252
    Thanks! I have been using Firefox since this possible weakness was spotted. The padlock appears normally, as it does with IE7 for my ISP, Amazon and CAF but not the Bank.
     
  4. Bubba

    Bubba Updates Team

    Joined:
    Apr 15, 2002
    Posts:
    11,271
    I'm not sure if it would be any different for other users of IE 7 but if you would like to share the URL of the site either privately or in thread....others could somewhat confirm whether the problem is on your end or IE 7 itself.

    Bubba
     
  5. crash79`

    crash79` Registered Member

    Joined:
    Jul 9, 2004
    Posts:
    114
    Location:
    Isle of Bute Scotland
    My bank has moved the padlock to the right of the address bar.
     
  6. Green Giant

    Green Giant Registered Member

    Joined:
    Jun 18, 2003
    Posts:
    252
    I am delighted to report that the problem has been solved thanks to Bubba's guidance through the personal message facility.

    The solution was to remove all references to the bank from 'Sites' (of IE7) in the Trusted Zone, then reset both Trusted and Internet Zones to the default level. The padlock then appeared to the right of the URL, which was then a dropdown rather than an embedded one.

    Grateful thanks!

    Green Giant.
     
Loading...
Thread Status:
Not open for further replies.