Mint security problem ?

Discussion in 'all things UNIX' started by Singu, Aug 4, 2010.

Thread Status:
Not open for further replies.
  1. Singu

    Singu Registered Member

    Joined:
    Aug 4, 2010
    Posts:
    2
    Mint cant authenticate downloaded packages by default. I installed Mint 9 KDE and noticed authentication failure on every package during first update. Went googling and found this thread on Mint forum which confirms that third most popular Linux distro is not capable of authenticating its own binaries, or any other binaries.
    http://forums.linuxmint.com/viewtopic.php?f=46&t=26343

    This is not mentioned in the Mint release notes as it should be, nor is there any debate or pressure on devs to sort it. Is this not a major security flaw or hole even?
     
  2. tlu

    tlu Guest

    Yes, that's something that has always annoyed me - it is a potential security hole. One of a couple of reasons why I went back to Kubuntu.
     
  3. linuxforall

    linuxforall Registered Member

    Joined:
    Feb 6, 2010
    Posts:
    2,136
    Wow another Kubuntu user, have you added the kubuntu updates ppa btw?
     
  4. Singu

    Singu Registered Member

    Joined:
    Aug 4, 2010
    Posts:
    2
    They should really mention this in the release notes and not hide this from users. This is not a way how opensource project should be run. On a side note, not one review of Mint i have lately read mentions this either, which is just crazy since this problem is Mint specific and doesnt touch other *buntu or debian distros and is worth mentioning. It is nice to have codecs preinstalled, but not at the price of safety or having to ponder vendor credibility.
    Link to excellent brief article explaining apt-get authentications:

    http://www.infodrom.org/~joey/Writing/Linux-Journal/secure-apt/
     
  5. tlu

    tlu Guest

    Yes, I have just today! I'm having the problem that kontact is causing heavy harddisk activity after every start in the past days (never before). The update to 4.4.5 hasn't helped in that matter. Do you have an idea what's causing that?
     
  6. tlu

    tlu Guest

    @Singu: I agree with everything you said. This is an issue that should be urgently fixed.

    BTW: Nice article, indeed!
     
  7. linuxforall

    linuxforall Registered Member

    Joined:
    Feb 6, 2010
    Posts:
    2,136
    Try system settings>advanced>desktop search, turn it off. In my case I have it on but I am not facing any issues so far, been running Kubuntu for more than a month. I don't use kontact though as I use Opera's M2 instead.
     
  8. tlu

    tlu Guest

    Strigi is already off, and Nepomuk is needed for Akonadi. The funny thing is that I hadn't this problem a few days ago.
     
  9. linuxforall

    linuxforall Registered Member

    Joined:
    Feb 6, 2010
    Posts:
    2,136
    Check which process is doing the hogging. Also uncheck save sessions in session manager. Turn off nepomuk, reboot and then turn it on again.
     
    Last edited: Aug 5, 2010
Loading...
Thread Status:
Not open for further replies.