Minor Cursor Issue

Discussion in 'LnS English Forum' started by aria1946, Jul 2, 2007.

Thread Status:
Not open for further replies.
  1. aria1946

    aria1946 Registered Member

    Joined:
    Sep 8, 2006
    Posts:
    20
    When I start L&S as an application, the Windows cursor is moved to the top left position on my desktop. This doesn't happen if I start it as a service.

    I discovered this in the beta a short time ago, but it exists in the 2.06 release as well.


    Tom
     
  2. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    This is strange. I've never encountered that.
    I don't remember having some other users reporting that too.

    When starting Look 'n' Stop as a service, how could you check that ?

    Thanks,

    Frederic
     
  3. aria1946

    aria1946 Registered Member

    Joined:
    Sep 8, 2006
    Posts:
    20
    Because when L&S is started as a service, the cursor doesn't move from the very center of the desktop. If I make ONLY the change to have L&S start as a system application (selecting "System" in Options), the cursor moves to the top left of my desktop at almost the exact same time as the L&S icon appears in the system tray.


    Tom
     
  4. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    So you mean this happens just after a user log on ? after windows is started, you get the cursor in the corner ?

    Do you have any special software or configuration which automatically moves the cursor into the active windows ? (like some feature moving the cursor on the OK button automatically when a dialog box opens).

    When Look 'n' Stop starts, just before being minimzed in the tray it is displayed in position outside the screen. This may be linked to what you are observing. However I don't know why you would be the only one (so far) affected by that...

    Frederic
     
  5. aria1946

    aria1946 Registered Member

    Joined:
    Sep 8, 2006
    Posts:
    20
    I am the only user of this machine, and I seldom just log off and on, but I do restart my system every day or two. I should add at this point that since I am the only user, I have used tweakUI to automatically log myself in when the system (re)starts.

    I don't use anything that moves the cursor around AFAIK. When L&S is started as a service, the cursor first appears dead-center in my desktop and does not move throughout all the loading of applications that follows.

    I also remember once while using the last beta that I was playing around with starting L&S as a system startup and then as a service that on one occasion it seemed that it was not removed from the startup group when I set it as a service, because at one point during system startup, L&S asked me if it was okay to start itself. I assumed at the time that it was the service wondering why a second instance was attempting to start as an ordinary application (I'm just guessing here). In any event, this only happened once and never again - probably because Looknstop.exe is still in my list of approved applications :)


    Tom
     
Thread Status:
Not open for further replies.