MailWasher Updates

Discussion in 'other software & services' started by anon, May 24, 2017.

  1. anon

    anon Registered Member

    Joined:
    Dec 27, 2012
    Posts:
    8,090
    MailWasher Pro 7.15.5
    June 20, 2024
    https://www.firetrust.com/products/mailwasher-pro/change-log
    Download MailWasher Pro:
    http://cdn.firetrust.com/downloads/mailwasher_pro/7/mailwasher_pro_setup_7_15_5.exe

    Download MailWasher Free:
    https://25fc482ddf92aa413bac-f38e90dc860e94d93d82757ea3e76c3d.ssl.cf2.rackcdn.com/downloads/mailwasher_free/mailwasher_pro_setup_7_15_05_free.exe
     
    Last edited: Jun 20, 2024
  2. Krusty

    Krusty Registered Member

    Joined:
    Feb 3, 2012
    Posts:
    10,289
    Location:
    Among the gum trees
    I upgraded the free version and now if I check for updates I'm getting this:

    MailWasher Update Check.PNG
     
  3. Brummelchen

    Brummelchen Registered Member

    Joined:
    Jan 3, 2009
    Posts:
    6,022
    which site? what about "View certifikate" clicked it?
    otherwise ask your local installed security software, which may intercepting and acting as MITM.
    the message is from windows, not mailwasher, see icon.
     
  4. Rainwalker

    Rainwalker Registered Member

    Joined:
    May 18, 2003
    Posts:
    2,728
    Location:
    USA
    Interesting......I received the same Security Alert yesterday, but with Steam. Maybe something to do with an update.
     
  5. Brummelchen

    Brummelchen Registered Member

    Joined:
    Jan 3, 2009
    Posts:
    6,022
    see #178 and please answer.
     
  6. Rainwalker

    Rainwalker Registered Member

    Joined:
    May 18, 2003
    Posts:
    2,728
    Location:
    USA
    Don't recall which site if any. I may have clicked on certificate to view. Not sure. I ended up closing it out and that was the last of that. Have not installed anything new of late. Now that you mentioned it I am thinking it may very well have been MITM.
     
  7. Brummelchen

    Brummelchen Registered Member

    Joined:
    Jan 3, 2009
    Posts:
    6,022
    i have 3 different (german) email providers on the run, and no issues. but i only use defender and no other intermitting software (means also no adblocker for windows).

    as this messages is from windows - MW itself uses the windows cert store so edgewebview do. so the problem probably exists between web and windows, not later. MITM as intercepting the receiving cert, unpacking, and re-packing with the security software cert. either the new cert is not inserted, or the provider is delivering a wrong or outdated one. as long i read here most times i assume an intercepting security software. sorry.
     
  8. Krusty

    Krusty Registered Member

    Joined:
    Feb 3, 2012
    Posts:
    10,289
    Location:
    Among the gum trees
    It only started after updating MailWasher. What ever IP MW uses for update checks.

    I do not have this with any other program. Happens on two machines, one with Defender, the other with Kaspersky Plus.
    Certificate.PNG

    Certificate 2.PNG

    On closing the notification I get this:

    Closing notification.PNG
     
  9. Brummelchen

    Brummelchen Registered Member

    Joined:
    Jan 3, 2009
    Posts:
    6,022
    not here, also fine.
    maybe your windows cert store has been damaged. or at least something outside, maybe vpn or similar.

    akamai is known as a cdn, if MW uses firetrust domain and its internal redirected, thats no MW problem, its a server side issue. maybe they corrected it last night. try again. if not resolved you should ask the firetrust support whats wrong.

    edit2: seems that MW free is a variant of MW pro setup, no key means free!?
     
    Last edited: Jun 22, 2024
  10. Krusty

    Krusty Registered Member

    Joined:
    Feb 3, 2012
    Posts:
    10,289
    Location:
    Among the gum trees
    Don't know, but I just downgraded to 7.12.188 and the error has disappeared.
     
  11. Krusty

    Krusty Registered Member

    Joined:
    Feb 3, 2012
    Posts:
    10,289
    Location:
    Among the gum trees
    Tried downloading a fresh copy of 7.15.5 installer and ended up getting the same error. Back to 7.12.188, error has disappeared again.
     
  12. Krusty

    Krusty Registered Member

    Joined:
    Feb 3, 2012
    Posts:
    10,289
    Location:
    Among the gum trees
    I've just emailed support with a link to this thread about my issue, but as I'm using the free version, I'm not sure if they will help or not.

    Will update once I've heard back.
     
  13. Page42

    Page42 Registered Member

    Joined:
    Jun 18, 2007
    Posts:
    6,951
    Location:
    USA
    Thank you. I have been reluctant to upgrade MWPro 7.12.188 to 7.15.5. Release Notes show lots of changes (more opportunity to break something). I'm staying with the Nov 2023 release for now. Hope it works out for you.
     
  14. Krusty

    Krusty Registered Member

    Joined:
    Feb 3, 2012
    Posts:
    10,289
    Location:
    Among the gum trees
    Well, they sent me a beta, but my issue above persisted. I haven't heard back since.
     
  15. anon

    anon Registered Member

    Joined:
    Dec 27, 2012
    Posts:
    8,090
  16. Krusty

    Krusty Registered Member

    Joined:
    Feb 3, 2012
    Posts:
    10,289
    Location:
    Among the gum trees
    Email from support:
     
  17. Brummelchen

    Brummelchen Registered Member

    Joined:
    Jan 3, 2009
    Posts:
    6,022
    you are welcome, thx for the feedback.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.