Macrium Reflect Free - problems restoring Linux partitions?

Discussion in 'backup, imaging & disk mgmt' started by peterk62, Sep 3, 2009.

Thread Status:
Not open for further replies.
  1. peterk62

    peterk62 Registered Member

    Joined:
    Feb 10, 2009
    Posts:
    47
    I tried using Macrium Reflect Free to move a dual-boot Windows XP/Ubuntu system to a new hard disk. The Windows XP partition was restored without any problems, but I ran into a few issues trying to restore Linux (ext3 with 128-byte Inode :

    • I was not able to create a gap for the Windows data partition, which was not in my disk image. Macrium Reflect tried to restore the Linux partition right after the Windows partition. This is not a major issue since I can pre-partition the new drive.
    • After manually creating the Windows data partition, Reflect Free tried to expand the Linux partition to fill the empy space on the disk. I was not presented with an option to keep the restored partition the same size or to resize it.
    • After manually creating empty Linux partitions, the restore seemed to work but the data in the partitions was corrupt. Gparted showed that the used space in the Linux partitions was much larger than it should be.
    It seems to me that the free version of Reflect does not really support ext3 partitions since it appears to be trying to grow them to fill the available free space, but it seems to corrupt the partition in the process.

    Does anyone have experience restoring Linux partitions using Reflect Free? Unfortunately their forums are open only to users of the paid product so I can't ask there unless I buy a copy.
     
Loading...
Thread Status:
Not open for further replies.