Lost PCMCIA ATA memory card within Vista

Discussion in 'Acronis Disk Director Suite' started by Richard Patch, May 21, 2007.

Thread Status:
Not open for further replies.
  1. Richard Patch

    Richard Patch Registered Member

    Joined:
    May 21, 2007
    Posts:
    7
    While in the Vista Operating system I repartitioned my Panasonic 40M PCMCIA ATA memory using DD10. The card was recognized as the E: drive and all looked well. I next put in a couple of files and the Win 98SE boot data. Shortly later I lost the drove designation. Since the drive does not appear on Windows Explorer or on the list of drives in the DD10 software the 40 meg the card appears to have died. Is there some way that I can bring the card back to life?
     
  2. K0LO

    K0LO Registered Member

    Joined:
    Mar 9, 2006
    Posts:
    2,591
    Location:
    State College, Pennsylvania
    Richard:

    You might try booting your machine from the standalone version of DD10 in "safe" mode. This mode will show all drives recognized by your machine's BIOS. I use this mode when partitioning USB flash drives because the other modes of DD10 ("full" mode or in Windows) do not recognize removable drives.

    Another thing to check -- can you see the card using the Disk Management console in Vista? If so you could try to assign the card a drive letter or try reformatting and partitioning it with the Vista disk tools.
     
  3. Richard Patch

    Richard Patch Registered Member

    Joined:
    May 21, 2007
    Posts:
    7
    Mark,

    Thank you for the suggestions. I tried both suggestions but could not make the PCMCIA card visible. I may have pulled the card out of the slot before the Vista file transfers were completed. Premature ejection may be the problem.

    If you have any other suggestions I am willing to try them.

    Is going to Linux a possible solution? I have a bootable Knoppix 5.1, but do not know how to use it.
     
  4. K0LO

    K0LO Registered Member

    Joined:
    Mar 9, 2006
    Posts:
    2,591
    Location:
    State College, Pennsylvania
    Richard:

    Yes, Knoppix is the "swiss army knife" of PC repair. I would give it a go. Try booting from Knoppix with your drive attached. After it is running, go to the menus at the bottom of the screen and start the "Root Terminal". Type in the command
    Code:
    fdisk -l
    and post your output (that's a lower-case L in the command).

    See if Knoppix has a copy of gparted, the graphical partition manager. If so, run it and see if it can see the partition structure on your drive. You'll have to switch to the correct drive using the drop-down box in the upper-right corner of the program.

    Could you also let us know the model and manufacturer of your device so that we can see what you're dealing with? It sounds like a 40 GB solid-state IDE hard drive; is that correct?
     
  5. Richard Patch

    Richard Patch Registered Member

    Joined:
    May 21, 2007
    Posts:
    7
    Mark,

    We are making some real good progress. For the first time since I lost the PCMCIA solid-state drive I can now see that I have a drive. The fdisk –l in Knoppix show that I do have the drive. I do not know if my 5.1 Knoppix has the gparted program. I am not familiar enough with Linux to find it, but I will keep trying.

    I did a Google search and found a manual on GNU “parted” which looks like what you are describing. It sure looks like what I need to solve my problem. I do not know how to do a directory search on my Knoppix disk, but I will dig a little deeper.

    My PCMCIA card is made by Panasonic and it is a 40MB ATA card.
     
  6. K0LO

    K0LO Registered Member

    Joined:
    Mar 9, 2006
    Posts:
    2,591
    Location:
    State College, Pennsylvania
    Richard:

    Good! Then try this. I just fired up my copy of Knoppix 5.10 to check, and gparted is included. You can find it on the "K" menu under "System" and then "Gnome Partition Editor". See the attached screen shot.

    Before you start gparted you need to first click on the Knoppix menu (the penguin to the right of the "K" menu) and choose "Set password for root". Enter a password to use ("root", for example), then start the Gnome partition editor. It will ask you for the root password when starting up.

    On the drive selector drop-down list in the upper-right corner, select the designator for your solid-state drive. It would be helpful if you could post a picture of what you see. I've posted a view of my USB flash drive containing Knoppix and BartPE below as an example. So go to the "K" menu and select "Graphics" and then "KSnapshot Screen Capture Program". Choose "Window under Cursor" for the Capture Mode, click on "New Snapshot" and then click your cursor on the gparted window.

    If you have a USB flash drive, plug it into the PC and you should soon see a device icon for it appear on the desktop. Open the device by double-clicking to display the contents of your flash drive. Since the drive will automatically be mounted as read-only, you'll have to first right-click on the desktop icon and choose "Change read/write mode" to make it writeable. Then choose "Save As" in the screen capture program and save the image to your flash drive. Right-click on the drive icon again and this time choose "Unmount", unplug the drive, connect it to your Windows PC and then post the resulting image file back here.
     

    Attached Files:

  7. Richard Patch

    Richard Patch Registered Member

    Joined:
    May 21, 2007
    Posts:
    7
    Mark:

    Thank you in advance for all of your patience that you will need to pace me through this exercise. You are dealing with a 79-year-old retired engineer with a house full of computer toys.

    I am having trouble with:”You can find it on the "K" menu under "System" and then "Gnome Partition Editor". See the attached screen shot.”

    I am sitting with the: [DR-DOS] A:\>

    How do I get to the "K" menu under "System" and then "Gnome Partition Editor"”?
     
  8. K0LO

    K0LO Registered Member

    Joined:
    Mar 9, 2006
    Posts:
    2,591
    Location:
    State College, Pennsylvania
    Richard:

    It sounds like you're running DR-DOS. You need to be running Linux.

    Boot your PC with the Knoppix CD and then take it from there...
     
  9. Richard Patch

    Richard Patch Registered Member

    Joined:
    May 21, 2007
    Posts:
    7
    Mark:

    I am booting with a CD that I thought was Linux Knoppix 5.1. I probably have the wrong software. Could you provide me with a download URL that will get me the correct software?

    Thanks again.
     
  10. MudCrab

    MudCrab Imaging Specialist

    Joined:
    Nov 3, 2006
    Posts:
    6,482
    Location:
    California
  11. Richard Patch

    Richard Patch Registered Member

    Joined:
    May 21, 2007
    Posts:
    7
    Mark;

    I had the correct Knoppix V5.1 iso file. If one is interested in burning the iso to CD using Nero, you would follow the steps below:
    Nero 5 and 6
    · Open Nero
    · Go to Recorder -> Burn Image...
    · Choose the image
    · Choose type of disc in top left of window
    · Size
    · Then Burn!
    If you follow this procedure you will get a Linux bootable disk. This is what we wanted.

    If you ask Nero for a bootable disk using the same iso with an alternate approach, you will get a DOS boot disk. This was my error in arriving at a DOS prompt with my first Knoppix boot disk.

    I am now back to aiming for Gparted. I will revert back to your detailed explaination of how to put it all together. This will be the task for Wendsday.
     
  12. K0LO

    K0LO Registered Member

    Joined:
    Mar 9, 2006
    Posts:
    2,591
    Location:
    State College, Pennsylvania
    Richard:

    It sounds like you're on the right track. When you get back to this project then please repeat the fdisk -l command before doing anything else. See my post #4 above. When you did the command before you inadvertently ran the DOS fdisk command, which is different.

    I would like to see how Linux sees the layout of your solid-state drive. Please post the output of the command here.
     
  13. Richard Patch

    Richard Patch Registered Member

    Joined:
    May 21, 2007
    Posts:
    7
    Mark:

    Just a short note letting you know that I have not given up on this project. I now have Knoppix 5.10 running. I learned how to setup a password, open gparted, take pictures with the "KSnapshot Screen Capture Program" and how to setup the external USB to the writeable mode. I can see all of my device icons on the desktop.

    I am presently fighting with the problem of getting the saved screen shot pictures to my USB device. I am currently trying to understand “Then choose "Save As" in the screen capture program and save the image to your flash drive”.

    Your instructions are very precise. I expect that some of your background be in teaching.

    You are very good at it.
     
  14. K0LO

    K0LO Registered Member

    Joined:
    Mar 9, 2006
    Posts:
    2,591
    Location:
    State College, Pennsylvania
    Richard:

    Does it really show? Yes, I am a teacher by trade...

    One way to do this is to save your screen capture to the desktop. Then after it's been saved, open the flash drive window and drag the image to the flash drive. Don't forget to unmount the drive before unplugging it (that's an analogous function to Windows "safely remove hardware"; it ensures that all disk writes have finished).
     
  15. K0LO

    K0LO Registered Member

    Joined:
    Mar 9, 2006
    Posts:
    2,591
    Location:
    State College, Pennsylvania
    Richard:

    I received your screen shots and the drive looks just like I suspected. Your current partition table is either missing or damaged, so that’s probably why Windows won’t recognize the disk.

    Here’s what you need to do:

    1. Optional but recommended – zero the first part of the drive to remove any erroneous information from the old partition table. In Knoppix, open a root terminal and type this command:
    Code:
    dd if=/dev/zero of=/dev/hde count=64
    Short explanation: dd is the direct disk edit command in Linux, “if=/dev/zero” specifies the source of the data to write, in this case a special system device called “zero”, which writes bytes of 00; “of=/dev/hde” specifies the output (destination) of the disk writes, in this case your 40 MB drive is identified by the system as “hde” according to the screen shots that you sent me; and finally “count=64” tells dd to write zeros to the first 64 sectors on the drive. The partition table and any boot loaders are contained in sectors 0 – 63 and the identifying data for the first partition on the drive is contained in sector 64, so we want to wipe out any remnants in those first 64 sectors. If you want you can leave off the "count=64" and then the entire drive will be zeroed. You will see an error message when it reaches the last sector in the drive and runs out of space.

    2. Next start gparted and select your device “hde” from the drop-down box at the top right of the window. Go to the “Device” menu and choose “Set Disklabel”. Accept the default options and click on the “Apply” button. This step will create a new, blank partition table and write a standard master boot record to the drive.

    3. At this point you could exit Knoppix and reboot into Windows and you should now see your drive, although it will be unformatted. You could then use Acronis Disk Director to create partitions and format them to your choosing. Or, continue with gparted and use it to create your partitions and format them. However, just be aware that gparted lacks the facility to name the partitions so you’ll need to use other tools to do that.

    Here is a tutorial on gparted if you need more information:

    http://gparted.sourceforge.net/larry/generalities/gparted.htm
     
Thread Status:
Not open for further replies.