Look 'n' Stop and Windows XP Shutdown

Discussion in 'LnS English Forum' started by richter, Jan 3, 2004.

Thread Status:
Not open for further replies.
  1. richter

    richter Guest

    Hello,

    I checked FAQs on this and I couldn't find anything. As FAQs for 2.05 beta 1 are not available, I'm hoping you will be able to answer my question.

    I started using L 'n' S recently and I'm amaized with its functionality and size. I like it. I'm (beta) testing it to see if I'll stay with it or not. So far it works quite well but I've problem that shutdown, restart, log off takes a couple of minutes to complete while L 'n' S is running. If I quit application before shutdown, everything seems to be going normal and fast.

    I haven't tried v 2.04 as I always test newest applications. Would you recommend me going to older version, or there's something I can do about this slow shutdown problem? It's not a big problem, but still would like to do something about it, if possible.

    TIA!

    Richter
     
  2. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    Hey richter

    The Look ‘n’ Stop v2.05b1 Help file had been updated.

    Is this problem reproduced every time even without making new changes to Look ‘n’ Stop? What Operating System you using?

    Uninstalling v2.05b1 and re-booting and installing v2.04 would be interesting to determine if something specific in v2.05b1.

    Regards,
     
  3. richter

    richter Guest

    Hello,

    Sorry, I forgot to include version info. I am using Win XP Pro with SP1. On my machine it happens every time when I am shutting down or restarting my system. The only application that runs in the background besides L 'n' S is AdMuncher.

    I just installed v2.04pb2, as in post above it's not beta version and Frederic did mention this:

    I thought that would solve my problem, but It didn't. I just tried rebooting, shutting down several times, first with "out of the box" settings then trying to alter some settings in advanced options and everything remains the same.

    If it makes any difference, it's not registered copy, I'm in process of testing it, but it shouldn't make any difference as neither trial expired (it was installed before Christmas) nor firewall seems to have any locked features. I have never used this firewall before so I am not fully familiar with it. If there's anything (export log or similar) that I can do to help you out solving this, let me know.

    I just wanted to ask one more question, sometimes settings are not saved after reboot/shutdown, so you have to re-do them and then it seems to work.

    Regards,

    richter
     
  4. richter

    richter Guest

    Sorry to re-post. I forgot to include this into my reply.

    From changelog of 2.04pb2:

    Modification in the way Look 'n' Stop handles the "Windows Ending Session" event (in order to improve/fix the slowness issue when Windows is being closed).
     
  5. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    Hey richter

    Obviously the problem doesn’t seem to be specific to v2.05b1, and the way you described it, it does appear Look ‘n’ Stop GUI is the culprit for the abnormal delay upon shutdown.

    It is puzzling because Frederic had fixed this anomaly quite some time ago, and since no-one to my knowledge reported anything of the sort.

    * Try Disabling Just Application Filtering Layer and shutdown
    * Try Disabling Just Internet Filtering Layer and shutdown
    * Try Disabling both Application Filtering Layer and Internet Filtering Layer and shutdown.

    In Options screen enable “Common to all users” and checkmark “Extra Save”
     
  6. richter

    richter Registered Member

    Joined:
    Jan 3, 2004
    Posts:
    51
    Hello,

    I don't know why is this happening but it seems nothing helps to solve the issue. It could be system specific as I haven't seen any posts regarding my problems.

    I tried everything you proposed. At first I disabled Application Filtering. Tried both shutdown and reboot options and it didn't help. Both processes took a long time to complete. When I do either of the things, it takes a minute or so to show log off screen. If you try to run an application I get notification that application couldn't be initialized because windows is being shut down. When it gets to Log Off screen it takes just as long to get to Windows is shutting down message, after which system normally shuts down. I also tried just disabling Internet Filtering (with Application Filtering on) and disabling both. Same result.

    I must say that system is clean, freshly installed and I didn't have any firewall installed before L 'n' S. If you thing it might be an application causing this, I can tell you what else I've installed. The things that run during start up are MS CTF monitor (a part of MS Office), NeroCheck, jusched (part of Sun Java) and AdMuncher. Of course, I'm sure you're aware of other services that Windows run by default.

    Thank you! The weird thing is that I did check this when I first installed it but started to work only when I manually closed L 'n' S and manually started it again, after which everything seems to be ok. It didn't work if you enabled it and then reboot/shutdown. After which, settings seem to be lost. Weird.

    Best regards,

    richter
     
  7. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    Hey richter

    Could you try renaming the Application Filtering driver Temporary?

    %SystemRoot%\System32\Drivers\lnsfw1.sys
    To %SystemRoot%\System32\Drivers\lnsfw1.sy_

    And re-boot, then shutdown?


    Thanks in Advance
     
  8. richter

    richter Registered Member

    Joined:
    Jan 3, 2004
    Posts:
    51
    Hello,

    I renamed the file. Tried rebooting, everything remained the same. Windows started up. Got notification about failing to load lnsfw1 driver (error 0). Tried to Shut down. Process lasted long, as usual.

    richter
     
  9. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    Hey richter

    Nothing else comes to mind at the moment, I believe the best thing to-do now is to wait for Frederic to read and respond to this topic.

    Excellent btw, you definitely deserve a karma cookie… :)
     
  10. richter

    richter Registered Member

    Joined:
    Jan 3, 2004
    Posts:
    51
    Hi,

    Thanks for the help and a karma cookie! :)

    It's not top priority issue, I guess. In case there is something I could assist you with further info/testing, let me know.

    Best,

    richter
     
  11. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    This confirms that Look 'n' Stop is blocked somewhere before saving the options (which occurs only when Look 'n' Stop is stopped), and so Windows after a while decides to kill the application.

    Unfortunately, I've no idea about how solving/investigating the issue right now. One or two other user reported this problem which seems very rare.

    Frederic
     
  12. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    Richter if you experienced in REGEDIT could you goto the following location and paste the values for the following;

    [HKEY_CURRENT_USER\Control Panel\desktop]
    "AutoEndTasks"="?"
    "HungAppTimeout"="?"
    "MenuShowDelay"="?"
    "WaitToKillAppTimeout"="?"
    "WaitToKillServiceTimeout"="?"


    Thanks in Advance!
     
  13. richter

    richter Registered Member

    Joined:
    Jan 3, 2004
    Posts:
    51
    Hello,

    Sorry for late reply but I wasn't able to respond sooner. I had to uninstall LnS and use Tiny PF after I reported this problem. I downloaded latest beta and installed it a few minutes ago. The shutdown/restart problem seem to be gone and the computer doesn't hang. However, the current values are not windows default as they were when I had LnS installed (it was a fresh windows install). These are altered values:

    "AutoEndTasks"="1" 1
    "HungAppTimeout"="3000" 3000
    "MenuShowDelay"="150"
    "WaitToKillAppTimeout"="5000"
    "WaitToKillServiceTimeout"="?" - Don't see the value so I can't post exact value

    I had to disable LnS to be able to browse. I don't know why is it blocking my connection. I'll have to close more closely in settings to determine what's causing this.

    Regards,

    richter
     
  14. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    Hey richter

    Tweaking of this area can cause those problems with Look ‘n’ Stop or any Application, but if she is working great now that is great!

    Looks as if DNS server is being blocked, what rule-set you using?
     
  15. richter

    richter Registered Member

    Joined:
    Jan 3, 2004
    Posts:
    51
    Hi,

    Don't know what happened in the meantime. I'm just glad LnS is working as it should now. It could have been some settings that "bothered" LnS.

    I "figured out" that if Protocol Filtering is enabled I can't browse. If I disable it, it works fine.

    Here's what's listed there:

    WANARP.SYS - Allowed: No, Log: Yes, Active: Yes
    NETBT.SYS - Allowed: Yes, Log: N/A, Active: Yes*
    TCPIP.SYS - Allowed: Yes, Log: N/A, Active: Yes*

    Should WANARP.SYS be enabled? Is it safe to enable it all and activate Protocol Filtering? Sorry for not posting this in new thread and not checking FAQs first.

    Thanks in advance!

    Regards,

    richter
     
  16. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    Hey

    Yea obviously WANARP.SYS is needed to be authorized, is safe, do so... :)
     
  17. richter

    richter Registered Member

    Joined:
    Jan 3, 2004
    Posts:
    51
    Thanks very much for help and fast reply!!!

    I will allow it and enable Protocol Filtering. I hope that fixes things.

    regards,

    richter
     
  18. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    It will :)
     
  19. richter

    richter Registered Member

    Joined:
    Jan 3, 2004
    Posts:
    51
    Yup, it worked fine. :) Thanks for helping me out with this - things are working much faster than when I had Tiny installed. What a relief!

    regards,

    richter
     
  20. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    Not a prob! Any time! :)
     
  21. richter

    richter Registered Member

    Joined:
    Jan 3, 2004
    Posts:
    51
    Spoke too soon.

    The same problem re-appeared this morning and it's definitely LnS related. The only thing I did was that I installed Firefox 0.8 yesterday. I don't think that should have any impact on this particular bug. I have uninstalled LnS - the other things I had problem with was that Enhaced ruleset didn't show all rules after a reboot and DLL in advanced configuration just went blank.

    Regards,

    richter
     
  22. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    Hey richter

    I’m using Windows XP Pro and the Default values for

    [HKEY_CURRENT_USER\Control Panel\desktop]
    "AutoEndTasks"="?"
    "HungAppTimeout"="?"
    "MenuShowDelay"="?"
    "WaitToKillAppTimeout"="?"
    "WaitToKillServiceTimeout"="?"

    Are

    [HKEY_CURRENT_USER\Control Panel\Desktop]
    "AutoEndTasks"=dword:00000001
    "HungAppTimeout"="5000"
    "MenuShowDelay"="150"
    "WaitToKillAppTimeout"="2000"
    "WaitToKillServiceTimeout"="2000"

    As-is never giving me problems, and people who experienced this anomaly always used Tweaks that altered these settings.

    Also its always good idea to click “Save” button in Internet Filtering screen to save rule-set changes, and when modifying Look ‘n’ Stop settings its also good idea to click “Apply” button. These recommendations can also avoid slow shutdowns, and Look ‘n’ Stop saving anomalies also. And use of "Common to all users" selection in Options screen is advisable too.
     
  23. richter

    richter Registered Member

    Joined:
    Jan 3, 2004
    Posts:
    51
    I uninstalled it and reinstalled it again this morning. Things seem to be working fine at the moment. I really don't know what's going on with my installation. It works for a day or two and then it goes nuts, and everything seems to be fine when I reinstall. I can control DLLs again, rules are imported properly, changes are saved.

    If I find any other problem with it, I'll probably post again, lol. If I encounter this "shutdown problem" again I don't think it's worth troubling you over it as it's not crucial.

    Regards,

    richter
     
  24. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    Possibly it depends on how many things currently running in the background richter?
    Perhaps if you have some time to spare try running bunch of stuff like firebird browser and whatever else you can get running on there and then shutdown.

    Keep in mind to reproduce that anomaly you may have to avoid clicking save and apply buttons in Look ‘n’ Stop.

    In any case this problem or other problems you possibly have, I don’t mind one bit in helping you! ;)
     
  25. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    However if you do experience that persistent problem try doing following;

    Create text file, rename it to LNS.reg and right click goto Edit and add;

    REGEDIT4
    [HKEY_CURRENT_USER\Control Panel\Desktop]
    "AutoEndTasks"=dword:00000001
    "HungAppTimeout"="5000"
    "MenuShowDelay"="150"
    "WaitToKillAppTimeout"="2000"
    "WaitToKillServiceTimeout"="2000"
     
Thread Status:
Not open for further replies.