Long pause when starting partition backup

Discussion in 'Paragon Drive Backup Product Line' started by DickK, Oct 18, 2013.

  1. DickK

    DickK Registered Member

    Joined:
    Oct 18, 2013
    Posts:
    6
    Location:
    England
    When I backup my Windows 7 computer, I have 2 partitions to backup. It seems to take 10-15 minutes initialising the backup operation on each partition before starting the write operations. This started with Backup and Restore 10 after using it with no delay for years. I upgraded to Backup and Restore 2013 and the same thing happened. On one occasion it worked without delay after switching my backup drive to the USB lead previously used by my printer, but it subsequently reverted to the long delay. Initially, I thought that the backup had silently crashed, but by accident left it trying only to discover it had started when I came back 1/2 an hour later. All other operations on the backup drive work fine.
     
  2. Mech_An

    Mech_An Registered Member

    Joined:
    Mar 29, 2010
    Posts:
    855
    Long preparing stage could be caused by automatic file system check operation before backup.
    Maybe your source partitions are quite fragmented and check takes longer than usually.

    In 2013 version Paragon products got improved and full support of NTFS journal, that's why some operations now could take more time required for careful work with NTFS journal.

    I'd suggest to run CHKDSK for source volumes and check if preparing stage will go faster.
     
  3. DickK

    DickK Registered Member

    Joined:
    Oct 18, 2013
    Posts:
    6
    Location:
    England
    I have now run defragmenter and CheckDisk on both the partitions to be backed up and on the destination partition, but the delay remains. I suspect that the problem is another symptom of a bug that is recognized to have existed in several versions of Windows for many years. The symptoms include:
    1. Cannot eject USB drive. If you google for this you will find numerous posts. Something in Windows keeps files locked even though nothing the user has loaded is using the drive. There are a few avoidance methods posted in response, but no cure.
    2. Removable drives are flagged as fixed (sometimes mentioned in above posts).
    3. Shutdown delayed a minute or two while locks on these drives are released
    4. Similar delays or lock up as mentioned in my original post with other drive backup procedures
    I think that I may have to live with this problem. Total backup time is about an hour of which nearly half is this delay. I also noticed that there is delay of several minutes at the end of a partition when the index is being backed, during which there is no disk activity.
     
Loading...