Logitech 5.1 surround speakers and Toshiba A660

Discussion in 'hardware' started by DVD+R, Feb 12, 2011.

Thread Status:
Not open for further replies.
  1. DVD+R

    DVD+R Registered Member

    Joined:
    Aug 2, 2006
    Posts:
    1,979
    Location:
    The Antipodes
    I just got some logitech speakers of my Nephew, he had them a while, but has now upgraded to Bose :cool: but missing are the green/ yellow/ and black computer sound card to sub woofer cables, I could only find the basic red and white auxiliary cables in my local store, but of course without the others the sub woofer wont kick in, neither will the control panel to adjust sound/matrix etc, it will turn the speakers on or off, but the volume adjust wont work. does anyone know where I can get these? remember I'm in west australia, so somewhere over the Atlantic wont help lol... so just wondering if any fellow aus dweller can shed a little light:shifty:
     
  2. Cudni

    Cudni Global Moderator

    Joined:
    May 24, 2009
    Posts:
    6,956
    Location:
    Somethingshire
    I'm on another continent nevertheless fingers crossed you find it
     
  3. Carver

    Carver Registered Member

    Joined:
    Feb 5, 2006
    Posts:
    1,827
    Location:
    USA
    I have a logitecZ-5500 5.1 speaker set but I am in the United States here is the address for logitech in Australia http://www.logitech.com/en-au/speakers-audio/home-pc-speakers, this is the speaker section. You could order a new set or pickup three audio stereo cables in Radio shack, maybe someone from Australia can give you a more exact answer
     
  4. DVD+R

    DVD+R Registered Member

    Joined:
    Aug 2, 2006
    Posts:
    1,979
    Location:
    The Antipodes
    Thanks Guy's I've fixed it! turns out it was nothing to do with cabled so to speak, i noticed that when connecting the control panel, there was a bent connector pin, straightening that, has fixed up thee problem :D
     
Loading...
Thread Status:
Not open for further replies.