LnSSvc 1.01b2 ouvre deux fois LnS en fermant et ouvrant un autre profil WinXP ???

Discussion in 'LnS French Forum' started by General Noel, Sep 13, 2005.

Thread Status:
Not open for further replies.
  1. General Noel

    General Noel Registered Member

    Joined:
    May 3, 2005
    Posts:
    68
    J'utilise LnSSvc pour executer LnS en tant que Service de Window XP. J'ai deux profils utilisateurs sur mon laptop

    Cependant la premiere fois que je ferme ma session WinXP et ouvre une autre, LnS exécute 2 fois Lns, une dans la bare de tache ce qui est normal, l'autre en pop up que je suis obligé de fermer.

    (si par la suite je referme la session et ouvre une autre session voire la meme je n'ai pas le probleme)

    Est-ce que c'est un problème lié à LnSSvc 1.01b2 ? C'est agaçant ce petit bug :'(

    Quelqu'un a une idée ?

    Merci
     
  2. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Bonjour,

    C'est curieux que le problème ne soit pas systématique.

    Si je comprends bien:
    - lors de l'ouverture de la toute première session tout est Ok
    - lors du premier arrêt de session + réouverture d'une 2ème session => 2 Look 'n' Stop
    - lors des arrêt + réouverture suivants tout est Ok ?

    Il se peut que ce soit lié à un problème de timing.

    Juste pour vérifier un truc: faites un test où vous attendez 15 secondes avant de réouvrir la 2ème session.

    Autre essai à faire: fermez Look 'n' Stop avant d'arrêter la session, juste pour voir si par hasard c'est une vieille instance qui reste ouverte, ou si vraiment 2 sont lancées.

    Frédéric
     
  3. General Noel

    General Noel Registered Member

    Joined:
    May 3, 2005
    Posts:
    68
    Frédéric,


    Merci du conseil mais malheureusement ce n'est pas (apparemment) un problème de timing. J'ai ouvert une 1ere session, puis vérifié avec Process Explorer de Sysinternals tout ce qui se rapportait à LnS.


    PID 1020 - Process LnSSvc.exe - Description LnSSvc - Company Name Soft4Ever - DEP Status On - Version 1.00.0000.0001 - Path C:\Program Files\Soft4Ever\LnSSvc 1.01b2\LnSSvc.exe - handle 26 - Private Bytes 400 K - Virtual Size 14036 K - Thread 2

    PID 1068 - Process looknstop.exe - Description Look 'n' Stop Firewall Personnel - Company Name Soft4Ever - DEP Status OFF - Version 2.00.0000.0005 - Path C:\Program Files\Soft4Ever\looknstop\looknstop.exe - handle 154 - Private Bytes 3 840 K - Virtual Size 52660 K - Thread 9



    Ensuite , j'ai fermé ma session et ouvert une 2eme 30 secondes plus tard.

    J'ai eu le pop up LnS (celui qui me dérange !!) et également 2 icones LnS dans ma barre de tache. J'ai ouvert ensuite Process Explorer et j'ai eu les process suivants :


    PID 1020 - Process LnSSvc.exe - Description LnSSvc - Company Name Soft4Ever - DEP Status On - Version 1.00.0000.0001 - Path C:\Program Files\Soft4Ever\LnSSvc 1.01b2\LnSSvc.exe - handle 34 - Private Bytes 536 K - Virtual Size 19456 K - Thread 3

    PID 3196 - Process looknstop.exe - Description Look 'n' Stop Firewall Personnel - Company Name Soft4Ever - DEP Status OFF - Version 2.00.0000.0005 - Path C:\Program Files\Soft4Ever\looknstop\looknstop.exe - handle 155 - Private Bytes 3820 K - Virtual Size 52648 K - Thread 9

    PID 3000 - Process looknstop.exe - Description Look 'n' Stop Firewall Personnel - Company Name Soft4Ever - DEP Status OFF - Version 2.00.0000.0005 - Path C:\Program Files\Soft4Ever\looknstop\looknstop.exe - handle 128 - Private Bytes 2896 K - Virtual Size 45884 K - Thread 4

    Cela dit, la fameuse fenête de pop up LnS s'ouvre avec aucun paramètre de le filtrage logiciel, filtrage internet, et sans licence !! (mais le code 010DE5F6011F est le même). Je ferme donc la fenêtre pop up et regarde les process qui restent : PID 1020 et 3196 (PID 3000 ayant disparu en fermant la fenêtre).



    J'ai fermé la 2eme session et retourné à la 1ere session ( plus de pop up). Process Explorer m'affiche les infos suivantes :

    PID 1020 - Process LnSSvc.exe - Description LnSSvc - Company Name Soft4Ever - DEP Status On - Version 1.00.0000.0001 - Path C:\Program Files\Soft4Ever\LnSSvc 1.01b2\LnSSvc.exe - handle 34 - Private Bytes 540 K - Virtual Size 19456 K - Thread 3

    PID 2612 - Process looknstop.exe - Description Look 'n' Stop Firewall Personnel - Company Name Soft4Ever - DEP Status OFF - Version 2.00.0000.0005 - Path C:\Program Files\Soft4Ever\looknstop\looknstop.exe - handle 153 - Private Bytes 3820 K - Virtual Size 51624 K - Thread 8



    Conclusion : Lorque que je ferme une session et ouvre une autre, seul le process ID lié à LnSSvc.exe reste (ici PID 1020)


    Est-ce que ces infos sont plus parlantes ? Que puis-je faire de plus ?

    Merci de votre aide.


    General Noel
     
  4. General Noel

    General Noel Registered Member

    Joined:
    May 3, 2005
    Posts:
    68
    Encore une info : Lorque je ferme LnS dans ma première session, et que j'ouvre la 2eme session j'ai le même résultat

    General Noel
     
  5. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Ok, merci pour ces infos.

    Normalement LnsSvc ne peut pas de lui même lancer 2 instances de Look 'n' Stop.
    Donc si ce n'est pas lui c'est la 2ème instance est lancée autrement.
    Pourriez-vous vérifier que dans la base des registres des 2 utilisateurs, il n'y a pas d'entrée Look 'n' Stop dans:
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]
    ni dans
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run]
    et rien non plus dans le menu Démarrer/Programme/Démarrage pour chaque utilisateur.

    Frédéric
     
  6. General Noel

    General Noel Registered Member

    Joined:
    May 3, 2005
    Posts:
    68
    Bonjour Frédéric,

    Désolé, mais il n'y a aucune référence à LnS dans la base de registre au démarrage...

    Cela dit, il semble que c'est LnSSc.exe qui exécute looknstop.exe avec un nouveau PID à chaque fois. Je suis prêt à repasser en mode "normal" (sans LnSSc.exe) mais j'ai l'impression que c'est bien LnSSc.exe qui est à l'origine de ce comportement.

    Merci de toute autre idée

    General Noel
     
  7. General Noel

    General Noel Registered Member

    Joined:
    May 3, 2005
    Posts:
    68
    Frédéric,

    J'ai vu votre réponse (en anglais) le September 17th, 2005, 06:45 AM dans le Stread Update of LnSSvc for XP-SP2

    Je n'utilise pas la fonction FUS. Toutefois est-ce qu'on parle de la même chose ?

    Merci

    General Noel
     
  8. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Non, pour moi ce n'était pas la même chose, FUS c'est vraiment avoir 2 utilisateurs loggés en même temps et passer de l'un à l'autre. Avec ce mode d'utilisation, il y a effectivement quelques problèmes, et le LnSSvc n'arrange rien.

    Pour moi on parlait d'une fermerture de session complète d'un utilisateur, puis l'ouverture d'une nouvelle session pour un nouvelle utilisateur. C'est bien cela ?
    Si oui c'est curieux que cela pose problème.

    Pour ne plus être en mode service, et faire un test de ce genre, il suffit juste d'ouvrir la liste des services dans Windows et de passer le mode de démarrage sur désactivé pour "Look 'n' Stop Service". Déjà jusrte faire cela et vérifier que Look 'n' Stop ne se lance plus du tout pour aucun utilisateur.

    Frédéric
     
  9. Ricou

    Ricou Registered Member

    Joined:
    Sep 5, 2005
    Posts:
    2
    Bonjour,

    Je viens m'insérer dans la discution pour dire que j'ai aussi connu ce problème, après avoir installé Lnssvc 1.02, j'avais 2 icones de LNS dans la barre des tâches, mais lorsque j'ouvrais les logiciels il y en avait un des 2 qui n'avait pas le filtrage logiciel en mémoire. J'ai depuis désinstaller le pare-feu à cause de plantage avec la passerelle internet mais je l'ai gardé en version d'essai sur le 2ème PC. Je n'ai malheureusement pas trouvé de solution, c'était juste pour apporté un complément d'information, j'espère juste avoir été suffisamment clair.

    A plus.
     
  10. General Noel

    General Noel Registered Member

    Joined:
    May 3, 2005
    Posts:
    68
    Merci Ricou pour ton témoignage... au moins je me sens moins isolé sur le problème ;)
    Cela dit, j'ai désinstallé puis essayé de réinstaller LnSSvc sans amélioration :oops:. Je ne sais plus quoi essayer, de ce fait, je crois que je vais totallement désinstaller LnSSvc et remettre le "Démarrage auto : systeme" dans les options.

    Maintenant si quelqu'un qui lit ce thread a une solution, ce serait bien d'en faire profiter la communauté !!
     
  11. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Et pour les quelques confirmations que je demandais plus haut ?

    Merci,

    Frédéric
     
  12. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Attention, un cas fréquent (c'est arrivé à de nombreuses reprises) était d'avoir laissé un démarrage automatique dans la config de l'un des Look 'n' Stop de l'un des utilisateurs.
    Pour être sûr que ce n'est pas cela, il faut faire la manip de vérif de la base de registres et la manip d'arrêt du service (comme indiqué plus haut) puis reboot pour voir que Look 'n' Stop ne se lance plus du tout.

    Pour General Noel, ok il semble que tout cela soit vérifié. Mais pour vous aviez-vous fait ces vérifications ?

    Frédéric
     
  13. General Noel

    General Noel Registered Member

    Joined:
    May 3, 2005
    Posts:
    68
    :eek: OOps j'avais oublié la question de Frédéric ... Oui c'est bien une fermeture complète de session !!!

    Bref, j'ai fini par revenir en mode "normal" (Démarrage Auto : Système) et désenregistré le service LnSSvc.

    Je laisse quand même le firewall de XP-SP2 qui fera quand même office de blocage lorsque mes sessions seront fermées..

    D'autres idées ? Je suis preneur ;)
     
Thread Status:
Not open for further replies.