lns2.06 cpu usage up to 90% with emule running

Discussion in 'LnS English Forum' started by railrock, Mar 28, 2008.

Thread Status:
Not open for further replies.
  1. railrock

    railrock Registered Member

    Joined:
    Mar 28, 2008
    Posts:
    7
    My lns2.06 cpu usage up to 70-90% with emule running.
    Any tricks?
     
  2. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Probably the Look 'n' Stop log contains a lot of alerts, and CPU is used to block an high rate of incoming packets.
    Could you check the log when this happens, and how many lines per second are put there ?

    Frederic
     
  3. railrock

    railrock Registered Member

    Joined:
    Mar 28, 2008
    Posts:
    7
    Sorry I am green with LNS, I do not know how to check how many lines per second.
     
  4. shadek

    shadek Registered Member

    Joined:
    Feb 26, 2008
    Posts:
    2,363
    Location:
    Sweden
    Click the 'log'-tab. Check how many new entries that are made in the log per second (or try to estimate). :)

    Cheers!
     
  5. railrock

    railrock Registered Member

    Joined:
    Mar 28, 2008
    Posts:
    7
    And I found the log runs very fast while the download speed is high.
     
  6. railrock

    railrock Registered Member

    Joined:
    Mar 28, 2008
    Posts:
    7
    So, are there any ways to improve this?
     
  7. shadek

    shadek Registered Member

    Joined:
    Feb 26, 2008
    Posts:
    2,363
    Location:
    Sweden
    It might be that you're blocking too many connections - or the fact that you allow too many connetions in Emule. Is there an option to reduce the number of connections in Emule? If so, reduce the number and make sure you allow the legit connections in LnS.

    That's my advice, but Frederic might have different thoughts.
     
  8. railrock

    railrock Registered Member

    Joined:
    Mar 28, 2008
    Posts:
    7
    Thanks shadek, but if I cut the numbers of connections, the speed will be greatly hammered. There are really no solutions to this?
     
  9. shadek

    shadek Registered Member

    Joined:
    Feb 26, 2008
    Posts:
    2,363
    Location:
    Sweden
    Under the 'log'-tab... there's a button named 'connections'. How many connections is there to your computer? If there's not too many, you won't have to reduce the connections in Emule.
     
  10. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Yesn, the solution is to understand what are these lines in the log. Then additional rules are required, to accept more ports, or to still block packets, but in a silent way.
    We need an extracy of your log, to see what happens exactly.

    Did you modify the standard ruleset you are using ?
    It happens sometimes users select the log attribute (the '!') on the rule "TCP: Allow standard connections", and since this rule is to accept packets, it creates a lot of log entries for nothing.

    Regards,

    Frederic
     
  11. railrock

    railrock Registered Member

    Joined:
    Mar 28, 2008
    Posts:
    7
    I just used the Enhanced rule and import the BT the rule.
    Here are the logs,
     

    Attached Files:

  12. railrock

    railrock Registered Member

    Joined:
    Mar 28, 2008
    Posts:
    7
    I just drop the ! before the rule for bt and emule and it work fine.
    Hope this lower the security level.
    Thanks guys for your helps.
     
  13. shadek

    shadek Registered Member

    Joined:
    Feb 26, 2008
    Posts:
    2,363
    Location:
    Sweden
    Very nice. :)
     
  14. 1hui

    1hui Registered Member

    Joined:
    Aug 9, 2007
    Posts:
    54
    only a few ! before the rules are kept by me.Then there will be less logs
     
Thread Status:
Not open for further replies.