LNS service/driver name ?

Discussion in 'LnS English Forum' started by ooops, Jan 7, 2005.

Thread Status:
Not open for further replies.
  1. ooops

    ooops Registered Member

    Joined:
    Jan 6, 2005
    Posts:
    3
    I have used kerio PF before 2.1.5 , but it got abandoned, and their new version is really ...not good. LNS looks and feels much much better:)
    I am trying it now on
    Windows xp hone SP2. I got issue with home network (yeah yeah I saw a lot of posts about it) - file\printer sharing etc. I've read and tried advices about importing sharing.ie rules, about applying NAVRegPatch, about enabling NetBIOS or 445. Nothing worked so far. I guess I need to start from the beginning - understanding of the LNS :)
    So, I have basic question:

    1. What service/driver performs firewalling?
    I installed LNS with option - "NOT to start automatically when Windows starts." but as soon as system rebooted to complete installation - file sharing stops working.
    As soon as LNS unistalled with system reboot files sharing works again.

    2. Is there way to tell from the log if rule applied to stop
    packet or just reported this packet?
     
    Last edited: Jan 7, 2005
  2. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Hi,
    If you are encountering this issue, probably you have Norton Antivirus installed on your system.
    If this is the case, please apply the following patch and reboot:
    http://looknstop.soft4ever.com/Tools/NavRegPatch2.exe
    This will fix some registry key linked to the loading order of network driver, and should fix this specific issue.

    This will only fix the fact even with Look 'n' Stop stopped the file sharing no longer works.
    After that, to have this working with Look 'n' Stop active, you need to add some rules to allow MAC address or IP address to allow exchanges between PC on your local network.

    The services used by Look 'n' Stop are lnsfw.sys (SFILTER in the registry) and lnsfw1.sys (LNSFW1 in the registry).

    Yes, in the first column with the #, there is a - when the packet is blocked, a + when it is allowed.

    Regards,

    Frederic
     
  3. ooops

    ooops Registered Member

    Joined:
    Jan 6, 2005
    Posts:
    3
    Thanks for the reply.
    Yes I have NAV.
    When I ran patch it gives "Patch already there!" message ( I did it already before) and nothing happens, sharing does not work until LNS uninstalled. I found lnsfw1.sys in the device manager and tried to change it's Start property - to "Demand" didn't work. When I disabled it and rebooted, LNS couldn't do application filtering and I was not able to start lnsfw1.sys after that at all. Had to uninstall LNS once again.

    Is it possible that NAVRegPatch didn't work correctly?
    Can I uninstall patch or revert changes back, or verify everything manually?

    One more thing, I have wireless network adapter on this computer.
     
Thread Status:
Not open for further replies.