LnS 2.05b1 inactif au changement IP

Discussion in 'LnS French Forum' started by Croco, Dec 19, 2003.

Thread Status:
Not open for further replies.
  1. Croco

    Croco Registered Member

    Joined:
    Apr 23, 2003
    Posts:
    43
    Location:
    France
    Bonjour à tous,

    J'ai déjà signaler le problème avec le formulaire, mais ce matin j'ai constaté pour la 3ème fois l'incident depuis le passage en 2.05b1. Avec la 2.04sp2 ca marchait sans aucun pb.

    Lorsque l'IP Internet change, LnS deviens totalement inactif, en gros le PC n'est plus sécurisé :doubt: après avoir fait plusieur test, il s'avère qu'a chaques réattribution d'IP, la sélection automatique déjà sur le bon choix ne fonctionne plus, en décochant et remettant le même choix et en cliquant Appliquer cela repart.

    Est-ce que quelqu'un a le même problème ? Voir une solution, je veut bien testé quelques jours, mais d'ici a ne plus être protéger qd même pas ;)

    Mon système (serveur 24h/24) :
    Windows 2000 Pro SP4
    DirectX 9 / 512 Mo DDR
    ADSL Wanadoo sur carte Ethernet (Modem D Link DSL 300G+)
     
  2. Croco

    Croco Registered Member

    Joined:
    Apr 23, 2003
    Posts:
    43
    Location:
    France
    La perte complète du filtrage m'oblige de faire marche arrière et de remettre la version 2.04sp2, mais quel ne fut pas ma surprise de constaté que la version beta m'a bien arranger le système, désormais le problème est apparu sur une version qui ne ma jamais poser un seul ennuie depuis des mois, alors que puis je faire maintenant pour remettre LnS 2.04sp2 correctement et fonctionnel, le temps du beta test est fini pour moi :doubt:
     
  3. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Bonjour,

    C'est peut être en définitive un problème qui n'est pas du à la 2.05b1 mais à un autre évènement externe.

    Si vous avez bien réinstallé la 2.04p2 comme préconisé dans le post d'annonce de la 2.05b1, la 2.04p2 est bien installée comme avant, et le faire d'avoir essayé la 2.05b1 n'a absolument aucune influence sur le comportement actuel de la 2.04p2.

    Que se passe t-il si vous forcez le choix de l'interface réseau au lieu de laisser en automatique ?

    Frédéric
     
  4. Croco

    Croco Registered Member

    Joined:
    Apr 23, 2003
    Posts:
    43
    Location:
    France
    Bonjour,

    Malgré le repassage en 2.04sp2, déinstallation complète comme indiquer, même j'ai fait encore plus pousser en supprimant des clés dans la base de registre rien a y faire, le problème viens du faite que LnS (2.04sp2 et 2.05b1) ne détecte pas assez rapidement la déconnection/reconnection ADSL, sur l'onglet Acceuil il reste Connecté sur internet toujours avec la même IP, quelque après l'IP ce mets a jour mais déjà tout le filtrage est inactif. En déactivant le résident pour la reconnection automatique, et en attendant que LnS détecte entre chaques déco/reco, le filtrage reste actif.

    Sinon, en laissant le choix forcer sur LnS Driver dans l'interface réseau, c'est exactement le même résutat.

    Je ferait d'autres tests dans l'après midi, mais j'en suis a 3 install de la 2.05b1 et 5 fois pour la 2.04sp2.

    Question toute bête a l'époque un patch correctif circulait, lorsque j'était en 2.04 je l'avait utiliser avec succès, c'est peut liée a ça, si qqu'un a toujours le lien pour le DL ;)
     
  5. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Normalement la 2.05 est sensée contenir tous les patchs qui ont existé sur la 2.04, donc c'est peu probable que ça résolve le problème.

    Pourriez-vous nous donner plus d'information sur ces séquences de déconnexion/reconnexion:
    - à quel moment elles interviennent ?
    - est-ce que l'adresse IP change ?
    - quel est le résident dont vous parlez et comment intervient dans la manip ?

    Sinon, en revenant à votre premier post, quelques autres questions:
    - comment constatez-vous que Look 'n' Stop devient complètement inactif ?
    - Parlez-vous bien du filtrage internet ?

    Lors d'une séquence de déconnexion/reconnexion qui ne marche pas, il serait intéressant d'avoir le contenu de la fenêtre console (avec la 2.05 qui contient plus d'info lors de ces phases).
    Si vous refaites des tests, choisissez en dur l'interface à filtrer (au lieu du mode automatique), ça simplfiera l'investigation et éliminera d'autres problèmes éventuels.

    Merci,

    Frédéric
     
  6. Croco

    Croco Registered Member

    Joined:
    Apr 23, 2003
    Posts:
    43
    Location:
    France
    Voici la réponse aux questions, je travail encore en se moment sur la version 2.04ps2 que je n'arrive pas a stabilisé, étant donner que le problème est le même que la 2.05b1, je vais migrer a nouveau ré-installer la 2.05b1 pour approfondir les tests.

    [tt]Pourriez-vous nous donner plus d'information sur ces séquences de déconnexion/reconnexion:
    - à quel moment elles interviennent ?[/tt]
    Au bout d'environ 24h de connexion, Wanadoo fait un reset qui m'occasionne la dite déconnexion, j'ai constaté le problème chaques matin après une déconnexion programmé vers 6h00, après je suis carrément passé a du test en déconnectant volontairement pour voir le comportement de chaques éléments.

    [tt]- est-ce que l'adresse IP change ?[/tt]
    L'adresse IP afficher dans l'onglet Accueil LnS ne change pas imédiatement, de même qu'il faut un certains temps d'attente pour que LnS détecte la déconnexion et donc décoche la croix, ceci dit l'IP est corriger après 15sec après une nouvelle connection, mais déjà le FW ne semble plus assurer le filtrage dès ce manque de syncro.

    [tt]- quel est le résident dont vous parlez et comment intervient dans la manip ?[/tt]
    Pour la reconnexon automatique j'utilise Casc'ADSL (http://cascadsl.free.fr) en service sous W2K, le soft contrôle par des pings que la liaison est toujours valide, si ce n'est pas le cas il effectue une reconnection. J'ai pas trop idée comment le soft fonctionne, mais en tout cas la détection est très rapide de l'ordre de la seconde. J'ai tenté d'utiliser ADSL Autoreconnect, ce dernier fonctionnait aussi très bien il y a 3 mois avant mon passage a Casc', ben c'est le même résultat et ce aussi bien en client que service.

    [tt]Sinon, en revenant à votre premier post, quelques autres questions:
    - comment constatez-vous que Look 'n' Stop devient complètement inactif ?[/tt]
    Ayant souvent des pings et des paquests entrants TCP, j'ai vite été suppris de voir la log si vide, j'ai aussitôt testé un FTP perso d'un amis qui demande la saisie de son IP perso dans une règle pour passer, ben je me suis connecté directement, la j'ai compris que je n'était plus derrière le FW, j'ai testé dans l'affiler sur GRC, c'était confirmer, LnS en route tout coché mais le filtrage internet actif était devenu inactif.

    [tt]- Parlez-vous bien du filtrage internet ?[/tt]
    Oui, l'onglet filtrage internet qui est bien actif mais qui ne réagit plus du tout, je test directement en ligne sur GRC pour constaté si mes post son open/closed ou stealth

    Voilà, j'espère que mes réponses pourront aider, enfin pour le moment je semble être le seul :(

    Au cours de mes tests, j'ai constaté une chose étrange, le filtrage ne semble pas totalement arrêter des moments certains paquets son filtré comme les ports 137 (surmement le réseau local) a noté que l'interface est toujours LnS Driver.

    Prochain message avec log de la console.
     
  7. Croco

    Croco Registered Member

    Joined:
    Apr 23, 2003
    Posts:
    43
    Location:
    France
    Voici le contenue de la fenêtre console de LnS 2.05b1, j'ai effectué 2 déco vonlontaire, dès que le bouton Appliquer est utilser, le filtrage reprend normalement.

    [17:26:14] Adapter modified
    (IP) - Look 'n' Stop Driver - 2e:ad:20:52:41:53
    Intel(R) PRO/100 VE Network Con - 00:0a:e6:00:53:12 - 192.168.0.1
    Carte Realtek RTL8139(A) PCI Fa - 00:50:22:40:18:16 - 10.0.0.10
    [17:26:14] Ordinateur connecté à Internet sur: 81.51.211.81.
    [17:27:04] Adapter modified
    (IP) - Look 'n' Stop Driver - 2e:ad:20:52:41:53
    Intel(R) PRO/100 VE Network Con - 00:0a:e6:00:53:12 - 192.168.0.1
    Carte Realtek RTL8139(A) PCI Fa - 00:50:22:40:18:16 - 10.0.0.10
    [17:27:04] Ordinateur connecté à Internet sur: 217.128.4.109.
     
  8. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Est-ce bien un cas, où cela n'a pas marché ?

    A quel moment est affichée la ligne "[17:26:14] Adapter modified" ?
    Juste au moment de la déconnection ? ou un peu plus tard ? ou quand ça redétecte la connexion ?

    Je suis surpris qu'il n'y ait aucun "Ordinateur non connecté à Internet." ou "Ordinateur connecté à Internet sur: XXX".

    Qu'entendez vous par "dès que le bouton Appliquer est utilser, le filtrage reprend normalement" ?
    il s'agit du bouton Appliquer de Look 'n' Stop ? si oui pourquoi intervient-il dans la manip de déconnexion ?

    Je viens de faire un essai de déconnexion/reconnexion rapide, qui m'a aussi changé l'IP, et je suis tombé dans quelques problèmes également, mais ils semblent différents des votres (pour moi ça continue à filtrer mais les règles n'ont pas été mises à jour avec la nouvelle IP donc ça bloque là où ça ne devrait pas).

    Merci,

    Frédéric
     
  9. Croco

    Croco Registered Member

    Joined:
    Apr 23, 2003
    Posts:
    43
    Location:
    France
    Cette log console a bien été prise lorsque le problème de filtrage apparait. La ligne "[17:26:14] Adapter modified" est quasiement instantané après la reconnection, j'avais la console d'ouverte au moment du test, ceci dit la transition est tellement rapide que LnS n'indique pas "Ordinateur non connecté à Internet."

    Lorsque le problème de filtrage est présent, je peut très bien le rendre actif en validant un des 2 boutons Appliquer (Filtrage Internet ou Options) que je rend utilisable en faisant mine d'éditer une règle alors que je ne change rien.

    Sinon concernant votre essai, ca doit être du même ordre que moi, j'ai aussi quelques règles qui semble je ne sais pas pourquoi active, mais ce n'est pas l'intégralité du jeu.

    Suggestion toute bête, si LnS détecte "Adapter modified", cela sous entend changement IP, donc pourquoi ne pas forcé LnS a passer aussitot Ordinateur non connecté à Internet, pour qu'il puisse bien repartir en Ordinateur connecté à Internet.
     
  10. Croco

    Croco Registered Member

    Joined:
    Apr 23, 2003
    Posts:
    43
    Location:
    France
    Manifestement je ne suis pas le seul a rencontré le problème, sur le froum Anglais quelqu'un parle également d'une perte de la protection.

    http://www.wilderssecurity.com/showthread.php?t=18429
     
Thread Status:
Not open for further replies.