Livecd & ethernet connections

Discussion in 'other security issues & news' started by chattycathy, Apr 12, 2013.

Thread Status:
Not open for further replies.
  1. chattycathy

    chattycathy Registered Member

    Joined:
    Nov 8, 2005
    Posts:
    226
    Is there an ethernet friendly livecd out there that will work? I have been using livecd's for some time and have never had a problem until I got a new computer with Windows 7 Pro SP1. I have tried different versions of Ubuntu and none of them will connect to the internet. The Ethernet light on my dsl modem doesn't light up when I boot from livecd but if I boot into Windows, it works fine. I have did a search and it sounds like it is a problem with Ubuntu and Windows 7 but this new version, 12.04.2 doesn't work either. Any suggestions on what might work?
     
  2. lotuseclat79

    lotuseclat79 Registered Member

    Joined:
    Jun 16, 2005
    Posts:
    5,097
  3. chattycathy

    chattycathy Registered Member

    Joined:
    Nov 8, 2005
    Posts:
    226
    Thanks Tom for your suggestion but it didn't work either. It's like Ubuntu isn't loading the Ethernet driver or it isn't compatible one and I don't know which it is, if either. But, thanks again for your suggestions and feel free to offer more if you think of any. Kathy
     
  4. lotuseclat79

    lotuseclat79 Registered Member

    Joined:
    Jun 16, 2005
    Posts:
    5,097
    As it so happens, yes I do.

    In the past I have run into the problem of Ubuntu device management on bootup assigning device names for NICs (Network Interface Cards) one that has a driver and one that doesn't given the case of multiple NICs in the system - which occured when I changed the Motherboard in my system and a new NIC was installed. This problem is similar in nature to the past problems with Ubuntu releases regarding device name assignment to hard drives getting different names than expected on bootup that caused problems with scripts I had written with fixed device names.

    Run the ipconfig command under Win7 which should tell you the HWaddr of the NICs (Network Interface Cards) in your system. Write it down.

    As a comparison, you may want to use an earlier Ubuntu Live CD that worked before you inspect the Ubuntu 12.04.2 Live CD with the following steps.

    In Ubuntu 12.04.2, ifconfig is the command that normally outputs the HWaddr of the ethernet card(s) in your system.

    When there is no connection - i.e. network not enabled in Ubuntu then at most you might not get the eth0 or eth1 outputs from the ifconfig command, but only the lo (loopback) interface.

    Next, inspect the following two files in Ubuntu:

    /etc/network/interfaces
    and
    /etc/udev/rules.d/70-persistent-net.rules

    Oftentimes, if you have more than one NIC in your system the one that does not have a driver is the one that on boot up gets assigned the eth0 address - exactly what is not going to work. This problem is similar in nature to past problems Ubuntu has had with some of their earlier OS version releases with regard to device management assignment of hard drive device names.

    In that case, it is necessary to do a workaround that requires disabling the network at bootup (I simply turn off my router to disable detection of the network at bootup) to make some modifications in the above two files in Ubuntu prior to enabling the network.

    The contents of /etc/network/interfaces (in my system) is:
    auto lo
    iface lo inet loopback
    auto eth0
    iface eth0 inet dhcp

    In the /etc/udev/rules.d/70-persistent-net.rules file, it is necessary to make sure that the eth0 interface has the value of the NIC that works in your Win7 environment. So, what I suspect is that your system has two NICs, and the one that works is getting assigned the eth1 device name in this file at boot up. After editing the file to make sure that the eth0 line has the value of the NIC HWaddr that works in Win7, then it is necessary (as root) to make sure that the system (when networking is reenabled) won't overwrite the modified file, and to insure this you simply need to make that file unwritable with the chmod -w command.

    -- Tom
     
  5. chattycathy

    chattycathy Registered Member

    Joined:
    Nov 8, 2005
    Posts:
    226
    Ok, I have saved your last comment and I will try it later when I have more time. I've got guests coming today and may not get back to it until tomorrow. But, now I'm wondering if it's my system because, this morning I turned it on, Windows booted up but the ethernet light didn't come on. I turned my modem off, waited a few minutes and turned it back on and the ethernet light still didn't come on. I rebooted and tried it again and this time it worked fine. This activity rang a bell. It did this before and I went through the same procedure and then it was working again in Windows. I tried another modem before I rebooted and it didn't work either. When I reboot, it has worked in Windows each time. I have tried rebooting with the livecd over and over but it never works. Does this sound like a bad card? Thanks for your time.
     
  6. lotuseclat79

    lotuseclat79 Registered Member

    Joined:
    Jun 16, 2005
    Posts:
    5,097
    Have you tried turning the modem off/on with Ubuntu 12.04.2 in a similar way between reboots as you describe doing with Win7. Also, you can try booting up with the modem turned off and then turn it on several times vs. after a successful Wini7 boot with it on,

    As far as I know, Ubuntu Live CDs are set to detect an enabled network connection on boot, so if you can regress the Unity environment to Unity 2D or something resembling a gnome environment where the gnome panel is available and you can disable/enable the network with the icon on the top right of the panel would be the easiest way to control the process while turning the modem on/off during the testing process.

    You may need to install ubuntu-restricted-extras, gnome-session-fallback, and gnome-panel packages in the Ubuntu 2D choice at login if you do not see the earlier Ubuntu top panel to do some of the above to control the network enabling/disabling.

    This sounds like more of an intermittent problem than a bad card which could be happening for several reasons. Do try and investigate my previous message suggestions to see what you find as that may be one of the reasons you are encountering difficulties with Ubuntu. As for problems with Win7, stick with the modem that is known to work so that the number of variables between tests are minimized for comparisons.

    -- Tom
     
  7. chattycathy

    chattycathy Registered Member

    Joined:
    Nov 8, 2005
    Posts:
    226
    I have booted with the modem off and after Ubuntu has loaded, then turned the modem on, turned it off and back on, waited and then turned it off and waited again and turned it back on, booted with the modem on, but none of it has made a difference. I hope to be able to try the suggestions above today. I should have some time available to be able to try it today. I'll let you know how it goes. Thanks again!
     
  8. chattycathy

    chattycathy Registered Member

    Joined:
    Nov 8, 2005
    Posts:
    226
    I tried your suggestions and they didn't work either, but, I noticed it had wireless enabled, etc. This desktop has a wireless card, could this be my problem? My previous desktop didn't have a wireless card and it worked fine on every version I tried. Is it possible that because of the wireless card, it isn't loading properly for my modem because it thinks I'm using a router?
     
  9. lotuseclat79

    lotuseclat79 Registered Member

    Joined:
    Jun 16, 2005
    Posts:
    5,097
    Hi chattycathy,

    Ok, here is what I would try in that situation.

    If you have a wireless card, does the HWaddr of it show up in the ifconfig output? The main idea is to identify the HWaddr of the wireless card which you can also do by looking at the contents of the /etc/udev/rules.d/70-persistent-net.rules after you have booted up Ubuntu 12.04.2. Note: # is the root command prompt below.

    # ifconfig

    If so, you can issue the command:

    # ifconfig eth1 down
    where eth1 represents the wireless card from the previous ifconfig command's output, or whatever was assigned at bootup in the /etc/udev/rules.d/70-persistent-net.rules file.

    I would do this and then toggle the on/off for the modem to see what happens.

    -- Tom
     
    Last edited: Apr 15, 2013
  10. chattycathy

    chattycathy Registered Member

    Joined:
    Nov 8, 2005
    Posts:
    226
    I didn't find it. Do you think it would work and make it a lot simplier if I purchased a router? If not, I may as well accept the fact that I can't use a livecd with this machine. I really do appreciate all you have done in trying to get this worked out. Thanks a lot!
     
  11. lotuseclat79

    lotuseclat79 Registered Member

    Joined:
    Jun 16, 2005
    Posts:
    5,097
    I don't know that a router alone will fix the problem, but I definitely think that the wireless card may have something to do with it similar to the 2nd NIC that was added to my system when the motherboard was changed.

    BTW, what were the contents of the /etc/udev/rules.d/70-persistent-net.rules file vs what are its contents if you are able to boot a previous Ubuntu release that works or not?

    -- Tom
     
  12. chattycathy

    chattycathy Registered Member

    Joined:
    Nov 8, 2005
    Posts:
    226
    I couldn't get another version to boot. I tried 10.10 but it just hangs up on this machine. But, the 70-persistent-net.rules file contents of 12.04.02 is:

    # PCI device 0x1814:/sys/devices/pci0000:00/0000:00:1c.4/0000:03:00.0 (rt2800pci)
    SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="20:10:7a:ba:83:78", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"

    It just isn't going to work on this machine but thanks for trying to help me. Kathy
     
  13. lotuseclat79

    lotuseclat79 Registered Member

    Joined:
    Jun 16, 2005
    Posts:
    5,097
    If that is the only line in your /etc/udev/rules.d/70-persistent-net.rules then either you do or you don't have an ethernet NIC card in your new computer that would be capable of connecting to the dsl modem.

    What did the output of ipconfig on Win7 booted on the new computer say about eth0 or eth1 interfaces or did it just output wlan0 information?

    If its only output wlan0 information, then you might not have an ethernet NIC installed on your new computer which would explain why you are unable to connect to the dsl modem via that interface.

    There are some Linux commands that you can run to determine if you have an Ethernet NIC installed on your new computer (running under Ubuntu 12.04.2):
    For Kernel detected hardware:
    # dmesg # Detected hardware and boot messages
    # lsdev # information about installed hardware
    # dd if=/dev/mem bs=1k skip=768 count=256 2>/dev/null | strings -n 8 # Read BIOS
    Note: run sudo dd if=/dev/mem bs=1k skip=768 count=256 2>/dev/null | strings -n 8 | grep Ethernet
    or
    run the command: lspci | grep Ethernet
    It should tell you if you have Ethernet controllers installed for each Ethernet NIC installed in the computer.

    -- Tom
     
  14. chattycathy

    chattycathy Registered Member

    Joined:
    Nov 8, 2005
    Posts:
    226
    Although I do appreciate your help but to be honest, this is getting way over my head. I've fooled with computers for years but haven't gotten quiet that deep. My device manager shows an Atheros Ethernet Controller card is installed if that tells you anything. If it doesn't, then this is the link to the system I purchased: http://h10025.www1.hp.com/ewfrf/wc/..._r1002_usen_s-002_r0001&lc=en&product=5261651 Maybe this will answer your questions.
     
  15. lotuseclat79

    lotuseclat79 Registered Member

    Joined:
    Jun 16, 2005
    Posts:
    5,097
  16. chattycathy

    chattycathy Registered Member

    Joined:
    Nov 8, 2005
    Posts:
    226
    Thank you! I will certainly check it out!! I apologize for being so late in responding. For some strange reason, even though I have my settings in my profile set to message me when someone replies, I don't get them. I have to come and find my post and check it myself to see if someone has responded. I'm going to check your link out right now!!!! Thanks again!! I'll let you know!!!
     
  17. chattycathy

    chattycathy Registered Member

    Joined:
    Nov 8, 2005
    Posts:
    226
    I've tried and tried to download this file but it doesn't work for me. I get the "no such file" message, etc. I appreciate everything you've done. At least I know now why it doesn't work. I'll just have to forget about livecds until they decide to include this driver in their own package, if they ever do. Thanks!
     
  18. lotuseclat79

    lotuseclat79 Registered Member

    Joined:
    Jun 16, 2005
    Posts:
    5,097
    Hi chattycathy,

    I run a Live CD/USB version of Ubuntu 11.04, and I had no problem downloading the 1st link at the above URL I previously posted, i.e. http://media.cdn.ubuntu-de.org/forum/attachments/48/33/2666793-AR81Family-linux-v1.0.1.14.tar.gz which is a tar gzip'd file.

    The second link leads to a webpage that needs to be translated into English from German, but looks like it contains some commands for either natty or oneric that install some backported packages. Note: This is a link to the translated webpage.

    The file is there, so I don't know why you are getting a "no such file" reply to your attempts to download the file. I have all of my downloads set for download and save rather than open.

    The file is only 133.8 KB. You can contact me via private message if you need it to be emailed to you. I'll keep it on my system until I hear from you on this.

    -- Tom
     
    Last edited: Apr 18, 2013
  19. chattycathy

    chattycathy Registered Member

    Joined:
    Nov 8, 2005
    Posts:
    226
    I got the file to download but, I still couldn't get it to work for me. I'm quitting on this although I do appreciate everything you've done to try to help me. If it's going to be this complicated to get online with a livecd occasionally, it's not worth it to me. Thanks anyway.
     
  20. lotuseclat79

    lotuseclat79 Registered Member

    Joined:
    Jun 16, 2005
    Posts:
    5,097
    Hi chattycathy,

    I have been looking at your system's specifications at the link you gave in message #14.

    If you run the following command on Ubuntu 12.04.2:

    # lspci -vv | grep Atheros

    and it indicates that you have the following Ethernet controller:

    Ethernet controller: Atheros Communications Inc. AR8161 Gigabit Ethernet ( rev 08 )

    Note: AR8161 is the significant part

    Then you could very easily solve your problem with the following commands to get it working:

    $ sudo apt-get install linux-backports-modules-cw-3.4-precise-generic
    $ sudo modprobe alx

    and then bring up the interface afterward with:
    sudo ifconfig eth0 up && sudo dhclient eth0

    If this works for you, then after booting Ubuntu 14.04.2 Live CD every time, you would simply need to put these instructions in a script that you keep on either a CD or USB or on hard drive, and execute it once you have booted up Ubuntu 12.04.2 to get going.

    After all you have tried, I hope this works. If not, let me know what the ID is for your Ethernet Controller from the lspci command (as above), and if there is an easy way like the above available, I'll find it for you.

    Note: It is likely that the suggestion I gave you in message #15 did not work, because it was relevant to AR8151 instead of the AR8161 controller you have. My bad for not looking at your computer specification prior to giving advice.

    -- Tom
     
  21. chattycathy

    chattycathy Registered Member

    Joined:
    Nov 8, 2005
    Posts:
    226
    Ok, I got the lspci -vv | grep Atheros command to work. This is exactly how it was listed:
    04:00.0 Ethernet Controller: Atheros Commications Inc. AR8161 Gigabit Ethernet ( rev 08 )

    That was all that worked. I have been running commands in Windows and Dos but this system, I am completely green on so I may not have been doing something correctly if I was suppose to try the last commands you listed. Scripts is something I've never done either. I've heard of them but I've never tried them myself. I apologize for being so green at this but I don't mind learning and I appreciate your patience with me.
     
  22. lotuseclat79

    lotuseclat79 Registered Member

    Joined:
    Jun 16, 2005
    Posts:
    5,097
    In Ubuntu 12.04.2 Live CD, issue the following: Ctrl-Alt-T (i.e. hold down both the Ctrl and Alt key with left hand, and then press the T key)

    That should bring up a Terminal (command line window).

    Then issue the command: $ sudo -i
    in order to become root.

    Then try the commands I listed with the # prompt for root, and ignore the sudo on the other commands.

    The script would be the following lines for the script file init-atheros-8161.sh:
    #!/bin/bash -x
    sudo apt-get install linux-backports-modules-cw-3.4-precise-generic
    sudo modprobe alx
    sudo ifconfig eth0 up && sudo dhclient eth0
    exit

    Then issue the following command (as ubuntu) to make the script executable:
    chmod +x init-atheros-8161.sh

    Note: the -x at the end of the 1st line in the script logs the lines as they execute to the Terminal window

    Note: I usually run scripts from the command line as follows which implies that the script is in the current directory via using the './' before the script name:
    $ ./init-atheros-8161.sh

    Note: when done with root commands, issue the command: exit
    to become ubuntu (default user)

    -- Tom
     
    Last edited: Apr 20, 2013
  23. chattycathy

    chattycathy Registered Member

    Joined:
    Nov 8, 2005
    Posts:
    226
    I couldn't get that to work either. Either I'm too green for this or this hardware just isn't compatible with Ubuntu, no matter what. Thanks again for everything you've done.
     
  24. lotuseclat79

    lotuseclat79 Registered Member

    Joined:
    Jun 16, 2005
    Posts:
    5,097
    Hi chattycathy,

    The reason you may not have succeeded is probably that the file /etc/apt/sources.list needs to have some changes made to it in order to be able to download the driver, and then subsequently do an apt-get update command to reload the available package downloads for Ubuntu 12.04.2 from the Live CD environment - if that was the problem that caused you to not get it working - you did not give a detailed enough account of what did not work.

    So, I am making some changes to the /etc/apt/sources.list file (as root) in order to be able to make sure that it is possible for you to download the relevant driver that works. We already know what driver you need for your Ethernet Controller to make it work. Once I have succeeded in that, I will post the complete detailed changes you will need to make in the Ubuntu 12.04.2 Live CD environment to make it work.

    -- Tom
     
  25. lotuseclat79

    lotuseclat79 Registered Member

    Joined:
    Jun 16, 2005
    Posts:
    5,097
    A more direct way to download the driver file is to do the following.

    Visit the web page at:
    http://packages.ubuntu.com/precise/i386/linux-backports-modules-cw-3.4-precise-generic/download
    where you just click on the download link, i.e. the line that says:
    You can download the requested file from the pool/main/l/linux-meta/ subdirectory at:

    security.ubuntu.com/ubuntu <--- Click on this line
    which will allow you to download the .deb file:

    linux-backports-modules-cw-3.4-precise-generic_3.2.0.40.48_i386.deb

    Once you have downloaded the above .deb file, issue the command:

    $ sudo dpkg -i linux-backports-modules-cw-3.4-precise-generic_3.2.0.40.48_i386.deb

    in order to install it. Then issue the two commands:
    $ sudo modprobe alx
    $ sudo ifconfig eth0 up && sudo dhclient eth0

    and you should be good to go after you have checked the contents of the /etc/udev/rules.d/70-persistent-net.rules file to ensure that there is an entry line for eth0 in the file.

    Remember to save the .deb file above on some media, as it will be necessary to install the driver after each Ubuntu 12.04.2 Live CD reboot.

    -- Tom
     
Loading...
Thread Status:
Not open for further replies.