Linux RH FC3 and Firefox versions?

Discussion in 'other software & services' started by lotuseclat79, Jul 24, 2006.

Thread Status:
Not open for further replies.
  1. lotuseclat79

    lotuseclat79 Registered Member

    Joined:
    Jun 16, 2005
    Posts:
    5,094
    What is the latest version of Firefox compatible with Red Hat Fedora Core 3? Also, Fedora Core 5?

    I am running Linux Red Hat Fedora Core 3 (RH FC3) and the default Firefox version installed is ancient, i.e. v1.0.3.

    I have looked at the system requirements for Firefox which state:
    XFree86-3.3.6 or higher, gtk+2.0 or higher, libstdc++5 which I do not have installed, however, I do have: glibc 2.3.4 and fontconfig (aka xft) installed which do meet the minimum requirements.

    Does anyone know which versions of Firefox correspond to these system requirements that I do not have as in what version of Firefox will be compatible with them? Will it be the latest Firefox version or up to a certain version such as 1.0.7 on Linux RH FC3?

    Tia,

    -- Tom
     
  2. Lamehand

    Lamehand Registered Member

    Joined:
    Mar 2, 2006
    Posts:
    428
    Location:
    the Netherlands,very near to the North sea
    Can't you install those missing packages?, then you can run the latest version of FF with al the security fixes.

    Lamehand
     
  3. craigbass76

    craigbass76 Registered Member

    Joined:
    Jan 22, 2003
    Posts:
    72
    Location:
    Maine, USA
    Just yum -y update firefox and youshould get the browser with all the required dependencies.
     
  4. lotuseclat79

    lotuseclat79 Registered Member

    Joined:
    Jun 16, 2005
    Posts:
    5,094
    Hi Lamehand and craigbass76,

    Thanks for your replies.

    [Lamehand]
    That is the question! It is not clear that those packages can be installed on FC3 as the system requirements for Firefox do not explicitly mention specific Linux release compatibility.

    [craigbass76]
    yum list updates indicates that only v1.0.7-1.1.fc3 is available for FC3 - so, I guess that answers my original question save for FC5, leaving the door open for an answer yet on what Lamehand infers about installing the missing packages.

    -- Tom
     
  5. Lamehand

    Lamehand Registered Member

    Joined:
    Mar 2, 2006
    Posts:
    428
    Location:
    the Netherlands,very near to the North sea
    For what it's worth, i have never seen a specific version of firefox for every linux-distro that's out there, i have 1.5.0.4 installed here on Ubuntu Dapper.
    I could be wrong on this, but is FC3 so much different then Ubuntu in this regard?
    I have no experience with Fedora Core, but it's linux also.

    Greetz
    Abe
     
  6. craigbass76

    craigbass76 Registered Member

    Joined:
    Jan 22, 2003
    Posts:
    72
    Location:
    Maine, USA
    Wow, this took a while to get back to. You've probably fixed your trouble by now, but I'm guessing the problem is that Fedora gets end-of-lifed so quickly. I ran into this a couple weeks ago with FC4 and Firefox. I ended up getting the new version some other way (can't remember) but then decided it was time for FC5, only to realize that FC6 was coming out soon.
    Anyway, 1.5 is the current version now in FC5. Not sure about 6 and I don't know as I will find out. I may move to CentOS where support lasts longer; it will be at the cost of bells and whistles though. :(
     
Loading...
Thread Status:
Not open for further replies.