linux restore woes

Discussion in 'Acronis True Image Product Line' started by dorourke, Mar 8, 2005.

Thread Status:
Not open for further replies.
  1. dorourke

    dorourke Registered Member

    Joined:
    Mar 8, 2005
    Posts:
    2
    I am attempting to us TI8 to restore a linux system from an CD image. I have run into a number of problems. I am attempting to restore an image of a 38GB linux drive with 4 partitions, a boot partition, the Active Partition, a swap partition Primary, EXT3, the / or root OS partition,Primary, EXT3, and a data partition mounted to /var/opt also Primary, EXT3 to an unformated 58GB drive. If I attemp to restore the entire Disk, without resizing, I get an error the the media is damaged, although the media was verified as being clean. If I instead choose to restore individual partitions, after selecting and configuring one partition, when asked if I wish to restore another partition, If I answer yes, It won't let me restore to the available space on the drive. I am forced to restore one partition, exit, begin another restore session, restore the next partition, exit, etc, until all partitions are restored. For all partitions, I did not resize the partition, and kept them at the orig size. TI indicated that all restores had been successful, but the machine will not boot. I then tried the mbrautowrite utility, hoping that that would fix the problem but still no luck, just a black screen w/ a flashing cursor. PQmagic idicates that the partitions are configured correctly, ie, as Primary EXT3 partitions, with the boot partition active. Any help would be appreciated...
     
  2. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
    Hello dorourke,

    Thank you for choosing Acronis True Image (http://www.acronis.com/homecomputing/products/trueimage/).

    We are really sorry for the inconveniences.

    Could you please send the letter to support@acronis.com with the description of what Linux you use and especially what loader you use. We will try to help you with the loader installation.

    Thank you.
    --
    Ilya Toytman
     
  3. bouchecl

    bouchecl Registered Member

    Joined:
    Mar 10, 2005
    Posts:
    7
    I'm trying to figure out your partition table:
    /dev/hda1 /boot ext3
    /dev/hda2 / ext3
    /dev/hda3 swap swap
    /dev/hda4 /var/opt ext3

    It's not related to TI per se, but you should have setup your disk with 3 primary and an extended partition (and one or more logical). One never knows...

    Regarding your booting problem, I have a couple of questions:

    a) Do you use GRUB as a bootloader?
    b) When you installed your distro, did you set it to boot from the MBR?

    If you answer YES to both questions, try the following:

    1) Start with the Linux Rescue Disk from your favorite distro and enter Rescue mode (some disk will let you in directly in rescue mode; but if you use your regular installation disk, you might have to type 'linux rescue')
    2) select a language and keyboard layout.
    3) Mount your / partition (usually it mounts on /mnt/sysimage)
    4) at the shell prompt, change the root of your filesystem with the command
    'chroot /mnt/sysimage'
    5) type 'grub-install'
    6) Reboot.

    That might solve your problem.

    Hope it helps.

    Claude
     
Thread Status:
Not open for further replies.