Linux Login Password

Discussion in 'all things UNIX' started by Infected, Sep 12, 2018.

  1. Infected

    Infected Registered Member

    Joined:
    Feb 9, 2015
    Posts:
    868
    When I installed Mint, I selected to have login automatically. Is there a way to make it so I have to enter a password at welcome screen?
     
  2. Minimalist

    Minimalist Registered Member

    Joined:
    Jan 6, 2014
    Posts:
    9,542
    Location:
    Slovenia
    I have the opposite problem - I would like to auto login, but couldn't find a solution. I changed some configuration lines as suggested but it didn't work for me...
     
  3. fblais

    fblais Registered Member

    Joined:
    Jul 31, 2008
    Posts:
    1,125
    Location:
    Québec, Canada
    Which DE?
    In MATE, Control Center, then Login Window I think.
     
  4. Minimalist

    Minimalist Registered Member

    Joined:
    Jan 6, 2014
    Posts:
    9,542
    Location:
    Slovenia
    For me it's Linux Mint 17.3 Cinnamon and I can't enable it there.
     
  5. Infected

    Infected Registered Member

    Joined:
    Feb 9, 2015
    Posts:
    868
    I'm running Mint Cinnamon 19.

    I got it to work. I ran the Login Window tool from the Mint menu, switch to the Users tab and removed my username at the bottom where it says Automatic Login. Rebooted and my login was required.
     
  6. KeyPer4Life

    KeyPer4Life Registered Member

    Joined:
    Dec 18, 2013
    Posts:
    1,105
    So in Linux Mint 17.3 in login windows preferences under Auto login or Options tab
    there's no setting for you to use.

    NOTE: Automatic login will fail if the users home directory is encrypted.
     
  7. Minimalist

    Minimalist Registered Member

    Joined:
    Jan 6, 2014
    Posts:
    9,542
    Location:
    Slovenia
    Yes there is an option but I can't select original user created during OS install. There is no user to select from drop down menu. If I create another user than I can set this new user to auto-login.

    EDIT: I don't remember of encrypting anything.
     
  8. fblais

    fblais Registered Member

    Joined:
    Jul 31, 2008
    Posts:
    1,125
    Location:
    Québec, Canada
    I suggest you submit your problem on the Mint forums.
    Or maybe there's already something about this issue, I didn't check.
    https://forums.linuxmint.com
     
    Last edited: Sep 13, 2018 at 11:15 AM
  9. KeyPer4Life

    KeyPer4Life Registered Member

    Joined:
    Dec 18, 2013
    Posts:
    1,105
    When installing Linux Mint when you get to the user screen where you enter
    a name and password there is a box where you can check encrypt the home folder.
    By default it's unchecked. (not encrypted)

    Also LTS for Mint 17.3 ends next year so keep that in mind.

    I couldn't find anything concrete in a search for your situation.
    Post in Linux Mint forum as mentioned in this post or maybe someone
    here at Wilders will have an answer for you.

    It probably requires editing some file, then save it and reboot.

    Other alternative is to re-install Mint and select automatically login
    during the install process.
     
  10. Rules

    Rules Registered Member

    Joined:
    Mar 3, 2009
    Posts:
    584
    Location:
    Lugdunum
    try to edit your lightdm.conf :
    https://forums.linuxmint.com/viewtopic.php?t=252967

    Rules.
     
  11. Minimalist

    Minimalist Registered Member

    Joined:
    Jan 6, 2014
    Posts:
    9,542
    Location:
    Slovenia
    Thank you all for your answers. I'm using this system in Virtualbox and I'm planning to upgrade to newer version soon. So solving this problem is not that important to me.
    I tried to configure .conf file in past but after reboot I could not log in. I guess that I misconfigured something or indeed encrypted home folder during install.
    Again, thank you all for your help.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.