Ksnip - Make my screenshots pretty please

Discussion in 'other software & services' started by Mrkvonic, Dec 13, 2021.

  1. Mrkvonic

    Mrkvonic Linux Systems Expert

    Joined:
    May 9, 2005
    Posts:
    10,091
    A lick of paint, a lick of paint. Boom, pro image. Presenting, a review of Ksnip, a free, cross-platfrom image screenshot and annotation tool, covering basic usage, tabbed interface, text boxes, arrows, numbers, blur, stickers and watermark effects, various upload and editing options, other settings, and more. Enjoy.

    https://www.dedoimedo.com/computers/ksnip-review.html


    Cheers,
    Mrk
     
  2. Iangh

    Iangh Registered Member

    Joined:
    Jul 13, 2005
    Posts:
    842
    Location:
    Melbourne, Australia
    In Kubuntu how does one set Ksnip to open with rectangular area using PrtSc? The custom keyboard action "ksnip" opens it, but would like to open using rectangular area.
     
  3. Mrkvonic

    Mrkvonic Linux Systems Expert

    Joined:
    May 9, 2005
    Posts:
    10,091
    You mean assign the prtscn button to grab a rect area by default?
    Mrk
     
  4. chrisretusn

    chrisretusn Registered Member

    Joined:
    Jun 16, 2004
    Posts:
    1,568
    Location:
    Philippines
    Nice find. Just installed it. Only complaint, the text default was white. That had me puzzled for a few... LOL, albeit a very minor and fixable one. ;)

    I see this as nice supplement to Spectacle.
     
  5. Stupendous Man

    Stupendous Man Registered Member

    Joined:
    Aug 1, 2010
    Posts:
    2,393
    Location:
    the Netherlands
  6. vasa1

    vasa1 Registered Member

    Joined:
    May 1, 2010
    Posts:
    4,404
    One way to not have the shadow when "screenshotting" active windows is to toggle off compositing with Alt+Shift+F12, take the screenshot and toggle compositing back on.
    The other way, at least in Kubuntu 20.04 is to globally turn off the shadow effect in
    System Settings
    Application Style
    Window Decorations
    Theme and then click on the little pencil that shows up when you hover over the theme. (CAVEAT: I use the default Breeze, so I don't know how this would work with other window manager themes)
    In the popup window, there should be a Shadows tab with options to customize the color and dimensions of the shadow.

    BTW, I dislike Spectacle :D and don't use it. I get by with `scrot` for normal stuff on X11 (from my Lubuntu days).

    For a screenshot of the entire screen with a delay of 20s (to get a dropdown menu for example) I use:
    Code:
    scrot -d 20 $HOME/Pictures/"$(date +%Y%m%d%H%M%S)".png && paplay /usr/share/sounds/freedesktop/stereo/camera-shutter.oga
    To capture a region:
    Code:
    scrot --select $HOME/Pictures/$(date +%Y%m%d%H%M%S).png && paplay /usr/share/sounds/freedesktop/stereo/camera-shutter.oga
    And for an active/focused window:
    Code:
    scrot --focused --pointer $HOME/Pictures/$(date +%Y%m%d%H%M%S).png && paplay /usr/share/sounds/freedesktop/stereo/camera-shutter.oga
    The respective keybinds are
    Ctrl+Super+D (for delay)
    Ctrl+Super+I (for interactive)
    Ctrl+Super+A (for active)
     
  7. Stupendous Man

    Stupendous Man Registered Member

    Joined:
    Aug 1, 2010
    Posts:
    2,393
    Location:
    the Netherlands
    Thanks very much, vasa1.
    Disabling compositing was option 3 in the aforementioned Remove shadows in screenshots Dedoimedo article and the Alt+Shift+F12 toggle was mentioned in the Plasma is sluggish? Disable desktop effects article.
    It sure is an option. Although one could say it's rather annoying there's a need to toggle off compositing altogether because there's no option in Spectacle to toggle off the shadow effect.

    Thanks again, vasa1.
    That was mentioned in the "Remove shadows in screenshots" article, as well, but where the 2017 Dedoimedo article wrote, "You can only reduce the size to 6px, so you cannot fully get away with it", now in Kubuntu 20.04, I see the shadow size can be set to "None", so that is much better.
    But yet again, I think it is annoying there's a need to toggle a system setting because there is no option in Spectacle to disable the shadow effect.
    Such annoyance motivates me not to use Spectacle at all and use an alternative. For me that is Xfce4-screenshooter, and I can imagine using ksnip.
     
  8. vasa1

    vasa1 Registered Member

    Joined:
    May 1, 2010
    Posts:
    4,404
    I tried to figure out the appropriate shortcuts to take the type of screenshots I require but didn't get far. (I don't like having to open a GUI just to take a screenshot.) Anyway, I like ksnip for its annotation features, adding text, arrows, highlights, etc. The developer is also quite responsive.

    (For cropping, I like gwenview.)
     
  9. Iangh

    Iangh Registered Member

    Joined:
    Jul 13, 2005
    Posts:
    842
    Location:
    Melbourne, Australia
    Yes, please. I have set ctrl+shift+K as a custom shortcut to open Ksnip. In Ksnip's setting I have set ctrl+shift+L to open rectangular area. So two actions to take rectangular screenshot. Would be nice if it could be one as as I currently have with Flameshot, PrtSc --> flameshot full -p /home/ian --> rectangular screenshot.
     
  10. Mrkvonic

    Mrkvonic Linux Systems Expert

    Joined:
    May 9, 2005
    Posts:
    10,091
    Have a look in Plasma under menu > custom shortcuts > screenshots. Here you can set a shortcut key + trigger for rect area. This could actually be a nice tutorial ...
    Mrk
     
  11. Iangh

    Iangh Registered Member

    Joined:
    Jul 13, 2005
    Posts:
    842
    Location:
    Melbourne, Australia
    Tried that, couldn't figure out how to make it a one-step process like Flameshot. Look forward to your tutorial - as always.:)
     
  12. chrisretusn

    chrisretusn Registered Member

    Joined:
    Jun 16, 2004
    Posts:
    1,568
    Location:
    Philippines
    I don't see the shadow effect on any screenshots that I take. I just took several more to verify. Maybe you are referring to the "shadow" in the Spectacle window showing the screenshot. That is not part of the captured image.

    Code:
    Operating System: Slackware -current
    KDE Plasma Version: 5.23.4
    KDE Frameworks Version: 5.89.0
    Qt Version: 5.15.3
    Kernel Version: 5.15.7 (64-bit)
    Graphics Platform: X11
    Processors: 4 × AMD Phenom(tm) II X4 840 Processor
    Memory: 7.8 GiB of RAM
    Graphics Processor: GeForce GT 730/PCIe/SSE2
    Screenshot_20211215_150829.png
     
  13. Mrkvonic

    Mrkvonic Linux Systems Expert

    Joined:
    May 9, 2005
    Posts:
    10,091
    If you take a non-fullscreen windowed screenshot in Spectacle, there will be a large alpha border in the generated image. Won't be there if compositing is turned off.
    Mrk
     
  14. Stupendous Man

    Stupendous Man Registered Member

    Joined:
    Aug 1, 2010
    Posts:
    2,393
    Location:
    the Netherlands
    Oh, that is great.
    I suppose this is different in Slackware, compared to Kubuntu. (Or perhaps you changed settings for Application Style\ Window Decorations, or for Display and Monitor\ Compositor.)
     
  15. chrisretusn

    chrisretusn Registered Member

    Joined:
    Jun 16, 2004
    Posts:
    1,568
    Location:
    Philippines
    I am using Breeze for Appearance, Global, Application Style. Composting is on.

    One pressing Prnt Scrn? Take a New Screenshot? Active Window? Wndow under Cursor.?

    This is what I see in Spectacle. (screenshot taken by Ksnip)
    ksnip_20211216-154439.png

    This is the screenshot saved from Spectacle.
    Screenshot_20211216_154145.png

    What am I missing?

    This is a rectangle screenshot selected a area outside of the KCalc window.
    Screenshot_20211216_160450.png
     
    Last edited: Dec 16, 2021
  16. Mrkvonic

    Mrkvonic Linux Systems Expert

    Joined:
    May 9, 2005
    Posts:
    10,091
    Try with Spectacle, active window, include window borders and decorations.
    Mrk
     
  17. Stupendous Man

    Stupendous Man Registered Member

    Joined:
    Aug 1, 2010
    Posts:
    2,393
    Location:
    the Netherlands
    On Kubuntu 20.04 (with Breeze, shadows not disabled), when I use Spectacle, it doesn't matter whether or not I choose "Include window titlebar and borders", in both(!) cases the saved screenshots have shadows, visible when pasted on a white background (in LibreOffice Writer) (but hardly noticeable when viewed in Gwenview).
    When I copy chrisretusn's "screenshot saved from Spectacle" and I paste that on a white background, I see no shadow.
    So, something seems different with Spectacle in Slackware.
    Apologies if one finds we're way off topic in this ksnip thread.
     
  18. Daveski17

    Daveski17 Registered Member

    Joined:
    Nov 11, 2008
    Posts:
    9,874
    Location:
    Lloegyr
    I've been wanting to try this.

    ksnip1.jpg

    I've convinced it to save on my desktop as a jpeg.

    ksnip3.jpg

    Let the anorak fun begin ...
     
  19. chrisretusn

    chrisretusn Registered Member

    Joined:
    Jun 16, 2004
    Posts:
    1,568
    Location:
    Philippines
    Ah... I have those turned off. Yes it does indeed capture the whole thing. Thanks! I now know what I was missing.

    Screenshot_20211217_235140.png

    To stay on topic, ksnip it pretty handy. It's earned a spot as a favorite in Application Launcher. With it Global Hotkeys, I don't see a reason to attach it to Print Scrn. Here is an Alt+****+A screenshot same Active Window above.

    Screenshot_20211218_000150.png
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.