KDE 4.10.2: Snappy and lush operating system

Discussion in 'all things UNIX' started by apathy, Apr 14, 2013.

Thread Status:
Not open for further replies.
  1. apathy

    apathy Registered Member

    Joined:
    Dec 10, 2004
    Posts:
    461
    Location:
    9th Circle of Hell(Florida)
    I was a KDE3 fanboy and then moved to Gnome years ago. My problem with KDE was that it was bloated and brutally slow. Early KDE4 was a nightmare for me, with the flickering, crashing and taking forever to even boot it.

    KDE 4.10.2 is a breath of fresh air, it's faster and transitions between windows are smooth and swift. Everything is working great for me. My only beef is that there is still bloat, they need to streamline the settings.

    My favorite KDE distros are Opensuse, Manjaro, Chakra and Linux Mint.

    My two favorite operating systems right now are KDE & XFCE
     
  2. Hmm. I tried KDE 4.10 on OpenSuSE, and it still seemed awfully slow. Especially the startup process.
     
  3. moontan

    moontan Registered Member

    Joined:
    Sep 11, 2010
    Posts:
    3,931
    Location:
    Québec
    certainly does not feel as snappy as XFCE.

    i'm looking forward to a try a few Ubuntu derivatives after April 25.

    the new Gnomebuntu will be something to look forward to i think.
     
  4. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
  5. chrisretusn

    chrisretusn Registered Member

    Joined:
    Jun 16, 2004
    Posts:
    1,322
    Location:
    Philippines
    Got to agree that KDE 4.10.2 is pretty slick. I've been on KDE for sometime now. it getting better every with every update.
     
  6. moontan

    moontan Registered Member

    Joined:
    Sep 11, 2010
    Posts:
    3,931
    Location:
    Québec
    trying out Mint 14 KDE at the moment.

    it' s pretty nice indeed. :thumb:
     
  7. moontan

    moontan Registered Member

    Joined:
    Sep 11, 2010
    Posts:
    3,931
    Location:
    Québec
    couple of tips:

    if you are using proprietary video drivers switch to the "Native" mode in the Desktop Effects/Advanced/.
    set compositing to OpenGL and the Qt graphic system to Native.

    for fonts:
    go to Application Appearance/Fonts

    Enable anti-aliasing, and in the Configure:
    * check Use sub-pixel rendering
    * RGB
    * Hinting style = Slight
    * back to the main tab: check Force fonts DPI, set to: 96

    this should be checked for and applied to every KDE distro you try/use.
     
    Last edited: Apr 16, 2013
Loading...
Thread Status:
Not open for further replies.