Jetico 1.0.1.61 as a service with NT Wrapper, applying correct policy??

Discussion in 'other firewalls' started by tama40, Jun 27, 2007.

Thread Status:
Not open for further replies.
  1. tama40

    tama40 Registered Member

    Joined:
    Jun 27, 2007
    Posts:
    3
    Hi,

    Have read the the threads regarding how to start Jetico 1.0.1.61 as a service and not as an app. Have used NT Wrapper Lite to do the job. It works, but I have a serious issue with that. Everytime Jetico is started as a service the default ruleset/policy is used!
    Normally I am logging into Windows with a created administrator account. When modifying the rules/policys in Jetico, the policy is always saved in
    C:\Documents and Settings\<my account>\Application Data\Jetico Personal Firewall\1.0.

    How can i get NT Wrapper to load Optimal.bcf from the above location??

    Thanks in advance.

    /Per
     
  2. tama40

    tama40 Registered Member

    Joined:
    Jun 27, 2007
    Posts:
    3
    Have now solved the issue.
    After I once again had NT Wrapper to start the JPF service, I took a look in the JPF settings via the menu,, Options->General.
    Saw that the policys that were loaded were located in "C:\Documents and Settings\NetworkService\Application Data\Jetico Personal Firewall\1.0"
    Very strange,, becuase the folder "NetworkService" was not visible from the explorer/directory structure...!
    I couldn't find it at all.

    Anyway, I copied my modified Optimal.bcf from my local account directory
    (C:\Documents and Settings\<my account>\Application Data\Jetico Personal Firewall\1.0) , into a directory reachable from the "File->Open" menu in JPF.
    Then I made that loaded policy as default. Reloaded the PC, and now everything is fine, and I have protection for my PC without logging into Windows
     
Loading...
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.