Java Installation Problems !!

Discussion in 'other software & services' started by Hard Rocker, May 20, 2005.

Thread Status:
Not open for further replies.
  1. Hard Rocker

    Hard Rocker Registered Member

    Joined:
    Jan 27, 2005
    Posts:
    258
    Location:
    Quebec, CANADA
    Hi, :D

    I recently installed the K-Meleon 0.9 Browser & today I was informed that for certain sites to appear as they should I would need Java 1_5 in my plugins folder.

    I have no problem with the initial download ....... either to my desktop ........ or my K-Meleon plugins folder. The problems start when I open Java to perform the actual install !! :(

    The actual Wizard never appears ....... instead a small rectangular " windows is preparing to install panel " appears and freezes on my desktop. When my mouse is placed over this panel the " hourglass " remains constantly and won't go away. I have let it sit for as long as 20 minutes and nothing changes. The only choice in this small panel is " cancel " ......... when I choose cancel the panel still remains & does nothing as well.

    I have to reboot each time to remove this " frozen panel " from my desktop.

    There is nothing blocking the install as far as I know ..... my firewall is configured & when my A2 Guard appears, to block the install, I choose ......... allow program ...... yet always the same results. o_O

    Thoughts or ideas anyone ?
    HR :cool:
     
  2. ronjor

    ronjor Global Moderator

    Joined:
    Jul 21, 2003
    Posts:
    57,719
    Location:
    Texas
    This refers to an older version of Java but still applies.

    Something is blocking your install of Java.


    How do I enable Java in K-Meleon?

    You must first install the Java Runtime Environment (JRE) to run Java applets in K-Meleon. You can download JRE 1.4 from http://java.sun.com/j2se/1.4/download.html. After you install JRE, K-Meleon automatically detects your JRE installation and no other configuration is necessary. To see if JRE is properly installed, type about:plugins in the URL bar. If you see Java Plug-in listed, K-Meleon properly recognizes the JRE.

    Note: If you change the User Agent/Browser Identification, Java may not work.
     
  3. nick s

    nick s Registered Member

    Joined:
    Nov 20, 2002
    Posts:
    1,430
    Hi Hard Rocker,

    I don't use A2, but have you tried the JRE install with the Guard disabled? From my experience with JRE installs and Process Guard (enabled), quite a few executables/processes are actually involved in the install. Disabling the A2 Guard would be the first thing I would look at.

    Nick
     
    Last edited: May 20, 2005
  4. Hard Rocker

    Hard Rocker Registered Member

    Joined:
    Jan 27, 2005
    Posts:
    258
    Location:
    Quebec, CANADA
    Thanks once again Ron, :)

    I typed in .... about:plugins as you suggested and appears as if Java 1.4 ....... along with numerous other Java listings are already there. As a matter of fact JRE v1.4.2_06 appears in my add / remove programs also.

    I didn't have any problems with this message appearing in K-Meleon before until I visited Guenter's Site ( one of the KM Builders ) & was advised to install JRE v1.5.

    I will check out your links ..... but I still don't understand why the later v1.5 JRE won't install or update the older version. o_O

    Regards,
    HR :cool:
     
  5. ronjor

    ronjor Global Moderator

    Joined:
    Jul 21, 2003
    Posts:
    57,719
    Location:
    Texas
  6. Hard Rocker

    Hard Rocker Registered Member

    Joined:
    Jan 27, 2005
    Posts:
    258
    Location:
    Quebec, CANADA
    Hi Nick, :)

    Your post " snuck in " just ahead of my reply to Ron so if you check above you'll see things appear to be OK. I do have JRE 1.4 enabled in K-Meleon ...... although I would not have known without Ron's advice of typing in about:plugins in the KM URL Bar !!!

    Yes, I did try the install with the A2 Guard disabled & still had / have the problem. o_O

    As above ....... I still don't understand why the v1.5 JRE will NOT install. :doubt:

    Thanks.
    HR :cool:
     
  7. Hard Rocker

    Hard Rocker Registered Member

    Joined:
    Jan 27, 2005
    Posts:
    258
    Location:
    Quebec, CANADA
    Ron, :)

    I actually have two versions of Java Runtime Environment in my add/remove programs :

    1) v1.4.2_03
    2) v1.4.2_06

    Since my PC was purchased from DELL ..... several months ago I was advised by one of their tech support reps to leave BOTH versions on my PC ..... when speaking with him about a Pest Patrol F/P detection within the 1.4.2_03 version of JRE.
    He advised me to simply " Exclude " the PP F/P detection. As well, I now realize that PP provides more F/P's than anything. ( But that's another story ). :(

    I do realize that with MOST programs an uninstall is usually performed before installing the latest version. This is generally the " norm " so to say !!

    My concerns at this point would be that since there did NOT appear to be any problem installing the second version of JRE while the first was obviously still installed ...... if I proceed to delete these 2 versions, and continue to have problems installing the newer JRE v1.5 ....... I'll really be " up the creek " .

    The link to the Java Forum should prove to be very useful. :D

    Thanks Again,
    HR :cool:
     
Loading...
Thread Status:
Not open for further replies.