Is Facebook being sneaky to non-users?

Discussion in 'privacy general' started by 59er, Dec 16, 2015.

  1. 59er

    59er Registered Member

    Joined:
    Mar 28, 2014
    Posts:
    43
    Location:
    Oregon
    I have never signed up with Facebook, however there are a couple of public pages that are viewed for organizations I'm involved with. A couple of days ago, trying to view those pages became impossible. I went to a few more public pages, same problem.
    With Firefox, Vivaldi, Opera, and Slimjet as soon as I tried to scroll down the page with the slider, the page filled with a sign-up form. With Opera beta, it was a little different. A third of the page was blocked with a black sign-up area. As you move the slider, the page is eventually completely blocked by the sign-up page.
    I played around with settings and found the problem was related to Javascript. I added exceptions to block Javascript (except for Firefox) for the Facebook pages and all is back to normal.
    If Facebook known for doing things like this?
     
    Last edited: Dec 16, 2015
  2. amarildojr

    amarildojr Registered Member

    Joined:
    Aug 8, 2013
    Posts:
    1,989
    Location:
    Brasil
    Have you ever head of uBlock Origin or AdBlockPlus? :)
     
  3. 59er

    59er Registered Member

    Joined:
    Mar 28, 2014
    Posts:
    43
    Location:
    Oregon
    Using UBlock O on most browsers. Using default blocker on Slimjet. Using Adguard on Vivaldi for now (had problems with UBlock O). This was a new problem. First solution, adding Javascript exceptions, worked. Didn't get around to playing with ad blockers. Cheers!

    Got curious regarding Firefox. Enabled UBlock Matrix and started disabling elements to find a fix.
    Disabling a cookie and an image related to www.facebook.com temporarily solved the problem with Fox. However, when I closed and re-opened the Facebook page it was not viewable at all. The 'image' box (had a 1 in it before) that I disabled was now empty. Will play some more.
    Would prefer a browser fix regarding Firefox, unfortunately there is no easy 'add an an exception to Javascript in the settings. Everything regarding Javascript is in about:config.
     
    Last edited: Dec 16, 2015
  4. 59er

    59er Registered Member

    Joined:
    Mar 28, 2014
    Posts:
    43
    Location:
    Oregon
    Problem solved in all browsers.
    The root cause was some junk that affected all browsers. When I ran CCleaner the problem was gone in Firefox. I ran Privazer for a more thorough cleaning. Cleaned SLimjet and Vivaldi separately. With Opera beta and Slimjet, I had to re-allow Javascript for Facebook. After cleaning, the pages were now blocked with Javascript blocked. With Opera stable the pages still worked with Javascript blocked. I deleted the exclusion anyway.
    Something odd happened. The last week, I only opened Facebook pages with Opera, yet after the problem existed in all browsers. Oh well..Cheers!
     
  5. Rasheed187

    Rasheed187 Registered Member

    Joined:
    Jul 10, 2004
    Posts:
    8,055
    Location:
    The Netherlands
    Actually, I see the same, seems like FB has changed something, it now bugs you with login screens, when you're not logged in. A very dumb idea, because it will annoy people. Just how dumb can companies be?
     
  6. mick92z

    mick92z Registered Member

    Joined:
    Apr 27, 2007
    Posts:
    499
    Location:
    Nottingham
    I'm having simila problems , especially from my mobile. I visit a facebook page that is about the town i live in, it is not an individual account.
    On my mobile I can only see the last two posts, then I am asked to log in.
    On my computer , I get asked to log in, or a get catchpa request and the page that slides up ( mentioned by op )
    I did actually create a couple of fake accounts to log in. One was disabled , and i was asked for proof of ID.
    The day i give facebook my real details is the day I stop using it
     
  7. 59er

    59er Registered Member

    Joined:
    Mar 28, 2014
    Posts:
    43
    Location:
    Oregon
    Opened Opera today and the sign-up thing was back on a public page. Cleared the cache and the page was visible again.
    I've seen three different versions so far. One is there when you open a page, second a full-screen sign-up form appears after you click on the slider and then release. My favorite is number 3, the bottom third of the page is covered in black, or white, and as you use the slider to move down the page the covered portion increases in size until the entire page is filled.
     
  8. inka

    inka Registered Member

    Joined:
    Oct 21, 2009
    Posts:
    408
    You should be able to find a greasemonkey (or scriptish) script that handles those nuisances.
    I've seen similar anti-blackout scripts for pinterest.com, quora.com etc.
     
  9. Rasheed187

    Rasheed187 Registered Member

    Joined:
    Jul 10, 2004
    Posts:
    8,055
    Location:
    The Netherlands
    Has anyone been able to block this annoying behavior? In Opera 12 this behavior is not present, but it is in FF. Which ABP filter should I use, to kill this pop-up? Here is a link where I get to see a sign in pop-up, but only in FF:

    https://www.facebook.com/halalfriedchicken.netherlands/
     
    Last edited: Jan 30, 2016
  10. inka

    inka Registered Member

    Joined:
    Oct 21, 2009
    Posts:
    408
    izzit truly a "popup", a javascript "alert"? (I'm not gonna click the link to find out)
    Maybe it's a "social toast" notification, a "feature" you can probably elect to disable in firefox via about:config
     
  11. Rasheed187

    Rasheed187 Registered Member

    Joined:
    Jul 10, 2004
    Posts:
    8,055
    Location:
    The Netherlands
    It hasn't got anything to do with malware, the site is safe. It's simply a new "feature" that FB has introduced, to bug people and to force them to login. Just how dumb can companies be, don't they know these type of things will eventually hurt their brand? They can go to hell as far as I'm concerned.
     
    Last edited: Feb 1, 2016
Loading...