Interactive service

Discussion in 'ESET NOD32 Antivirus' started by DavidCo, May 1, 2009.

Thread Status:
Not open for further replies.
  1. DavidCo

    DavidCo Registered Member

    Joined:
    Jul 9, 2005
    Posts:
    503
    Location:
    UK
    V4 latest installed
    Vista 32bit
    How do I turn off 'Allow service to interact with desktop'
    I get access denied.
     
  2. ThomasC

    ThomasC Former ESET Support Rep

    Joined:
    Sep 8, 2008
    Posts:
    209
    You will have to first boot into safe mode. Make the change then reboot back to normal mode.

    Cheers
     
  3. DavidCo

    DavidCo Registered Member

    Joined:
    Jul 9, 2005
    Posts:
    503
    Location:
    UK
    Thank you ThomasC
    I spotted this conflict in event viewer
    Eset AV asks to have 'interactive desktop' enabled.
    Seems a bit odd when Vista has 'interactive desktop' disabled by default because it is a security issue.

    o_O
     
  4. ThomasC

    ThomasC Former ESET Support Rep

    Joined:
    Sep 8, 2008
    Posts:
    209
    I was reading about the implications of the, “allow service to interact with desktop” settings. The way that the ESET Service operates along with the built-in self defense, prevents the service from being hijacked. Hence the risk of allowing the interaction is negated. However, I am glad I could be of assistance and have a great weekend.

    Cheers
     
  5. DavidCo

    DavidCo Registered Member

    Joined:
    Jul 9, 2005
    Posts:
    503
    Location:
    UK
    Thanks
    It is a pain tho' when you do the event viewer review.

    Feature request :- make it an option.
     
Thread Status:
Not open for further replies.