Insufficient free memory or disk space...

Discussion in 'ESET NOD32 Antivirus' started by De Hollander, Apr 12, 2010.

Thread Status:
Not open for further replies.
  1. De Hollander

    De Hollander Registered Member

    Joined:
    Sep 10, 2005
    Posts:
    718
    Location:
    Windmills and cows
    Performing a on-demand scan results in a "Insufficient free memory or disk space, or a problem with temp folders" error.

    So far, deleting and recreating the userprofile\temp and windows\temp folders with UAC enabled... Same problem.
    Trying version 4.0.474...same problem

    This solution

    http://www.eset.eu/knowledge-base/is-it-taking-an-unusually-long-time-to-scan-files

    or disabling UAC works.

    Besides disabling UAC or change the default permission for the Windows\Temp folder, any suggestion is welcome with this stubborn machine.

    4.2.40.10 (dutch) on a vista Home Premium SP2
     

    Attached Files:

  2. De Hollander

    De Hollander Registered Member

    Joined:
    Sep 10, 2005
    Posts:
    718
    Location:
    Windmills and cows
    Bump

    Nobody o_O
     
  3. Cudni

    Cudni Global Moderator

    Joined:
    May 24, 2009
    Posts:
    6,956
    Location:
    Somethingshire
    allow users write rights to temp folder as suggested. I looked on my install and user have that right (under Special right)
     
  4. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,411
    It's not clear for which user the permissions were displayed in screenshot 1 (c:\windows\temp) but it doesn't seem the selected user had full permissions to that folder.
     
  5. De Hollander

    De Hollander Registered Member

    Joined:
    Sep 10, 2005
    Posts:
    718
    Location:
    Windmills and cows
    Screenhot 1 shows the rights for the default user that logs in as administrator (Gebruikers\***\Gebruikers)





    If I give write rights everthing works. But i'm under the impression that normaly those rights are not the default settings. At least I haven't change them.

    After the reply from Cudni i'm starting to doubt if the settings are correct for this spare machine.

    These are the settings with elevated command prompt type:

    icacls c:\windows\temp


    c:\windows\temp NT SERVICE\TrustedInstaller:(I)(F)
    NT SERVICE\TrustedInstaller:(I)(CI)(IO)(F)
    NT AUTHORITY\SYSTEEM:(I)(F)
    NT AUTHORITY\SYSTEEM:(I)(OI)(CI)(IO)(M,WDAC,WO,GA,DC)
    INGEBOUWD\Administrators:(I)(F)
    INGEBOUWD\Administrators:(I)(OI)(CI)(IO)(F)
    INGEBOUWD\Gebruikers:(I)(RX)
    INGEBOUWD\Gebruikers:(I)(OI)(CI)(IO)(GR,GE)
    MAKER EIGENAAR:(I)(OI)(CI)(IO)(F)

    The frown smiley is the letter I
     

    Attached Files:

    Last edited: Apr 18, 2010
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.