Inconsistent Drive Labeling in B&R 10 and DB 10 WS

Discussion in 'Paragon Drive Backup Product Line' started by reedm, Nov 22, 2009.

Thread Status:
Not open for further replies.
  1. reedm

    reedm Registered Member

    Joined:
    Oct 26, 2009
    Posts:
    52
    I have noticed some inconsistencies in how both B&R 10 Free and DB 10 WS label attached USB devices. I have both a USB hard drive, which Windows sees as J: and a Sandisk USB CF card reader, which Windows sees as M: attached to my computer.

    With the hard drive attached, but not the USB CF card reader, I note the following behavior: B&R 10, Disk View- hard drive is labelled J:, Archives- hard drive has no label. DB 10 WS, Disk View, Vol Explorer-Disk Map Hard Drive is J:, in tree view at top of page, hard drive has no label. Archives-hard drive has no label.

    Now, if I just attach the Sandisk card reader, but without a card in it, I get the following changes, in both programs, any tree view now shows the hard drive as M: In disk views, it is correctly shown, as before, as J:

    Now, if I put a CF card in the Sandisk card reader, I get the following changes in both programs. In any Disk View, the card reader shows up as M: and the hard drive shows up as J: In any tree view, the card reader shows up as M: and the hard drive is now correctly labeled J:

    So I get correct drive labeling only if the card reader is connected and contains a card. Otherwise all bets are off. This is certainly not as bad as the crashes I experienced in earlier versions, but is something that could be and probably should be fixed.

    It is little things like this that make one wonder a bit about the robustness of other, more important features of the programs.

    Reed
     
  2. Howard Kaikow

    Howard Kaikow Registered Member

    Joined:
    Apr 10, 2005
    Posts:
    2,802
    The question is what drive letters are seen in Widows Explorer?

    Unless the progs use different drive letters than Windows Explorer, there is no problem.
     
  3. reedm

    reedm Registered Member

    Joined:
    Oct 26, 2009
    Posts:
    52
    As I indicated previously, Windows Explorer sees the USB hard drive as J: and it sees the Sandisk USB card reader as M:

    Thus the fact that the Paragon software sometimes sees the hard drive as M: is incorrect.

    I would note that, in Disk View, in the bottom pane, both applications always see the hard drive as J:. The card reader only appears in Disk View when it has a memory card in it. When it does appear, it is correctly labeled as M:.

    The problem lies in the tree view. This is where the erratic drive labeling occurs.

    Reed
     
  4. Howard Kaikow

    Howard Kaikow Registered Member

    Joined:
    Apr 10, 2005
    Posts:
    2,802
    Ayup.

    As I pointed out in other treads, I cannot evem ISTALL any of the Paragon backup products, unless I first disconnect the USB drives.

    So, the Paragon software is doing something strange with external drives.

    No such problems with Partition Manager.
     
Loading...
Thread Status:
Not open for further replies.